summaryrefslogtreecommitdiff
path: root/openembedded/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-06-12 12:47:18 +0000
committerRichard Purdie <richard@openedhand.com>2006-06-12 12:47:18 +0000
commit8a3e00ff657a8404aa6423dd3167b5611017b361 (patch)
tree31252a16e7904a1a7a70e93a5a7adf7e08c5ffff /openembedded/packages
parent156c652e216f9ee2ecc41376f6e59cfb5ac4515d (diff)
downloadopenembedded-core-8a3e00ff657a8404aa6423dd3167b5611017b361.tar.gz
openembedded-core-8a3e00ff657a8404aa6423dd3167b5611017b361.tar.bz2
openembedded-core-8a3e00ff657a8404aa6423dd3167b5611017b361.tar.xz
openembedded-core-8a3e00ff657a8404aa6423dd3167b5611017b361.zip
detect-stylus: Add for now until I teach udev how to do this instead
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@463 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch17
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch15
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch13
-rw-r--r--openembedded/packages/detect-stylus/detect-stylus_0.13.bb18
4 files changed, 63 insertions, 0 deletions
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch
new file mode 100644
index 000000000..cd8c52074
--- /dev/null
+++ b/openembedded/packages/detect-stylus/detect-stylus-0.13/access.patch
@@ -0,0 +1,17 @@
+Index: detect-stylus.c
+===================================================================
+RCS file: /cvs/gpe/base/detect-stylus/detect-stylus.c,v
+retrieving revision 1.12
+retrieving revision 1.13
+diff -u -r1.12 -r1.13
+--- detect-stylus.c 8 Sep 2004 15:57:15 -0000 1.12
++++ detect-stylus.c 9 Sep 2004 23:08:42 -0000 1.13
+@@ -131,7 +131,7 @@
+ XChangeProperty (dpy, root, atom, XA_INTEGER, 8, PropModeReplace, &b, 1);
+
+ XCloseDisplay (dpy);
+- if (!access("/usr/bin/xrdb", X_OK))
++ if (access("/usr/bin/xrdb", X_OK))
+ system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
+ else
+ system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/bin/xrdb -nocpp -merge");
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch
new file mode 100644
index 000000000..7c8213da1
--- /dev/null
+++ b/openembedded/packages/detect-stylus/detect-stylus-0.13/correct-theme-name.patch
@@ -0,0 +1,15 @@
+diff -urNd ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c detect-stylus-0.13/detect-stylus.c
+--- ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c 2004-09-08 16:56:58.000000000 +0100
++++ detect-stylus-0.13/detect-stylus.c 2004-09-13 21:36:03.000000000 +0100
+@@ -132,9 +132,9 @@
+
+ XCloseDisplay (dpy);
+ if (access("/usr/bin/xrdb", X_OK))
+- system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
++ system ("echo \"Matchbox.cursor: no\nXcursor.theme: xcursor-transparent\" | /usr/X11R6/bin/xrdb -nocpp -merge");
+ else
+- system ("echo \"Matchbox.cursor: no\nXcursor.theme: fully-transparent\" | /usr/bin/xrdb -nocpp -merge");
++ system ("echo \"Matchbox.cursor: no\nXcursor.theme: xcursor-transparent\" | /usr/bin/xrdb -nocpp -merge");
+ }
+
+ exit (0);
diff --git a/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch b/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch
new file mode 100644
index 000000000..94542b11a
--- /dev/null
+++ b/openembedded/packages/detect-stylus/detect-stylus-0.13/extra-device-check.patch
@@ -0,0 +1,13 @@
+diff -urNd ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c detect-stylus-0.13/detect-stylus.c
+--- ../detect-stylus-0.13-r1/detect-stylus-0.13/detect-stylus.c 2004-09-08 16:56:58.000000000 +0100
++++ detect-stylus-0.13/detect-stylus.c 2004-09-18 23:43:12.000000000 +0100
+@@ -62,6 +62,9 @@
+ if (fd < 0)
+ fd = try_open ("/dev/touchscreen/ucb1x00");
+
++ if (fd < 0)
++ fd = try_open ("/dev/ts");
++
+ if (fd < 0)
+ {
+ DIR *d;
diff --git a/openembedded/packages/detect-stylus/detect-stylus_0.13.bb b/openembedded/packages/detect-stylus/detect-stylus_0.13.bb
new file mode 100644
index 000000000..793cbef84
--- /dev/null
+++ b/openembedded/packages/detect-stylus/detect-stylus_0.13.bb
@@ -0,0 +1,18 @@
+inherit gpe pkgconfig
+LICENSE = "GPL"
+
+PR = "r2"
+
+DEPENDS = "libx11 xcursor-transparent-theme xrdb"
+SECTION = "gpe"
+RDEPENDS = "xrdb"
+
+DESCRIPTION = "Touchscreen detection utility"
+MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz \
+ file://access.patch;patch=1;pnum=0 \
+ file://extra-device-check.patch;patch=1 \
+ file://correct-theme-name.patch;patch=1"
+
+export CVSBUILD="no"