summaryrefslogtreecommitdiff
path: root/openembedded/packages
diff options
context:
space:
mode:
authorMatthew Allum <mallum@openedhand.com>2005-09-30 13:55:42 +0000
committerMatthew Allum <mallum@openedhand.com>2005-09-30 13:55:42 +0000
commitac134c081408c57fff89c79e1f4884e94d00ffeb (patch)
tree4fdc041c9ccb9abef00ee372d076b12b8bb81bbd /openembedded/packages
parentf33f340a9402f4ee9462bbd73c30085a4ac21b39 (diff)
downloadopenembedded-core-ac134c081408c57fff89c79e1f4884e94d00ffeb.tar.gz
openembedded-core-ac134c081408c57fff89c79e1f4884e94d00ffeb.tar.bz2
openembedded-core-ac134c081408c57fff89c79e1f4884e94d00ffeb.tar.xz
openembedded-core-ac134c081408c57fff89c79e1f4884e94d00ffeb.zip
Add 'home' button to panel hacks
git-svn-id: https://svn.o-hand.com/repos/poky@84 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop7
-rwxr-xr-xopenembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home2
-rw-r--r--openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb7
3 files changed, 15 insertions, 1 deletions
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop
new file mode 100644
index 000000000..4e08dfd37
--- /dev/null
+++ b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Home
+Comment=Home
+Exec=mb-applet-home
+Type=PanelApp
+Icon=xrandr.png
+Categories=Panel;Utility;MB
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home
new file mode 100755
index 000000000..74f422e7d
--- /dev/null
+++ b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home
@@ -0,0 +1,2 @@
+#!/bin/sh
+mb-applet-launcher -na -l --title "Home" mbdesktop.png matchbox-remote -d
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
index e7c1b4e64..804bcab55 100644
--- a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
+++ b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb
@@ -2,10 +2,12 @@ DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
DEPENDS = "matchbox xmodmap"
SRC_URI = "file://xrandr-panelapp.sh \
file://xrandr-panelapp.desktop \
+ file://mb-applet-home \
+ file://home-panelapp.desktop \
file://xrandr.png"
SECTION = "x11/wm"
PRIORITY = "optional"
-PR = "r4"
+PR = "r5"
LICENSE = "MIT"
do_install() {
@@ -15,4 +17,7 @@ do_install() {
install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
+ install -m 0755 ${WORKDIR}/mb-applet-home ${D}${bindir}/
+ install -m 0644 ${WORKDIR}/home-panelapp.desktop ${D}${datadir}/applications/
+
}