summaryrefslogtreecommitdiff
path: root/openembedded/packages
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2006-03-20 12:48:46 +0000
committerRoss Burton <ross@openedhand.com>2006-03-20 12:48:46 +0000
commitf12c6c68ddedec320f82c3c67c086541d4689722 (patch)
tree29090e63481e81f21783dc4373da987f044ca376 /openembedded/packages
parentb58756b169ea993487acbfdaea29d08baee936af (diff)
downloadopenembedded-core-f12c6c68ddedec320f82c3c67c086541d4689722.tar.gz
openembedded-core-f12c6c68ddedec320f82c3c67c086541d4689722.tar.bz2
openembedded-core-f12c6c68ddedec320f82c3c67c086541d4689722.tar.xz
openembedded-core-f12c6c68ddedec320f82c3c67c086541d4689722.zip
Add GLib 2.10.x
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@303 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb b/openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb
new file mode 100644
index 000000000..81ae84df0
--- /dev/null
+++ b/openembedded/packages/glib-2.0/glib-2.0_2.10.1.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "LGPL"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+DEPENDS += "glib-2.0-native gtk-doc"
+DEPENDS += "virtual/libiconv virtual/libintl"
+PACKAGES =+ "glib-2.0-utils "
+PR = "r1"
+
+LEAD_SONAME = "libglib-2.0.*"
+FILES_glib-2.0-utils = "${bindir}/*"
+
+EXTRA_OECONF = "--disable-debug"
+
+SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \
+ file://glibconfig-sysdefs.h"
+
+S = "${WORKDIR}/glib-${PV}"
+
+inherit autotools pkgconfig gettext
+
+python () {
+ if bb.data.getVar("USE_NLS", d, 1) == "no":
+ raise bb.parse.SkipPackage("${PN} requires native language support.")
+}
+
+acpaths = ""
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
+}
+
+do_stage () {
+ oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+ install -d ${STAGING_INCDIR}/glib-2.0/glib
+ install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
+ install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
+}