summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-01-19 21:55:53 +0000
committerRichard Purdie <richard@openedhand.com>2006-01-19 21:55:53 +0000
commit00f73b93ad637c0a46ad22e0e1451b9d250a2651 (patch)
tree5529e260e220c0013839329a7c431dcd321c951b /openembedded
parent7c37c29a5a141a02ca4acf6d54f6a762f1ff4a79 (diff)
downloadopenembedded-core-00f73b93ad637c0a46ad22e0e1451b9d250a2651.tar.gz
openembedded-core-00f73b93ad637c0a46ad22e0e1451b9d250a2651.tar.bz2
openembedded-core-00f73b93ad637c0a46ad22e0e1451b9d250a2651.tar.xz
openembedded-core-00f73b93ad637c0a46ad22e0e1451b9d250a2651.zip
Add avahi 0.6.3 abd renive 0.5.2 and 0.6
git-svn-id: https://svn.o-hand.com/repos/poky@225 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/avahi/avahi-0.5.2/alignment-fix.patch96
-rw-r--r--openembedded/packages/avahi/avahi_0.5.2.bb53
-rw-r--r--openembedded/packages/avahi/avahi_0.6.3.bb (renamed from openembedded/packages/avahi/avahi_0.6.bb)9
3 files changed, 5 insertions, 153 deletions
diff --git a/openembedded/packages/avahi/avahi-0.5.2/alignment-fix.patch b/openembedded/packages/avahi/avahi-0.5.2/alignment-fix.patch
deleted file mode 100644
index fc23f2375..000000000
--- a/openembedded/packages/avahi/avahi-0.5.2/alignment-fix.patch
+++ /dev/null
@@ -1,96 +0,0 @@
---- avahi-0.5/avahi-core/dns.c.orig 2005-09-23 16:35:02 +0200
-+++ avahi-0.5/avahi-core/dns.c 2005-09-23 16:35:07 +0200
-@@ -177,11 +177,13 @@
- assert(idx < p->size);
-
- if (idx < 0x4000) {
-- uint16_t *t;
-- if (!(t = (uint16_t*) avahi_dns_packet_extend(p, sizeof(uint16_t))))
-+ uint8_t *t;
-+
-+ if (!(t = (uint8_t*) avahi_dns_packet_extend(p, sizeof(uint16_t))))
- return NULL;
-
-- *t = htons((0xC000 | idx));
-+ t[0] = (uint8_t) ((0xC000 | idx) >> 8);
-+ t[1] = (uint8_t) idx;
- return saved_ptr;
- }
- }
-@@ -223,7 +225,8 @@
- if (!(d = avahi_dns_packet_extend(p, sizeof(uint16_t))))
- return NULL;
-
-- *((uint16_t*) d) = htons(v);
-+ d[0] = (uint8_t) (v >> 8);
-+ d[1] = (uint8_t) v;
- return d;
- }
-
-@@ -234,7 +237,10 @@
- if (!(d = avahi_dns_packet_extend(p, sizeof(uint32_t))))
- return NULL;
-
-- *((uint32_t*) d) = htonl(v);
-+ d[0] = (uint8_t) (v >> 24);
-+ d[1] = (uint8_t) (v >> 16);
-+ d[2] = (uint8_t) (v >> 8);
-+ d[3] = (uint8_t) v;
-
- return d;
- }
-@@ -385,26 +391,42 @@
- }
-
- int avahi_dns_packet_consume_uint16(AvahiDnsPacket *p, uint16_t *ret_v) {
-+ uint8_t *d;
-+ uint16_t tmp_v;
-+
- assert(p);
- assert(ret_v);
-
- if (p->rindex + sizeof(uint16_t) > p->size)
- return -1;
-
-- *ret_v = ntohs(*((uint16_t*) (AVAHI_DNS_PACKET_DATA(p) + p->rindex)));
-+ d = (uint8_t*) (AVAHI_DNS_PACKET_DATA(p) + p->rindex);
-+ tmp_v = (d[0] << 8) | d[1];
-+ d = (uint8_t*) ret_v;
-+ d[0] = ((uint8_t*)(&tmp_v))[0];
-+ d[1] = ((uint8_t*)(&tmp_v))[1];
- p->rindex += sizeof(uint16_t);
-
- return 0;
- }
-
- int avahi_dns_packet_consume_uint32(AvahiDnsPacket *p, uint32_t *ret_v) {
-+ uint8_t* d;
-+ uint32_t tmp_v;
-+
- assert(p);
- assert(ret_v);
-
- if (p->rindex + sizeof(uint32_t) > p->size)
- return -1;
-
-- *ret_v = ntohl(*((uint32_t*) (AVAHI_DNS_PACKET_DATA(p) + p->rindex)));
-+ d = (uint8_t*) (AVAHI_DNS_PACKET_DATA(p) + p->rindex);
-+ tmp_v = (d[0] << 24) | (d[1] << 16) | (d[2] << 8) | d[3];
-+ d = (uint8_t*) ret_v;
-+ d[0] = ((uint8_t*)(&tmp_v))[0];
-+ d[1] = ((uint8_t*)(&tmp_v))[1];
-+ d[2] = ((uint8_t*)(&tmp_v))[2];
-+ d[3] = ((uint8_t*)(&tmp_v))[3];
- p->rindex += sizeof(uint32_t);
-
- return 0;
-@@ -733,7 +755,8 @@
-
- /* avahi_log_debug("appended %u", size); */
-
-- * (uint16_t*) l = htons((uint16_t) size);
-+ l[0] = (uint8_t) ((uint16_t) size >> 8);
-+ l[1] = (uint8_t) ((uint16_t) size);
-
- return t;
-
diff --git a/openembedded/packages/avahi/avahi_0.5.2.bb b/openembedded/packages/avahi/avahi_0.5.2.bb
deleted file mode 100644
index e4291db2c..000000000
--- a/openembedded/packages/avahi/avahi_0.5.2.bb
+++ /dev/null
@@ -1,53 +0,0 @@
-DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-HOMEPAGE = "http://www.freedesktop.org/Software/Avahi"
-LICENSE= "GPL"
-DEPENDS = "expat libdaemon dbus-0.50"
-RRECOMMENDS = "libnss-mdns"
-SECTION = "net"
-PRIORITY = "optional"
-PR = "r0"
-
-SRC_URI = "http://www.freedesktop.org/~lennart/avahi-${PV}.tar.gz \
- file://alignment-fix.patch;patch=1"
-
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc"
-
-FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
-FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
-FILES_avahi-daemon = "${sbindir}/avahi-daemon \
- ${sysconfdir}/avahi/avahi-daemon.conf \
- ${sysconfdir}/avahi/services \
- ${sysconfdir}/dbus-1 \
- ${sysconfdir}/init.d/avahi-daemon \
- ${datadir}/avahi/introspection/*.introspect \
- ${datadir}/avahi/avahi-service.dtd \
- ${datadir}/avahi/service-types"
-FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
-FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
- ${sysconfdir}/avahi/avahi-dnsconfd.action \
- ${sysconfdir}/init.d/avahi-dnsconfd"
-FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
-
-CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
-
-EXTRA_OECONF = "--with-distro=debian --disable-mono --disable-mono-docs --disable-gtk --disable-qt3 --disable-qt4 --disable-python"
-inherit autotools
-inherit update-rc.d
-
-INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
-INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
-INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
-INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
-INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
-
-pkg_postinst_avahi-daemon () {
- grep avahi /etc/group || addgroup avahi
- grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
- /etc/init.d/dbus-1 force-reload
-}
-
-pkg_postrm_avahi-daemon () {
- deluser avahi || true
- delgroup avahi || true
-}
-
diff --git a/openembedded/packages/avahi/avahi_0.6.bb b/openembedded/packages/avahi/avahi_0.6.3.bb
index 4ea3841f1..fbd7208d1 100644
--- a/openembedded/packages/avahi/avahi_0.6.bb
+++ b/openembedded/packages/avahi/avahi_0.6.3.bb
@@ -1,15 +1,15 @@
DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
-HOMEPAGE = "http://www.freedesktop.org/Software/Avahi"
+HOMEPAGE = "http://avahi.org"
LICENSE= "GPL"
-DEPENDS = "expat libdaemon dbus-0.50"
+DEPENDS = "expat libdaemon dbus-0.60"
RRECOMMENDS = "libnss-mdns"
SECTION = "net"
PRIORITY = "optional"
PR = "r0"
-SRC_URI = "http://www.freedesktop.org/~lennart/avahi-${PV}.tar.gz"
+SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
-PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc"
+PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
@@ -26,6 +26,7 @@ FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
${sysconfdir}/avahi/avahi-dnsconfd.action \
${sysconfdir}/init.d/avahi-dnsconfd"
FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_avahi-utils = "${bindir}/avahi-*"
CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"