summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-09-27 17:18:54 +0000
committerChris Lord <chris@openedhand.com>2005-09-27 17:18:54 +0000
commit570ff4f6987377244fabaa4fa3d9057fd4a5d6a2 (patch)
tree8452da21e04b826c988ab5608ba304d49412f57f /openembedded
parentb433acd989cd936b135d41d276cc5413bfa4d05b (diff)
downloadopenembedded-core-570ff4f6987377244fabaa4fa3d9057fd4a5d6a2.tar.gz
openembedded-core-570ff4f6987377244fabaa4fa3d9057fd4a5d6a2.tar.bz2
openembedded-core-570ff4f6987377244fabaa4fa3d9057fd4a5d6a2.tar.xz
openembedded-core-570ff4f6987377244fabaa4fa3d9057fd4a5d6a2.zip
- Bump PR in matchbox-wm
- Define X_LIBS in libxsettings-client and startup-notification to stop them adding system dirs to the library path - Add do_stage to matchbox-desktop git-svn-id: https://svn.o-hand.com/repos/poky@44 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/libxsettings-client/libxsettings-client_0.14.bb4
-rw-r--r--openembedded/packages/matchbox-desktop/matchbox-desktop_svn.bb6
-rw-r--r--openembedded/packages/matchbox-wm/matchbox-wm_svn.bb2
-rw-r--r--openembedded/packages/startup-notification/startup-notification_0.8.bb5
4 files changed, 16 insertions, 1 deletions
diff --git a/openembedded/packages/libxsettings-client/libxsettings-client_0.14.bb b/openembedded/packages/libxsettings-client/libxsettings-client_0.14.bb
index 11d0d3497..1ccb6e4eb 100644
--- a/openembedded/packages/libxsettings-client/libxsettings-client_0.14.bb
+++ b/openembedded/packages/libxsettings-client/libxsettings-client_0.14.bb
@@ -2,12 +2,16 @@ SECTION = "gpe/libs"
LICENSE = "BSD-X"
PRIORITY = "optional"
DEPENDS = "libxsettings x11"
+PR = "r1"
inherit autotools pkgconfig gpe
SRC_URI = "${GPE_MIRROR}/xsettings-client-${PV}.tar.bz2"
S = ${WORKDIR}/xsettings-client-${PV}
+do_configure () {
+ X_LIBS=" -L${STAGING_LIBDIR}" oe_runconf
+}
headers = "xsettings-client.h xsettings-common.h"
do_stage () {
diff --git a/openembedded/packages/matchbox-desktop/matchbox-desktop_svn.bb b/openembedded/packages/matchbox-desktop/matchbox-desktop_svn.bb
index ca193d42c..468caff25 100644
--- a/openembedded/packages/matchbox-desktop/matchbox-desktop_svn.bb
+++ b/openembedded/packages/matchbox-desktop/matchbox-desktop_svn.bb
@@ -23,3 +23,9 @@ FILES_${PN} = "${bindir} \
FILES_${PN}-dev = "${libdir}/matchbox-desktop \
${includedir}/matchbox-desktop \
${datadir}/matchbox/desktop/modules/*a"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/matchbox-desktop/
+ install -m 0644 ${S}/src/*.h ${STAGING_INCDIR}/matchbox-desktop/
+}
+
diff --git a/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb b/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
index 48d9044f3..f9765df44 100644
--- a/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
+++ b/openembedded/packages/matchbox-wm/matchbox-wm_svn.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
DEPENDS = "libmatchbox x11 xext libxrender startup-notification expat matchbox-common gconf"
RDEPENDS = "matchbox-common"
PV = "0.9.5cvs${CVSDATE}"
-PR = "r3"
+PR = "r4"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
diff --git a/openembedded/packages/startup-notification/startup-notification_0.8.bb b/openembedded/packages/startup-notification/startup-notification_0.8.bb
index c4cc57440..a505a5396 100644
--- a/openembedded/packages/startup-notification/startup-notification_0.8.bb
+++ b/openembedded/packages/startup-notification/startup-notification_0.8.bb
@@ -4,11 +4,16 @@ SECTION = "libs"
PRIORITY = "optional"
MAINTAINER = "Phil Blundell <pb@nexus.co.uk>"
DEPENDS = "x11"
+PR = "r1"
inherit autotools pkgconfig
SRC_URI = "http://www.freedesktop.org/software/startup-notification/releases/startup-notification-0.8.tar.gz"
+do_configure_prepend () {
+ export X_LIBS=" -L${STAGING_LIBDIR}"
+}
+
do_stage () {
oe_runmake install DESTDIR="" bindir=${STAGING_BINDIR} includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} prefix=${STAGING_DIR}
}