summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-08 20:37:25 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-08 20:37:25 +0000
commit64725e12d44b3484ddde2de6e265f6d64331a4f3 (patch)
treeef030a7fc8f565ca0cc8920d6dc1f313a5ff7aa9 /openembedded
parent722f400c1cf04aaa90c760f3b6507492c74235fc (diff)
downloadopenembedded-core-64725e12d44b3484ddde2de6e265f6d64331a4f3.tar.gz
openembedded-core-64725e12d44b3484ddde2de6e265f6d64331a4f3.tar.bz2
openembedded-core-64725e12d44b3484ddde2de6e265f6d64331a4f3.tar.xz
openembedded-core-64725e12d44b3484ddde2de6e265f6d64331a4f3.zip
Add accidently removed module-init-tools bb file
git-svn-id: https://svn.o-hand.com/repos/poky@176 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools_3.1.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb b/openembedded/packages/module-init-tools/module-init-tools_3.1.bb
new file mode 100644
index 000000000..62523f513
--- /dev/null
+++ b/openembedded/packages/module-init-tools/module-init-tools_3.1.bb
@@ -0,0 +1,60 @@
+LICENSE = "GPL"
+SECTION = "base"
+DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
+removing kernel modules for Linux (versions 2.5.48 and above). It serves \
+the same function that the modutils package serves for Linux 2.4."
+PR = "r2"
+
+PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
+RDEPENDS_${PN} += "module-init-tools-depmod"
+
+FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
+FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
+ file://ignore_arch_directory;patch=1 \
+ file://modutils_extension;patch=1 \
+ file://no_man_rebuild;patch=1 \
+ file://manpagesopt;patch=1 \
+ file://soc.patch;patch=1;pnum=0"
+S = "${WORKDIR}/module-init-tools-${PV}"
+
+EXTRA_OECONF = "--disable-manpages"
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+inherit autotools
+
+do_install() {
+ autotools_do_install
+ for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
+ mv ${D}/$f ${D}/$f.26
+ done
+}
+
+pkg_postinst_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
+bn=`basename $f`
+ update-alternatives --install /$f $bn /$f.26 20
+done
+}
+
+pkg_prerm_module-init-tools() {
+#!/bin/sh
+for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
+bn=`basename $f`
+ update-alternatives --remove $bn /$f.26
+done
+}
+
+pkg_postinst_module-init-tools-depmod() {
+#!/bin/sh
+update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 20
+}
+
+pkg_prerm_module-init-tools() {
+#!/bin/sh
+update-alternatives --remove depmod /sbin/depmod.26
+}