summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-29 10:41:32 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-29 10:41:32 +0000
commitc309ab875f39504b6de12ccad1d3bd9de6ec41d3 (patch)
tree62f34df8ef2b5ef80e9974dfd0459dd2447cdc8b /openembedded
parent156e5b0e0bcc19f0a5fbeac71c1397d085844cd6 (diff)
downloadopenembedded-core-c309ab875f39504b6de12ccad1d3bd9de6ec41d3.tar.gz
openembedded-core-c309ab875f39504b6de12ccad1d3bd9de6ec41d3.tar.bz2
openembedded-core-c309ab875f39504b6de12ccad1d3bd9de6ec41d3.tar.xz
openembedded-core-c309ab875f39504b6de12ccad1d3bd9de6ec41d3.zip
eds: More updates to try and get it working
git-svn-id: https://svn.o-hand.com/repos/poky@60 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/eds/eds-dbus/external_libdb.patch34
-rw-r--r--openembedded/packages/eds/eds-dbus/iconv-detect.h5
-rw-r--r--openembedded/packages/eds/eds-dbus/no_gnomevfs.patch87
-rwxr-xr-xopenembedded/packages/eds/eds-dbus_svn.bb12
4 files changed, 128 insertions, 10 deletions
diff --git a/openembedded/packages/eds/eds-dbus/external_libdb.patch b/openembedded/packages/eds/eds-dbus/external_libdb.patch
index cb88efbc0..ebb32403e 100644
--- a/openembedded/packages/eds/eds-dbus/external_libdb.patch
+++ b/openembedded/packages/eds/eds-dbus/external_libdb.patch
@@ -1,7 +1,7 @@
Index: trunk/Makefile.am
===================================================================
---- trunk.orig/Makefile.am 2005-09-28 17:12:46.000000000 +0000
-+++ trunk/Makefile.am 2005-09-28 20:01:01.000000000 +0000
+--- trunk.orig/Makefile.am 2005-09-29 09:19:48.000000000 +0000
++++ trunk/Makefile.am 2005-09-29 09:19:53.000000000 +0000
@@ -8,9 +8,9 @@
endif
@@ -30,8 +30,8 @@ Index: trunk/Makefile.am
libdb/Makefile.am \
Index: trunk/configure.in
===================================================================
---- trunk.orig/configure.in 2005-09-28 17:12:46.000000000 +0000
-+++ trunk/configure.in 2005-09-28 21:45:00.000000000 +0000
+--- trunk.orig/configure.in 2005-09-29 09:19:48.000000000 +0000
++++ trunk/configure.in 2005-09-29 10:11:00.000000000 +0000
@@ -179,6 +179,21 @@
AC_SUBST(REGEX_LIBS)
@@ -72,8 +72,8 @@ Index: trunk/configure.in
libedataserverui/Makefile
Index: trunk/libedataserver/Makefile.am
===================================================================
---- trunk.orig/libedataserver/Makefile.am 2005-09-28 17:07:06.000000000 +0000
-+++ trunk/libedataserver/Makefile.am 2005-09-28 21:41:32.000000000 +0000
+--- trunk.orig/libedataserver/Makefile.am 2005-09-29 09:19:48.000000000 +0000
++++ trunk/libedataserver/Makefile.am 2005-09-29 09:19:53.000000000 +0000
@@ -1,7 +1,7 @@
INCLUDES = \
-I$(top_srcdir) \
@@ -92,3 +92,25 @@ Index: trunk/libedataserver/Makefile.am
$(SOCKET_LIBS)
libedataserver_1_2_la_LDFLAGS = \
+Index: trunk/addressbook/backends/file/Makefile.am
+===================================================================
+--- trunk.orig/addressbook/backends/file/Makefile.am 2005-09-29 09:05:35.000000000 +0000
++++ trunk/addressbook/backends/file/Makefile.am 2005-09-29 09:27:21.000000000 +0000
+@@ -4,7 +4,7 @@
+ -I$(top_builddir) \
+ -I$(top_srcdir)/addressbook \
+ -I$(top_builddir)/addressbook \
+- -I$(top_srcdir)/libdb/dist \
++ $(DB_CFLAGS) \
+ $(EVOLUTION_ADDRESSBOOK_CFLAGS)
+
+ extension_LTLIBRARIES = libebookbackendfile.la
+@@ -18,7 +18,7 @@
+ $(top_builddir)/addressbook/libebook-dbus/libebook-$(API_VERSION).la \
+ $(top_builddir)/addressbook/libedata-book-dbus/libedata-book-$(API_VERSION).la \
+ $(top_builddir)/libedataserver/libedataserver-$(API_VERSION).la \
+- $(top_builddir)/libdb/dist/libdb-4.1.la \
++ $(DB_LIBS) \
+ $(EVOLUTION_ADDRESSBOOK_LIBS)
+
+ libebookbackendfile_la_LDFLAGS = \
diff --git a/openembedded/packages/eds/eds-dbus/iconv-detect.h b/openembedded/packages/eds/eds-dbus/iconv-detect.h
new file mode 100644
index 000000000..46f476d5b
--- /dev/null
+++ b/openembedded/packages/eds/eds-dbus/iconv-detect.h
@@ -0,0 +1,5 @@
+/* This is an auto-generated header, DO NOT EDIT! */
+
+#define ICONV_ISO_D_FORMAT "iso-%d-%d"
+#define ICONV_ISO_S_FORMAT "iso-%d-%s"
+#define ICONV_10646 "iso-10646"
diff --git a/openembedded/packages/eds/eds-dbus/no_gnomevfs.patch b/openembedded/packages/eds/eds-dbus/no_gnomevfs.patch
new file mode 100644
index 000000000..3a0fb8e7e
--- /dev/null
+++ b/openembedded/packages/eds/eds-dbus/no_gnomevfs.patch
@@ -0,0 +1,87 @@
+Index: addressbook/libebook/e-contact.c
+===================================================================
+--- trunk/addressbook/libebook/e-contact.c (revision 206)
++++ trunk/addressbook/libebook/e-contact.c (working copy)
+@@ -27,7 +27,9 @@
+ #include <ctype.h>
+ #include <string.h>
+ #include <glib/gi18n-lib.h>
++#if 0
+ #include <libgnomevfs/gnome-vfs-mime-utils.h>
++#endif
+ #include "e-contact.h"
+ #include "e-book.h"
+ #include "e-name-western.h"
+@@ -418,8 +420,11 @@
+ e_vcard_attribute_add_param_with_value (attr,
+ e_vcard_attribute_param_new (EVC_ENCODING),
+ "b");
+-
++#if 0
+ mime_type = gnome_vfs_get_mime_type_for_data (photo->inlined.data, photo->inlined.length);
++#else
++ mime_type = "image/jpeg";
++#endif
+ if (!strcmp (mime_type, "image/gif"))
+ image_type = "GIF";
+ else if (!strcmp (mime_type, "image/jpeg"))
+Index: configure.in
+===================================================================
+--- trunk/configure.in (revision 214)
++++ trunk/configure.in (working copy)
+@@ -1180,7 +1180,7 @@
+
+ dnl --- evolution-addressbook flags
+
+-EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS gnome-vfs-2.0 "
++EVOLUTION_ADDRESSBOOK_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 $IPC_DEPS"
+
+ EVO_SET_COMPILE_FLAGS(EVOLUTION_ADDRESSBOOK, $EVOLUTION_ADDRESSBOOK_DEPS)
+ AC_SUBST(EVOLUTION_ADDRESSBOOK_CFLAGS)
+@@ -1188,7 +1188,7 @@
+
+ dnl --- evolution-calendar flags
+
+-EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 gnome-vfs-2.0 dbus-glib-1"
++EVOLUTION_CALENDAR_DEPS="libxml-2.0 gobject-2.0 gconf-2.0 dbus-glib-1"
+
+ EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, $EVOLUTION_CALENDAR_DEPS)
+ AC_SUBST(EVOLUTION_CALENDAR_CFLAGS)
+Index: calendar/backends/Makefile.am
+===================================================================
+--- trunk/calendar/backends/Makefile.am (revision 212)
++++ trunk/calendar/backends/Makefile.am (working copy)
+@@ -4,4 +4,4 @@
+ GROUPWISE_SUBDIR =
+ endif
+
+-SUBDIRS = file $(GROUPWISE_SUBDIR) contacts
++SUBDIRS = $(GROUPWISE_SUBDIR) contacts
+Index: calendar/libedata-cal-dbus/e-data-cal-factory.c
+===================================================================
+--- trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c (revision 206)
++++ trunk/calendar/libedata-cal-dbus/e-data-cal-factory.c (working copy)
+@@ -28,8 +28,9 @@
+ #include <dbus/dbus-protocol.h>
+ #include <dbus/dbus-glib.h>
+ #include <dbus/dbus-glib-bindings.h>
+-/**/
++#if 0
+ #include <libgnomevfs/gnome-vfs.h>
++#endif
+ #include <libedataserver/e-url.h>
+ #include <libedataserver/e-source.h>
+ #include <libedataserver/e-data-server-module.h>
+@@ -406,10 +407,12 @@
+
+ loop = g_main_loop_new (NULL, FALSE);
+
++#if 0
+ if (!gnome_vfs_init ()) {
+ g_error ("Failed to initialise gnome-vfs");
+ exit (1);
+ }
++#endif
+
+ g_print ("Launching EDataCalFactory\n");
+
diff --git a/openembedded/packages/eds/eds-dbus_svn.bb b/openembedded/packages/eds/eds-dbus_svn.bb
index a087b0493..28d7748e1 100755
--- a/openembedded/packages/eds/eds-dbus_svn.bb
+++ b/openembedded/packages/eds/eds-dbus_svn.bb
@@ -4,16 +4,20 @@ RDEPENDS = "glib-2.0 gtk+ gconf dbus db libglade libiconv"
MAINTAINER = "Chris Lord <chris@openedhand.com>"
DESCRIPTION = "Evolution database backend server"
PV = "1.4.0cvs${CVSDATE}"
-PR = "r1"
+PR = "r2"
SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
file://external_libdb.patch;patch=1 \
- file://no_libgnome.patch;patch=1 \
- file://no_iconv_test.patch;patch=1"
+ file://no_gnomevfs.patch;patch=1 \
+ file://no_iconv_test.patch;patch=1 \
+ file://iconv-detect.h"
+
S = "${WORKDIR}/trunk"
inherit autotools pkgconfig
-EXTRA_OECONF = "--without-openldap --disable-nntp --disable-gtk-doc --enable-groupwise=no --with-dbus=yes --with-libgnome=no --enable-soup=no --with-libdb43=${STAGING_DIR}/${HOST_SYS}"
+EXTRA_OECONF = "--without-openldap --disable-nntp --disable-gtk-doc --with-dbus=yes --with-libgnome=no --enable-soup=no --with-libdb43=${STAGING_DIR}/${HOST_SYS} --enable-smime=no --enable-nss=no"
acpaths = " -I ${STAGING_DATADIR}/aclocal/gnome-macros "
+
+do_configure_append = " cp ${WORKDIR}/iconv-detect.h ${S} " \ No newline at end of file