summaryrefslogtreecommitdiff
path: root/openembedded
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-10-28 17:17:56 +0000
committerChris Lord <chris@openedhand.com>2005-10-28 17:17:56 +0000
commitd1dae06dc1edb0bd3ae82104e35699e800384ab8 (patch)
treeb66d6a2a18fb62fddb69eb521bd06dd26f92d88b /openembedded
parent9ad36d44f008862cefa1a19f4f5690cf9706effe (diff)
downloadopenembedded-core-d1dae06dc1edb0bd3ae82104e35699e800384ab8.tar.gz
openembedded-core-d1dae06dc1edb0bd3ae82104e35699e800384ab8.tar.bz2
openembedded-core-d1dae06dc1edb0bd3ae82104e35699e800384ab8.tar.xz
openembedded-core-d1dae06dc1edb0bd3ae82104e35699e800384ab8.zip
Add gnome-vfs-dbus (builds correctly, but untested)
git-svn-id: https://svn.o-hand.com/repos/poky@147 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/bzip2/bzip2-1.0.2/installpaths.patch103
-rw-r--r--openembedded/packages/bzip2/bzip2_1.0.2.bb41
-rw-r--r--openembedded/packages/gnome/gnome-mime-data_2.4.2.bb8
-rw-r--r--openembedded/packages/gnome/gnome-vfs-dbus/gssapi.patch13
-rw-r--r--openembedded/packages/gnome/gnome-vfs-dbus/no-gtk-doc.patch24
-rwxr-xr-xopenembedded/packages/gnome/gnome-vfs-dbus_cvs.bb99
6 files changed, 288 insertions, 0 deletions
diff --git a/openembedded/packages/bzip2/bzip2-1.0.2/installpaths.patch b/openembedded/packages/bzip2/bzip2-1.0.2/installpaths.patch
new file mode 100644
index 000000000..e7d09a71c
--- /dev/null
+++ b/openembedded/packages/bzip2/bzip2-1.0.2/installpaths.patch
@@ -0,0 +1,103 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- bzip2-1.0.2/Makefile~installpaths
++++ bzip2-1.0.2/Makefile
+@@ -12,8 +12,12 @@
+ CFLAGS=-Wall -Winline -O2 -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
+
+ # Where you want it installed when you do 'make install'
+-PREFIX=/usr
+-
++DESTDIR=
++prefix=/usr
++bindir=$(prefix)/bin
++mandir=$(prefix)/man
++includedir=$(prefix)/include
++libdir=$(prefix)/lib
+
+ OBJS= blocksort.o \
+ huffman.o \
+@@ -58,43 +62,43 @@
+ @cat words3
+
+ install: bzip2 bzip2recover
+- if ( test ! -d $(PREFIX)/bin ) ; then mkdir -p $(PREFIX)/bin ; fi
+- if ( test ! -d $(PREFIX)/lib ) ; then mkdir -p $(PREFIX)/lib ; fi
+- if ( test ! -d $(PREFIX)/man ) ; then mkdir -p $(PREFIX)/man ; fi
+- if ( test ! -d $(PREFIX)/man/man1 ) ; then mkdir -p $(PREFIX)/man/man1 ; fi
+- if ( test ! -d $(PREFIX)/include ) ; then mkdir -p $(PREFIX)/include ; fi
+- cp -f bzip2 $(PREFIX)/bin/bzip2
+- cp -f bzip2 $(PREFIX)/bin/bunzip2
+- cp -f bzip2 $(PREFIX)/bin/bzcat
+- cp -f bzip2recover $(PREFIX)/bin/bzip2recover
+- chmod a+x $(PREFIX)/bin/bzip2
+- chmod a+x $(PREFIX)/bin/bunzip2
+- chmod a+x $(PREFIX)/bin/bzcat
+- chmod a+x $(PREFIX)/bin/bzip2recover
+- cp -f bzip2.1 $(PREFIX)/man/man1
+- chmod a+r $(PREFIX)/man/man1/bzip2.1
+- cp -f bzlib.h $(PREFIX)/include
+- chmod a+r $(PREFIX)/include/bzlib.h
+- cp -f libbz2.a $(PREFIX)/lib
+- chmod a+r $(PREFIX)/lib/libbz2.a
+- cp -f bzgrep $(PREFIX)/bin/bzgrep
+- ln $(PREFIX)/bin/bzgrep $(PREFIX)/bin/bzegrep
+- ln $(PREFIX)/bin/bzgrep $(PREFIX)/bin/bzfgrep
+- chmod a+x $(PREFIX)/bin/bzgrep
+- cp -f bzmore $(PREFIX)/bin/bzmore
+- ln $(PREFIX)/bin/bzmore $(PREFIX)/bin/bzless
+- chmod a+x $(PREFIX)/bin/bzmore
+- cp -f bzdiff $(PREFIX)/bin/bzdiff
+- ln $(PREFIX)/bin/bzdiff $(PREFIX)/bin/bzcmp
+- chmod a+x $(PREFIX)/bin/bzdiff
+- cp -f bzgrep.1 bzmore.1 bzdiff.1 $(PREFIX)/man/man1
+- chmod a+r $(PREFIX)/man/man1/bzgrep.1
+- chmod a+r $(PREFIX)/man/man1/bzmore.1
+- chmod a+r $(PREFIX)/man/man1/bzdiff.1
+- echo ".so man1/bzgrep.1" > $(PREFIX)/man/man1/bzegrep.1
+- echo ".so man1/bzgrep.1" > $(PREFIX)/man/man1/bzfgrep.1
+- echo ".so man1/bzmore.1" > $(PREFIX)/man/man1/bzless.1
+- echo ".so man1/bzdiff.1" > $(PREFIX)/man/man1/bzcmp.1
++ if ( test ! -d $(DESTDIR)$(bindir) ) ; then mkdir -p $(DESTDIR)$(bindir) ; fi
++ if ( test ! -d $(DESTDIR)$(libdir) ) ; then mkdir -p $(DESTDIR)$(libdir) ; fi
++ if ( test ! -d $(DESTDIR)$(mandir) ) ; then mkdir -p $(DESTDIR)$(mandir) ; fi
++ if ( test ! -d $(DESTDIR)$(mandir)/man1 ) ; then mkdir -p $(DESTDIR)$(mandir)/man1 ; fi
++ if ( test ! -d $(DESTDIR)$(includedir) ) ; then mkdir -p $(DESTDIR)$(includedir) ; fi
++ cp -f bzip2 $(DESTDIR)$(bindir)/bzip2
++ cp -f bzip2 $(DESTDIR)$(bindir)/bunzip2
++ cp -f bzip2 $(DESTDIR)$(bindir)/bzcat
++ cp -f bzip2recover $(DESTDIR)$(bindir)/bzip2recover
++ chmod a+x $(DESTDIR)$(bindir)/bzip2
++ chmod a+x $(DESTDIR)$(bindir)/bunzip2
++ chmod a+x $(DESTDIR)$(bindir)/bzcat
++ chmod a+x $(DESTDIR)$(bindir)/bzip2recover
++ cp -f bzip2.1 $(DESTDIR)$(mandir)/man1
++ chmod a+r $(DESTDIR)$(mandir)/man1/bzip2.1
++ cp -f bzlib.h $(DESTDIR)$(includedir)
++ chmod a+r $(DESTDIR)$(includedir)/bzlib.h
++ cp -f libbz2.a $(DESTDIR)$(libdir)
++ chmod a+r $(DESTDIR)$(libdir)/libbz2.a
++ cp -f bzgrep $(DESTDIR)$(bindir)/bzgrep
++ ln $(DESTDIR)$(bindir)/bzgrep $(DESTDIR)$(bindir)/bzegrep
++ ln $(DESTDIR)$(bindir)/bzgrep $(DESTDIR)$(bindir)/bzfgrep
++ chmod a+x $(DESTDIR)$(bindir)/bzgrep
++ cp -f bzmore $(DESTDIR)$(bindir)/bzmore
++ ln $(DESTDIR)$(bindir)/bzmore $(DESTDIR)$(bindir)/bzless
++ chmod a+x $(DESTDIR)$(bindir)/bzmore
++ cp -f bzdiff $(DESTDIR)$(bindir)/bzdiff
++ ln $(DESTDIR)$(bindir)/bzdiff $(DESTDIR)$(bindir)/bzcmp
++ chmod a+x $(DESTDIR)$(bindir)/bzdiff
++ cp -f bzgrep.1 bzmore.1 bzdiff.1 $(DESTDIR)$(mandir)/man1
++ chmod a+r $(DESTDIR)$(mandir)/man1/bzgrep.1
++ chmod a+r $(DESTDIR)$(mandir)/man1/bzmore.1
++ chmod a+r $(DESTDIR)$(mandir)/man1/bzdiff.1
++ echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzegrep.1
++ echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzfgrep.1
++ echo ".so man1/bzmore.1" > $(DESTDIR)$(mandir)/man1/bzless.1
++ echo ".so man1/bzdiff.1" > $(DESTDIR)$(mandir)/man1/bzcmp.1
+
+ distclean: clean
+ clean:
diff --git a/openembedded/packages/bzip2/bzip2_1.0.2.bb b/openembedded/packages/bzip2/bzip2_1.0.2.bb
new file mode 100644
index 000000000..1e1cb8e53
--- /dev/null
+++ b/openembedded/packages/bzip2/bzip2_1.0.2.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Very high-quality data compression program."
+SECTION = "console/utils"
+PR = "r1"
+
+LICENSE = "bzip2"
+SRC_URI = "ftp://sources.redhat.com/pub/bzip2/v102/bzip2-${PV}.tar.gz \
+ file://installpaths.patch;patch=1"
+
+CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
+
+do_compile () {
+ oe_runmake -f Makefile-libbz2_so
+ ln -sf libbz2.so.1.0.2 libbz2.so.1.0
+ ln -sf libbz2.so.1.0.2 libbz2.so.1
+ ln -sf libbz2.so.1.0.2 libbz2.so
+ oe_runmake libbz2.a bzip2 bzip2recover
+}
+
+do_stage () {
+ install -m 0644 bzlib.h ${STAGING_INCDIR}/
+ oe_libinstall -a -so libbz2 ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ oe_libinstall -a -so libbz2 ${D}${libdir}
+ mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
+ mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
+}
+
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
+ update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
+}
+
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove bunzip2 bunzip2.${PN}
+ update-alternatives --remove bzcat bzcat.${PN}
+}
diff --git a/openembedded/packages/gnome/gnome-mime-data_2.4.2.bb b/openembedded/packages/gnome/gnome-mime-data_2.4.2.bb
new file mode 100644
index 000000000..bf98e1441
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-mime-data_2.4.2.bb
@@ -0,0 +1,8 @@
+LICENSE = "GPL"
+
+inherit pkgconfig autotools
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${PN}/2.4/${PN}-${PV}.tar.bz2"
+
+DEPENDS += "shared-mime-info intltool-native"
+RDEPENDS = "shared-mime-info"
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus/gssapi.patch b/openembedded/packages/gnome/gnome-vfs-dbus/gssapi.patch
new file mode 100644
index 000000000..bcf46176b
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-vfs-dbus/gssapi.patch
@@ -0,0 +1,13 @@
+--- trunk/configure.in.old 2005-10-28 17:18:36.000000000 +0100
++++ trunk/configure.in 2005-10-28 17:20:34.000000000 +0100
+@@ -444,6 +444,10 @@
+ ])
+ LIBS="$saved_LIBS"
+ CPPFLAGS="$saved_CPPFLAGS"
++ if test "x$have_gssapi" != "xyes"; then
++ GSSAPI_LIBS=
++ GSSAPI_CFLAGS=
++ fi
+ fi
+ AC_SUBST(GSSAPI_LIBS)
+ AC_SUBST(GSSAPI_CFLAGS)
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus/no-gtk-doc.patch b/openembedded/packages/gnome/gnome-vfs-dbus/no-gtk-doc.patch
new file mode 100644
index 000000000..331889b63
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-vfs-dbus/no-gtk-doc.patch
@@ -0,0 +1,24 @@
+diff -urNd ../gnome-vfs-dbus-2.12.0cvs20051004-r0/trunk/doc/Makefile.am trunk/doc/Makefile.am
+--- ../gnome-vfs-dbus-2.12.0cvs20051004-r0/trunk/doc/Makefile.am 2005-10-28 15:48:43.000000000 +0100
++++ trunk/doc/Makefile.am 2005-10-28 16:17:15.000000000 +0100
+@@ -81,7 +81,7 @@
+ GTKDOC_LIBS = $(LIBGNOMEVFS_LIBS) \
+ $(top_builddir)/libgnomevfs/libgnomevfs-2.la
+
+-include $(top_srcdir)/gtk-doc.make
++#include $(top_srcdir)/gtk-doc.make
+
+ dist-hook-local:
+ # mkdir $(distdir)/TEXT; \
+diff -urNd ../gnome-vfs-dbus-2.12.0cvs20051004-r0/trunk/Makefile.am trunk/Makefile.am
+--- ../gnome-vfs-dbus-2.12.0cvs20051004-r0/trunk/Makefile.am 2005-10-28 15:49:03.000000000 +0100
++++ trunk/Makefile.am 2005-10-28 16:17:07.000000000 +0100
+@@ -21,7 +21,7 @@
+ gnome-vfs-zip.in \
+ gnome-vfs-2.0.pc.in \
+ gnome-vfs-module-2.0.pc.in \
+- gtk-doc.make \
++# gtk-doc.make \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb b/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
new file mode 100755
index 000000000..d94812fb5
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
@@ -0,0 +1,99 @@
+DEFAULT_PREFERENCE = "-1"
+
+SECTION = "x11/utils"
+DEPENDS = "gtk+ glib-2.0 gconf dbus libxml2 zlib bzip2"
+DESCRIPTION = "Virtual file system library using DBUS for communication."
+LICENSE = "GPLv2"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+PROVIDES = "gnome-vfs"
+RPROVIDES_${PN} = "gnome-vfs"
+RPROVIDES_${PN}-dev = "gnome-vfs-dev"
+RRECOMMENDS_${PN} = "gnome-vfs-plugin-file shared-mime-info"
+
+PV = "2.12.0cvs${CVSDATE}"
+
+SRC_URI = "svn://anonymous@developer.imendio.com/svn/gnome-vfs-dbus;module=trunk;proto=http \
+ file://no-gtk-doc.patch;patch=1 \
+ file://gssapi.patch;patch=1"
+S = "${WORKDIR}/trunk"
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = "--with-ipc=dbus --disable-hal --disable-gtk-doc --disable-more-warnings"
+
+FILES_${PN} += " ${libdir}/vfs ${datadir}/dbus-1/services/dbus-vfs-daemon.service"
+FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/modules/*.a ${libdir}/gnome-vfs-2.0/modules/*.la ${libdir}/gnome-vfs-2.0/include"
+FILES_${PN}-doc += " ${datadir}/gtk-doc"
+
+# These header lists have been copy-pasted from trunk/libgnomevfs/Makefile.am
+GNOME_VFS_PLATFORM_HEADERS = " \
+ gnome-vfs-file-size.h"
+
+GNOME_VFS_MODULE_HEADERS = " \
+ gnome-vfs-cancellable-ops.h \
+ gnome-vfs-inet-connection.h \
+ gnome-vfs-method.h \
+ gnome-vfs-mime.h \
+ gnome-vfs-mime-info.h \
+ gnome-vfs-module-callback-module-api.h \
+ gnome-vfs-module-shared.h \
+ gnome-vfs-module.h \
+ gnome-vfs-parse-ls.h \
+ gnome-vfs-ssl.h \
+ gnome-vfs-transform.h \
+ gnome-vfs-socket-buffer.h \
+ gnome-vfs-socket.h"
+
+GNOME_VFS_HEADERS = " \
+ gnome-vfs-application-registry.h \
+ gnome-vfs-address.h \
+ gnome-vfs-async-ops.h \
+ gnome-vfs-cancellation.h \
+ gnome-vfs-context.h \
+ gnome-vfs-directory.h \
+ gnome-vfs-dns-sd.h \
+ gnome-vfs-drive.h \
+ gnome-vfs-enum-types.h \
+ gnome-vfs-file-info.h \
+ gnome-vfs-file-size.h \
+ gnome-vfs-find-directory.h \
+ gnome-vfs-handle.h \
+ gnome-vfs-init.h \
+ gnome-vfs-job-limit.h \
+ gnome-vfs-mime-deprecated.h \
+ gnome-vfs-mime-handlers.h \
+ gnome-vfs-mime-info-cache.h \
+ gnome-vfs-mime-monitor.h \
+ gnome-vfs-mime-utils.h \
+ gnome-vfs-module-callback.h \
+ gnome-vfs-monitor.h \
+ gnome-vfs-ops.h \
+ gnome-vfs-resolve.h \
+ gnome-vfs-result.h \
+ gnome-vfs-standard-callbacks.h \
+ gnome-vfs-types.h \
+ gnome-vfs-uri.h \
+ gnome-vfs-utils.h \
+ gnome-vfs-volume-monitor.h \
+ gnome-vfs-volume.h \
+ gnome-vfs-xfer.h \
+ gnome-vfs.h"
+
+do_stage() {
+ oe_libinstall -so -C libgnomevfs libgnomevfs-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs
+ for i in ${GNOME_VFS_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs/; done
+ install -d ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs
+ for i in ${GNOME_VFS_MODULE_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs/; done
+ install -d ${STAGING_INCDIR}/include/libgnomevfs
+ for i in ${GNOME_VFS_PLATFORM_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/include/libgnomevfs/; done
+}
+
+python populate_packages_prepend () {
+ print bb.data.getVar('FILES_gnome-vfs', d, 1)
+
+ plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
+ do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s',
+'GNOME VFS plugin for %s')
+}
+