summaryrefslogtreecommitdiff
path: root/scripts/poky-autobuild-moblin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-09 15:27:25 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-09 15:28:17 +0100
commit62d37206681c3049c5ee7590cb9bce59e782ed15 (patch)
tree7b3b091e3c376b2350718c9f418020d1021a3acd /scripts/poky-autobuild-moblin
parent44a88198c129eff0aabd3fb20b999b4bef4aadde (diff)
downloadopenembedded-core-62d37206681c3049c5ee7590cb9bce59e782ed15.tar.gz
openembedded-core-62d37206681c3049c5ee7590cb9bce59e782ed15.tar.bz2
openembedded-core-62d37206681c3049c5ee7590cb9bce59e782ed15.tar.xz
openembedded-core-62d37206681c3049c5ee7590cb9bce59e782ed15.zip
scripts: Remove autobuilder scripts
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'scripts/poky-autobuild-moblin')
-rwxr-xr-xscripts/poky-autobuild-moblin109
1 files changed, 0 insertions, 109 deletions
diff --git a/scripts/poky-autobuild-moblin b/scripts/poky-autobuild-moblin
deleted file mode 100755
index 025b7678b..000000000
--- a/scripts/poky-autobuild-moblin
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/sh
-
-# Poky Automated Build Server Enviroment Setup Script
-#
-# Copyright (C) 2008 Intel
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
-SRVWORKDIR=/home/rpurdie
-TARGETDIR=$SRVWORKDIR/httpd/autobuild-output
-CURRDIR=`pwd`
-if [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/full-shihtzu/build" ]; then
- ABTARGET="poky"
-elif [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/full-bleeding-shihtzu/build" ]; then
- ABTARGET="poky-bleeding"
-elif [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/toolchain-shihtzu/build" ]; then
- ABTARGET="toolchain"
-elif [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/incremental-shihtzu/build" ]; then
- ABTARGET="incremental"
-elif [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/moblin-incremental/build" ]; then
- ABTARGET="moblin-incremental"
-elif [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/moblin-full/build" ]; then
- ABTARGET="moblin-full"
-elif [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/moblin-uricheck/build" ]; then
- ABTARGET="moblin-uricheck"
-elif [ "$CURRDIR" = "$SRVWORKDIR/poky-slave/full-darwin-shihtzu/build" ]; then
- ABTARGET="darwin"
- if [ ! -d "$CURRDIR/meta-darwin" ]; then
- svn co http://svn.o-hand.com/repos/poky/branches/experimental/meta-darwin $CURRDIR/meta-darwin
- else
- cd $CURRDIR/meta-darwin
- svn up
- cd $CURRDIR
- fi
-fi
-
-if [ "xpreamble" = "x$1" ]; then
- mkdir -p ./build/tmp/deploy/images
- rm -f ./build/tmp/deploy/images/images-complete
- git log -1 > ./build/tmp/deploy/images/svninfo
- exit 0
-fi
-
-BDIR="build"
-. ./scripts/poky-env-internal
-BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE"
-POSTPROCESS=`which poky-autobuild-postprocess-moblin`
-
-if [ "xcomplete" = "x$1" ]; then
- touch ./tmp/deploy/images/images-complete
- chmod a+w ./tmp/deploy/images/images-complete
- if [ "x$POSTPROCESS" != "x" -a -x "$POSTPROCESS" ]; then
- cd ..
- $POSTPROCESS $ABTARGET $TARGETDIR $BASEDIR
- fi
- exit 0
-fi
-
-CONFFILE="./conf/auto.conf"
-
-if [ ! -e "$CONFFILE" ]; then
- if [ ! -d "./conf" ]; then
- mkdir -p "./conf"
- fi
- echo 'PACKAGE_CLASSES = "package_ipk package_deb package_rpm"' > "$CONFFILE"
- echo 'BB_NUMBER_THREADS = "6"' >> "$CONFFILE"
- echo 'PARALLEL_MAKE = "-j 6"' >> "$CONFFILE"
- echo "DL_DIR = \"$SRVWORKDIR/httpd/sources\"" >> "$CONFFILE"
- echo 'INHERIT += "rm_work"' >> "$CONFFILE"
- #echo 'INHERIT += "poky-autobuild-notifier"' >> "$CONFFILE"
- #echo 'INHERIT += "poky-moblin-autobuilder-proxy-config"' >> "$CONFFILE"
- if [ "$ABTARGET" = "darwin" ]; then
- echo 'PACKAGE_CLASSES += "package_tar"' >> "$CONFFILE"
- echo "BBFILES += \"$CURRDIR/meta-darwin/packages/*/*.bb\"" >> "./conf/local.conf"
- echo 'POKYMODE = "darwin"' >> "$CONFFILE"
- echo 'DARWINFILES = "file:///srv/poky/sources/"' >> "$CONFFILE"
- echo 'INHERIT_INSANE = ""' >> "$CONFFILE"
- echo "FILESPATH_append = \":$CURRDIR/meta-darwin/files\"" >> "$CONFFILE"
- fi
-fi
-
-BBPATH=$SRVWORKDIR/localmeta:$BBPATH
-
-if [ "$ABTARGET" = "darwin" ]; then
- BBPATH=$CURRDIR/meta-darwin:$BBPATH
-fi
-
-bitbake $@
-
-retval=$?
-
-#if [ "x$POSTPROCESS" != "x" ]; then
-# cd ..
-# $POSTPROCESS $ABTARGET $TARGETDIR
-#fi
-
-exit $retval