summaryrefslogtreecommitdiff
path: root/scripts/tunctl-src/Makefile
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-08-05 14:50:14 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-20 16:20:10 +0100
commit4df9f11171530ca60043504ce011f34c42e93b46 (patch)
tree81b6b7b565e7645d44d391da0bf80cf897842a34 /scripts/tunctl-src/Makefile
parent6ea1ed5f7b51b7c04e8aca29319c970846ddf1b8 (diff)
downloadopenembedded-core-4df9f11171530ca60043504ce011f34c42e93b46.tar.gz
openembedded-core-4df9f11171530ca60043504ce011f34c42e93b46.tar.bz2
openembedded-core-4df9f11171530ca60043504ce011f34c42e93b46.tar.xz
openembedded-core-4df9f11171530ca60043504ce011f34c42e93b46.zip
poky-qemu-internal: Support NFS boots better
The image specification can now be in the form nfs-server:directory. This makes it possible to nfs-boot from servers other than the host. poky-qemu-internal will properly construct the kernel command line given such a specification. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'scripts/tunctl-src/Makefile')
-rw-r--r--scripts/tunctl-src/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/scripts/tunctl-src/Makefile b/scripts/tunctl-src/Makefile
new file mode 100644
index 000000000..81cab8a3c
--- /dev/null
+++ b/scripts/tunctl-src/Makefile
@@ -0,0 +1,17 @@
+OBJS = tunctl.o
+BIN = tunctl
+CFLAGS ?= -g -Wall
+
+BIN_DIR ?= /usr/bin
+
+all : $(BIN)
+
+$(BIN) : $(OBJS)
+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
+
+clean :
+ rm -f $(BIN) $(OBJS) *~
+
+install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+ install -s $(BIN) $(DESTDIR)$(BIN_DIR)