summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/sato-icon-theme/sato-icon-theme.inc21
-rw-r--r--meta/packages/sato-icon-theme/sato-icon-theme_0.1.bb20
-rw-r--r--meta/packages/sato-icon-theme/sato-icon-theme_svn.bb20
3 files changed, 26 insertions, 35 deletions
diff --git a/meta/packages/sato-icon-theme/sato-icon-theme.inc b/meta/packages/sato-icon-theme/sato-icon-theme.inc
new file mode 100644
index 000000000..3c3699dc8
--- /dev/null
+++ b/meta/packages/sato-icon-theme/sato-icon-theme.inc
@@ -0,0 +1,21 @@
+require sato-icon-theme.inc
+
+SECTION = "x11"
+DESCRIPTION = "Sato Icon Theme"
+LICENSE = "CC-BY-SA3"
+DEPENDS = ""
+
+SRC_URI = "http://pokylinux.org/releases/sato/sato-icon-theme-0.1.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}"
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ gtk-update-icon-cache -q /usr/share/icons/Sato
+}
diff --git a/meta/packages/sato-icon-theme/sato-icon-theme_0.1.bb b/meta/packages/sato-icon-theme/sato-icon-theme_0.1.bb
index 30d0017b7..0a29175aa 100644
--- a/meta/packages/sato-icon-theme/sato-icon-theme_0.1.bb
+++ b/meta/packages/sato-icon-theme/sato-icon-theme_0.1.bb
@@ -1,19 +1,3 @@
-SECTION = "x11"
-DESCRIPTION = "Sato Icon Theme"
-LICENSE = "CC-BY-SA3"
-DEPENDS = ""
+require sato-icon-theme.inc
-SRC_URI = "http://pokylinux.org/releases/sato/sato-icon-theme-0.1.tar.gz"
-
-inherit autotools pkgconfig
-
-FILES_${PN} += "${datadir}"
-
-PACKAGE_ARCH = "all"
-
-pkg_postinst_${PN} () {
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- gtk-update-icon-cache -q /usr/share/icons/Sato
-}
+SRC_URI = "http://pokylinux.org/releases/sato/sato-icon-theme-${PV}.tar.gz"
diff --git a/meta/packages/sato-icon-theme/sato-icon-theme_svn.bb b/meta/packages/sato-icon-theme/sato-icon-theme_svn.bb
index 5d01e1f82..595886ab9 100644
--- a/meta/packages/sato-icon-theme/sato-icon-theme_svn.bb
+++ b/meta/packages/sato-icon-theme/sato-icon-theme_svn.bb
@@ -1,21 +1,7 @@
-SECTION = "x11"
-DESCRIPTION = "Sato Icon Theme"
-LICENSE = "CC-BY-SA3"
-DEPENDS = ""
+require sato-icon-theme.inc
+
PV = "0.1+svnr${SRCREV}"
SRC_URI = "svn://svn.o-hand.com/repos/sato/trunk;module=sato-icon-theme;proto=http"
-S = "${WORKDIR}/sato-icon-theme"
-
-inherit autotools pkgconfig
-FILES_${PN} += "${datadir}"
-
-PACKAGE_ARCH = "all"
-
-pkg_postinst_${PN} () {
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- gtk-update-icon-cache -q /usr/share/icons/Sato
-}
+S = "${WORKDIR}/sato-icon-theme"