summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xmeta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session4
-rw-r--r--meta/packages/matchbox-poky/matchbox-poky_0.1.bb8
2 files changed, 7 insertions, 5 deletions
diff --git a/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
index 90073e0f1..a3dd6e56a 100755
--- a/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
+++ b/meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
@@ -8,9 +8,7 @@ SHOWCURSOR="no"
## Start up machine specific input devices. Really needs to go in its own session
case `module_id` in
- "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
- chkhinge26 /dev/input/event0 hinge-handler &
- ;;
+ # On Zaurus models, zaurusd takes care of mbinputmgr for us in its hinge scripts
"Generic OMAP1510/1610/1710")
/usr/bin/mbinputmgr &
;;
diff --git a/meta/packages/matchbox-poky/matchbox-poky_0.1.bb b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
index 4eae59007..7a4eb7299 100644
--- a/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
+++ b/meta/packages/matchbox-poky/matchbox-poky_0.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
-PR = "r16"
+PR = "r19"
SRC_URI = "file://etc"
S = ${WORKDIR}
@@ -16,5 +16,9 @@ do_install() {
pkg_postinst_matchbox-poky () {
#!/bin/sh -e
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/theme Clearlooks
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Clearlooks
}