summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/avahi/avahi.inc9
-rw-r--r--meta/packages/avahi/avahi_0.6.27.bb2
2 files changed, 10 insertions, 1 deletions
diff --git a/meta/packages/avahi/avahi.inc b/meta/packages/avahi/avahi.inc
index 4e2949319..2a5bf4a18 100644
--- a/meta/packages/avahi/avahi.inc
+++ b/meta/packages/avahi/avahi.inc
@@ -64,6 +64,15 @@ INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+do_install() {
+ autotools_do_install
+
+ # don't install /var/run when populating rootfs. Do it through volatile
+ # /var/run of current version is empty, so just remove it.
+ # if /var/run become non-empty in the future, need to install it via volatile
+ rm -rf ${D}/var/run
+}
+
# At the time the postinst runs, dbus might not be setup so only restart if running
pkg_postinst_avahi-daemon () {
diff --git a/meta/packages/avahi/avahi_0.6.27.bb b/meta/packages/avahi/avahi_0.6.27.bb
index 736c61582..a4c22a8b0 100644
--- a/meta/packages/avahi/avahi_0.6.27.bb
+++ b/meta/packages/avahi/avahi_0.6.27.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
RDEPENDS_avahi-daemon = "sysvinit-pidof"
-PR = "r0"
+PR = "r1"
EXTRA_OECONF += "--disable-gtk3"