summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-kernel/linux/linux-wrs_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-wrs_git.bb b/meta/recipes-kernel/linux/linux-wrs_git.bb
index 2459b79c8..763eaf155 100644
--- a/meta/recipes-kernel/linux/linux-wrs_git.bb
+++ b/meta/recipes-kernel/linux/linux-wrs_git.bb
@@ -49,8 +49,11 @@ do_patch() {
exit 1
fi
- # updates or generates the target description
- updateme ${ARCH} ${WORKDIR}
+ # updates or generates the target description
+ if [ -n "${KERNEL_FEATURES}" ]; then
+ addon_features="--features ${KERNEL_FEATURES}"
+ fi
+ updateme ${addon_features} ${ARCH} ${WORKDIR}
if [ $? -ne 0 ]; then
echo "ERROR. Could not update ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
exit 1