summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--openembedded/packages/dbus/dbus-0.36/cross.patch15
-rw-r--r--openembedded/packages/dbus/dbus-0.36/dbus-1.init86
-rw-r--r--openembedded/packages/dbus/dbus-0.36/no-bindings.patch12
-rw-r--r--openembedded/packages/dbus/dbus-0.36/no-examples.patch10
-rw-r--r--openembedded/packages/dbus/dbus-0.36/no-introspect.patch16
-rw-r--r--openembedded/packages/dbus/dbus-0.36/tmpdir.patch30
-rw-r--r--openembedded/packages/dbus/dbus-native_0.34.bb2
-rw-r--r--openembedded/packages/dbus/dbus.inc (renamed from openembedded/packages/dbus/dbus_0.34.inc)0
-rw-r--r--openembedded/packages/dbus/dbus_0.34.bb2
-rw-r--r--openembedded/packages/dbus/dbus_0.36.bb16
-rw-r--r--openembedded/packages/gtk+/gtk+-2.6.7/xsettings.patch16
-rw-r--r--openembedded/packages/gtk+/gtk+-2.8.3/xsettings.patch16
-rw-r--r--openembedded/packages/gtk+/gtk+_2.6.7.bb3
-rw-r--r--openembedded/packages/gtk+/gtk+_2.8.3.bb4
-rw-r--r--openembedded/packages/meta/meta-oh.bb1
-rw-r--r--readme.txt3
16 files changed, 194 insertions, 38 deletions
diff --git a/openembedded/packages/dbus/dbus-0.36/cross.patch b/openembedded/packages/dbus/dbus-0.36/cross.patch
new file mode 100644
index 000000000..6d1d9d8e7
--- /dev/null
+++ b/openembedded/packages/dbus/dbus-0.36/cross.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- dbus-0.20/configure.in~cross
++++ dbus-0.20/configure.in
+@@ -466,6 +466,7 @@
+ exit (0);
+ ]])],
+ [have_abstract_sockets=yes],
++ [have_abstract_sockets=no],
+ [have_abstract_sockets=no])
+ AC_LANG_POP(C)
+ AC_MSG_RESULT($have_abstract_sockets)
diff --git a/openembedded/packages/dbus/dbus-0.36/dbus-1.init b/openembedded/packages/dbus/dbus-0.36/dbus-1.init
new file mode 100644
index 000000000..adefe7c5b
--- /dev/null
+++ b/openembedded/packages/dbus/dbus-0.36/dbus-1.init
@@ -0,0 +1,86 @@
+#! /bin/sh
+# -*- coding: utf-8 -*-
+# Debian init.d script for D-BUS
+# Copyright © 2003 Colin Walters <walters@debian.org>
+
+set -e
+
+DAEMON=/usr/bin/dbus-daemon-1
+NAME=dbus-1
+DAEMONUSER=messagebus
+PIDDIR=/var/run/dbus
+PIDFILE=$PIDDIR/pid
+DESC="system message bus"
+EVENTDIR=/etc/dbus-1/event.d
+
+test -x $DAEMON || exit 0
+
+# Source defaults file; edit that file to configure this script.
+ENABLED=1
+PARAMS=""
+if [ -e /etc/default/dbus-1 ]; then
+ . /etc/default/dbus-1
+fi
+
+test "$ENABLED" != "0" || exit 0
+
+start_it_up()
+{
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER $PIDDIR
+ chgrp $DAEMONUSER $PIDDIR
+ fi
+ if [ -e $PIDFILE ]; then
+ PIDDIR=/proc/$(cat $PIDFILE)
+ if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
+ echo "$DESC already started; not starting."
+ else
+ echo "Removing stale PID file $PIDFILE."
+ rm -f $PIDFILE
+ fi
+ fi
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ if [ -d $EVENTDIR ]; then
+ run-parts --arg=start $EVENTDIR
+ fi
+}
+
+shut_it_down()
+{
+ if [ -d $EVENTDIR ]; then
+ run-parts --reverse --arg=stop $EVENTDIR
+ fi
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER
+ # We no longer include these arguments so that start-stop-daemon
+ # can do its job even given that we may have been upgraded.
+ # We rely on the pidfile being sanely managed
+ # --exec $DAEMON -- --system $PARAMS
+ echo "$NAME."
+ rm -f $PIDFILE
+}
+
+case "$1" in
+ start)
+ start_it_up
+ ;;
+ stop)
+ shut_it_down
+ ;;
+ restart|force-reload)
+ shut_it_down
+ sleep 1
+ start_it_up
+ ;;
+ *)
+ echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/openembedded/packages/dbus/dbus-0.36/no-bindings.patch b/openembedded/packages/dbus/dbus-0.36/no-bindings.patch
new file mode 100644
index 000000000..12ba00ff7
--- /dev/null
+++ b/openembedded/packages/dbus/dbus-0.36/no-bindings.patch
@@ -0,0 +1,12 @@
+--- dbus-0.34/tools/Makefile.am.old 2005-06-27 21:48:44.000000000 +0100
++++ dbus-0.34/tools/Makefile.am 2005-06-27 21:49:04.000000000 +0100
+@@ -6,9 +6,6 @@
+ nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+-dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/glib/dbus-binding-tool
+- $(top_builddir)/glib/dbus-binding-tool --mode=glib-client --output=dbus-glib-bindings.h dbus-bus-introspect.xml
+-
+ BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+
+ else
diff --git a/openembedded/packages/dbus/dbus-0.36/no-examples.patch b/openembedded/packages/dbus/dbus-0.36/no-examples.patch
new file mode 100644
index 000000000..531646cfb
--- /dev/null
+++ b/openembedded/packages/dbus/dbus-0.36/no-examples.patch
@@ -0,0 +1,10 @@
+Index: dbus-0.36/glib/Makefile.am
+===================================================================
+--- dbus-0.36.orig/glib/Makefile.am 2005-08-04 15:49:30.000000000 +0000
++++ dbus-0.36/glib/Makefile.am 2005-09-02 12:42:17.000000000 +0000
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++#SUBDIRS = . examples
+
+ INCLUDES=-I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
+
diff --git a/openembedded/packages/dbus/dbus-0.36/no-introspect.patch b/openembedded/packages/dbus/dbus-0.36/no-introspect.patch
new file mode 100644
index 000000000..822afccf0
--- /dev/null
+++ b/openembedded/packages/dbus/dbus-0.36/no-introspect.patch
@@ -0,0 +1,16 @@
+Index: dbus-0.36/tools/Makefile.am
+===================================================================
+--- dbus-0.36.orig/tools/Makefile.am 2005-07-08 16:25:28.000000000 +0000
++++ dbus-0.36/tools/Makefile.am 2005-09-02 12:26:02.000000000 +0000
+@@ -21,11 +21,6 @@
+ GTK_TOOLS=
+ endif
+
+-if HAVE_GLIB
+-dbus-bus-introspect.xml: $(top_builddir)/bus/dbus-daemon dbus-launch dbus-send $(top_builddir)/bus/dbus-daemon Makefile
+- DBUS_TOP_BUILDDIR=$(top_builddir) $(srcdir)/run-with-tmp-session-bus.sh ./dbus-send --print-reply=literal --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.Introspectable.Introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
+-endif
+-
+ bin_PROGRAMS=dbus-send $(GLIB_TOOLS) dbus-launch dbus-cleanup-sockets $(GTK_TOOLS)
+
+ dbus_send_SOURCES= \
diff --git a/openembedded/packages/dbus/dbus-0.36/tmpdir.patch b/openembedded/packages/dbus/dbus-0.36/tmpdir.patch
new file mode 100644
index 000000000..838b903f0
--- /dev/null
+++ b/openembedded/packages/dbus/dbus-0.36/tmpdir.patch
@@ -0,0 +1,30 @@
+--- dbus-0.22/configure.in.orig 2004-08-13 00:57:16.000000000 +0200
++++ dbus-0.22/configure.in 2004-12-30 21:15:57.000000000 +0100
+@@ -1047,15 +1048,18 @@
+ AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
+
+ #### Find socket directories
+-if ! test -z "$TMPDIR" ; then
+- DEFAULT_SOCKET_DIR=$TMPDIR
+-elif ! test -z "$TEMP" ; then
+- DEFAULT_SOCKET_DIR=$TEMP
+-elif ! test -z "$TMP" ; then
+- DEFAULT_SOCKET_DIR=$TMP
+-else
+- DEFAULT_SOCKET_DIR=/tmp
+-fi
++#if ! test -z "$TMPDIR" ; then
++# DEFAULT_SOCKET_DIR=$TMPDIR
++#elif ! test -z "$TEMP" ; then
++# DEFAULT_SOCKET_DIR=$TEMP
++#elif ! test -z "$TMP" ; then
++# DEFAULT_SOCKET_DIR=$TMP
++#else
++# DEFAULT_SOCKET_DIR=/tmp
++#fi
++
++# checks disabled to avoid expanding this at build time
++DEFAULT_SOCKET_DIR=/tmp
+
+ if ! test -z "$with_test_socket_dir" ; then
+ TEST_SOCKET_DIR="$with_test_socket_dir"
diff --git a/openembedded/packages/dbus/dbus-native_0.34.bb b/openembedded/packages/dbus/dbus-native_0.34.bb
index 916f7ad8e..a84530d4d 100644
--- a/openembedded/packages/dbus/dbus-native_0.34.bb
+++ b/openembedded/packages/dbus/dbus-native_0.34.bb
@@ -1,4 +1,4 @@
-include dbus_${PV}.inc
+include dbus.inc
SRC_URI_EXTRA=""
diff --git a/openembedded/packages/dbus/dbus_0.34.inc b/openembedded/packages/dbus/dbus.inc
index 1c63c37fd..1c63c37fd 100644
--- a/openembedded/packages/dbus/dbus_0.34.inc
+++ b/openembedded/packages/dbus/dbus.inc
diff --git a/openembedded/packages/dbus/dbus_0.34.bb b/openembedded/packages/dbus/dbus_0.34.bb
index a1d19897c..35fed844e 100644
--- a/openembedded/packages/dbus/dbus_0.34.bb
+++ b/openembedded/packages/dbus/dbus_0.34.bb
@@ -1,4 +1,4 @@
-include dbus_${PV}.inc
+include dbus.inc
DEPENDS = "expat glib-2.0 virtual/libintl dbus-native"
diff --git a/openembedded/packages/dbus/dbus_0.36.bb b/openembedded/packages/dbus/dbus_0.36.bb
new file mode 100644
index 000000000..a45396adb
--- /dev/null
+++ b/openembedded/packages/dbus/dbus_0.36.bb
@@ -0,0 +1,16 @@
+include dbus.inc
+
+
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-native"
+SRC_URI_EXTRA = " \
+ file://no-introspect.patch;patch=1 \
+ file://no-bindings.patch;patch=1 \
+ file://no-examples.patch;patch=1"
+
+FILES_${PN} += "${bindir}/dbus-daemon"
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/
+}
diff --git a/openembedded/packages/gtk+/gtk+-2.6.7/xsettings.patch b/openembedded/packages/gtk+/gtk+-2.6.7/xsettings.patch
deleted file mode 100644
index b63e262d3..000000000
--- a/openembedded/packages/gtk+/gtk+-2.6.7/xsettings.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- gtk+-2.4.4/gdk/x11/gdkevents-x11.c.old Sun Aug 22 17:14:00 2004
-+++ gtk+-2.4.4/gdk/x11/gdkevents-x11.c Sun Aug 22 17:14:00 2004
-@@ -2827,10 +2827,9 @@
- {
- GdkScreenX11 *screen = data;
-
-- if (xsettings_client_process_event (screen->xsettings_client, (XEvent *)xevent))
-- return GDK_FILTER_REMOVE;
-- else
-- return GDK_FILTER_CONTINUE;
-+ xsettings_client_process_event (screen->xsettings_client, (XEvent *)xevent);
-+
-+ return GDK_FILTER_CONTINUE;
- }
-
- static void
diff --git a/openembedded/packages/gtk+/gtk+-2.8.3/xsettings.patch b/openembedded/packages/gtk+/gtk+-2.8.3/xsettings.patch
deleted file mode 100644
index b63e262d3..000000000
--- a/openembedded/packages/gtk+/gtk+-2.8.3/xsettings.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- gtk+-2.4.4/gdk/x11/gdkevents-x11.c.old Sun Aug 22 17:14:00 2004
-+++ gtk+-2.4.4/gdk/x11/gdkevents-x11.c Sun Aug 22 17:14:00 2004
-@@ -2827,10 +2827,9 @@
- {
- GdkScreenX11 *screen = data;
-
-- if (xsettings_client_process_event (screen->xsettings_client, (XEvent *)xevent))
-- return GDK_FILTER_REMOVE;
-- else
-- return GDK_FILTER_CONTINUE;
-+ xsettings_client_process_event (screen->xsettings_client, (XEvent *)xevent);
-+
-+ return GDK_FILTER_CONTINUE;
- }
-
- static void
diff --git a/openembedded/packages/gtk+/gtk+_2.6.7.bb b/openembedded/packages/gtk+/gtk+_2.6.7.bb
index 2e8179279..54e0e0e6e 100644
--- a/openembedded/packages/gtk+/gtk+_2.6.7.bb
+++ b/openembedded/packages/gtk+/gtk+_2.6.7.bb
@@ -6,7 +6,7 @@ SECTION = "libs"
PRIORITY = "optional"
MAINTAINER = "Philip Blundell <pb@handhelds.org>"
DEPENDS = "glib-2.0 pango atk jpeg libpng xext libxcursor gtk-doc libgcrypt"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://no-demos.patch;patch=1 \
@@ -18,7 +18,6 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
file://disable-tooltips.patch;patch=1 \
file://gtklabel-resize-patch;patch=1 \
file://menu-deactivate.patch;patch=1 \
- file://xsettings.patch;patch=1 \
file://scroll-timings.patch;patch=1 \
file://small-gtkfilesel.patch;patch=1 \
file://migration.patch;patch=1;pnum=0 \
diff --git a/openembedded/packages/gtk+/gtk+_2.8.3.bb b/openembedded/packages/gtk+/gtk+_2.8.3.bb
index f697e6ae5..cf32491db 100644
--- a/openembedded/packages/gtk+/gtk+_2.8.3.bb
+++ b/openembedded/packages/gtk+/gtk+_2.8.3.bb
@@ -13,12 +13,12 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.8/gtk+-${PV}.tar.bz2 \
file://automake-lossage.patch;patch=1 \
file://hardcoded_libtool.patch;patch=1 \
file://disable-tooltips.patch;patch=1 \
- file://gtklabel-resize-patch;patch=1
+ file://gtklabel-resize-patch;patch=1"
# file://menu-deactivate.patch;patch=1 \
# file://xsettings.patch;patch=1 \
# file://scroll-timings.patch;patch=1 \
# file://small-gtkfilesel.patch;patch=1 \
-# file://migration.patch;patch=1;pnum=0"
+# file://migration.patch;patch=1;pnum=0
# file://no-demos.patch;patch=1
# file://gtk+-handhelds.patch;patch=1
# file://single-click.patch;patch=1
diff --git a/openembedded/packages/meta/meta-oh.bb b/openembedded/packages/meta/meta-oh.bb
index 09e56c5ef..cf28f2b5e 100644
--- a/openembedded/packages/meta/meta-oh.bb
+++ b/openembedded/packages/meta/meta-oh.bb
@@ -17,6 +17,7 @@ oh-task-base = "\
matchbox \
xcursor-transparent-theme \
xserver-kdrive-common \
+ gtk+ \
avahi \
rxvt \
xhost \
diff --git a/readme.txt b/readme.txt
index d35ba3004..3f3fad72b 100644
--- a/readme.txt
+++ b/readme.txt
@@ -14,6 +14,9 @@ MACHINE = "nokia770"
in build/conf/local.conf
+NOTE: The above commands must be run in the build directory. Running
+them anywhere else will cause confusion.
+
Notes:
===