summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/binutils/binutils-cross-sdk.inc34
-rw-r--r--meta/packages/binutils/binutils-cross-sdk_2.17.50.0.5.bb20
2 files changed, 54 insertions, 0 deletions
diff --git a/meta/packages/binutils/binutils-cross-sdk.inc b/meta/packages/binutils/binutils-cross-sdk.inc
new file mode 100644
index 000000000..6cc057907
--- /dev/null
+++ b/meta/packages/binutils/binutils-cross-sdk.inc
@@ -0,0 +1,34 @@
+inherit sdk
+DEPENDS += "flex-native bison-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
+EXTRA_OECONF = "--with-sysroot=${CROSS_DIR}/${TARGET_SYS} \
+ --program-prefix=${TARGET_PREFIX}"
+
+
+FILES_binutils-cross-sdk-dbg = ""
+do_install () {
+ autotools_do_install
+
+ # We don't really need these, so we'll remove them...
+ rm -rf ${D}${libdir}/ldscripts
+
+ # Fix the /usr/${TARGET_SYS}/bin/* links
+ for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
+ rm -f $l
+ ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
+ | tr -s / \
+ | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
+ done
+
+ # Install the libiberty header
+ install -d ${D}${includedir}
+ install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
+ install -m 644 ${S}/include/libiberty.h ${D}${includedir}
+
+ cd ${D}${bindir}
+
+ # Symlinks for ease of running these on the native target
+ for p in ${TARGET_SYS}-* ; do
+ ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
+ done
+}
diff --git a/meta/packages/binutils/binutils-cross-sdk_2.17.50.0.5.bb b/meta/packages/binutils/binutils-cross-sdk_2.17.50.0.5.bb
new file mode 100644
index 000000000..7d3bb6c09
--- /dev/null
+++ b/meta/packages/binutils/binutils-cross-sdk_2.17.50.0.5.bb
@@ -0,0 +1,20 @@
+SECTION = "devel"
+require binutils_${PV}.bb
+inherit sdk
+DEPENDS += "flex-native bison-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
+EXTRA_OECONF = "--with-sysroot=${CROSS_DIR}/${TARGET_SYS} \
+ --program-prefix=${TARGET_PREFIX}"
+
+do_stage() {
+ :
+}
+
+do_install () {
+ autotools_do_install
+
+ # Install the libiberty header
+ install -d ${D}${includedir}
+ install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
+ install -m 644 ${S}/include/libiberty.h ${D}${includedir}
+}