summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/alsa/alsa-fpu.inc6
-rw-r--r--meta/packages/alsa/alsa-lib_1.0.14.bb5
2 files changed, 10 insertions, 1 deletions
diff --git a/meta/packages/alsa/alsa-fpu.inc b/meta/packages/alsa/alsa-fpu.inc
new file mode 100644
index 000000000..ebd3493e6
--- /dev/null
+++ b/meta/packages/alsa/alsa-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_alsa_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--with-softfloat"
+ return ""
+
diff --git a/meta/packages/alsa/alsa-lib_1.0.14.bb b/meta/packages/alsa/alsa-lib_1.0.14.bb
index de805b9a4..ba46342ae 100644
--- a/meta/packages/alsa/alsa-lib_1.0.14.bb
+++ b/meta/packages/alsa/alsa-lib_1.0.14.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.alsa-project.org"
SECTION = "libs/multimedia"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
# configure.in sets -D__arm__ on the command line for any arm system
# (not just those with the ARM instruction set), this should be removed,
@@ -17,6 +17,9 @@ SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
inherit autotools pkgconfig
+require alsa-fpu.inc
+EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
+
EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
do_stage () {