summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/dbus/dbus.inc12
-rw-r--r--meta/recipes-core/dbus/dbus_1.4.1.bb2
2 files changed, 10 insertions, 4 deletions
diff --git a/meta/recipes-core/dbus/dbus.inc b/meta/recipes-core/dbus/dbus.inc
index 2a5f8bdb9..38acf354f 100644
--- a/meta/recipes-core/dbus/dbus.inc
+++ b/meta/recipes-core/dbus/dbus.inc
@@ -49,13 +49,17 @@ pkg_postinst_dbus() {
MESSAGEUSER=messagebus
MESSAGEHOME=/var/run/dbus
+ UUIDDIR=/var/lib/dbus
- mkdir -p $MESSAGEHOME || true
+ mkdir -p $MESSAGEHOME
+ mkdir -p $UUIDDIR
chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER"
- chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || \
+ chown "$MESSAGEUSER":"$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || \
adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password \
--ingroup "$MESSAGEUSER" "$MESSAGEUSER"
+ chown "$MESSAGEUSER":"$MESSAGEUSER" "$UUIDDIR"
+
grep -q netdev: /etc/group || addgroup netdev
chown root:"$MESSAGEUSER" /usr/libexec/dbus-daemon-launch-helper
@@ -63,7 +67,9 @@ pkg_postinst_dbus() {
# add volatile after new user/grp are created
echo "d messagebus messagebus 0755 /var/run/dbus none" > /etc/default/volatiles/99_dbus
- /etc/init.d/populate-volatile.sh update
+ if [ -e /etc/init.d/populate-volatile.sh ] ; then
+ /etc/init.d/populate-volatile.sh update
+ fi
}
EXTRA_OECONF_X = "--with-x"
diff --git a/meta/recipes-core/dbus/dbus_1.4.1.bb b/meta/recipes-core/dbus/dbus_1.4.1.bb
index 1c8aeaa5c..f65ef35b9 100644
--- a/meta/recipes-core/dbus/dbus_1.4.1.bb
+++ b/meta/recipes-core/dbus/dbus_1.4.1.bb
@@ -1,6 +1,6 @@
include dbus.inc
-PR = "r4"
+PR = "r5"
SRC_URI[md5sum] = "99cb057700c0455fb68f8d57902f77ac"
SRC_URI[sha256sum] = "caa1a0ded2d0f2e95c1d4ec7e3c8bd44834928c5b0ed41a7189963f3593983bd"