summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch11
-rw-r--r--meta/packages/oprofile/oprofile_cvs.bb1
2 files changed, 12 insertions, 0 deletions
diff --git a/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch b/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch
new file mode 100644
index 000000000..ab4d7f421
--- /dev/null
+++ b/meta/packages/oprofile/oprofile/oparchive-exit-code-on-error.patch
@@ -0,0 +1,11 @@
+Index: oprofile/pp/oparchive.cpp
+===================================================================
+--- oprofile.orig/pp/oparchive.cpp 2007-02-27 18:15:52.000000000 +0000
++++ oprofile/pp/oparchive.cpp 2007-02-27 18:16:08.000000000 +0000
+@@ -164,5 +164,5 @@
+
+ int main(int argc, char const * argv[])
+ {
+- run_pp_tool(argc, argv, oparchive);
++ return run_pp_tool(argc, argv, oparchive);
+ }
diff --git a/meta/packages/oprofile/oprofile_cvs.bb b/meta/packages/oprofile/oprofile_cvs.bb
index 034ea51ff..4c4570981 100644
--- a/meta/packages/oprofile/oprofile_cvs.bb
+++ b/meta/packages/oprofile/oprofile_cvs.bb
@@ -12,6 +12,7 @@ SRC_URI = "cvs://anonymous@oprofile.cvs.sourceforge.net/cvsroot/oprofile;module=
file://oparchive-list-files.patch;patch=1 \
file://opreport-xml-output-fixes.patch;patch=1 \
file://xml_callgraph.patch;patch=1 \
+ file://oparchive-exit-code-on-error.patch;patch=1 \
file://acinclude.m4"
S = "${WORKDIR}/oprofile"