summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/qemu/qemu-0.12.4/init-info.patch16
-rw-r--r--meta/packages/qemu/qemu_0.12.4.bb1
2 files changed, 17 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-0.12.4/init-info.patch b/meta/packages/qemu/qemu-0.12.4/init-info.patch
new file mode 100644
index 000000000..8ba7d8ff4
--- /dev/null
+++ b/meta/packages/qemu/qemu-0.12.4/init-info.patch
@@ -0,0 +1,16 @@
+# This is a workaround to the crashes seen on Ubuntu. Setting info to zero
+# makes info.info.x11.display zero and avoids the calls to
+# opengl_exec_set_parent_window, one of which is crashing.
+
+Index: qemu-0.12.4/sdl.c
+===================================================================
+--- qemu-0.12.4.orig/sdl.c
++++ qemu-0.12.4/sdl.c
+@@ -871,6 +871,7 @@ void sdl_display_init(DisplayState *ds,
+ vi = SDL_GetVideoInfo();
+ host_format = *(vi->vfmt);
+
++ bzero(&info, sizeof(info));
+ SDL_GetWMInfo(&info);
+ if (info.subsystem == SDL_SYSWM_X11 && info.info.x11.display)
+ opengl_exec_set_parent_window(info.info.x11.display,
diff --git a/meta/packages/qemu/qemu_0.12.4.bb b/meta/packages/qemu/qemu_0.12.4.bb
index 79b73d38a..f1ecf3c06 100644
--- a/meta/packages/qemu/qemu_0.12.4.bb
+++ b/meta/packages/qemu/qemu_0.12.4.bb
@@ -14,5 +14,6 @@ SRC_URI = "\
file://fix-nogl.patch \
file://qemugl-allow-glxcontext-release.patch \
file://linker-flags.patch"
+ file://init-info.patch;patch=1"
S = "${WORKDIR}/qemu-${PV}"