summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xopenembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session2
-rw-r--r--openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session b/openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
index 033ba8b24..f20340a53 100755
--- a/openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
+++ b/openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
@@ -1,4 +1,4 @@
#!/bin/sh
matchbox-desktop --icon-size 64 &
-matchbox-panel --orientation east --no-menu --no-session --default-apps mb-applet-clock,mb-applet-battery &
+matchbox-panel --orientation east --no-menu --no-session --default-apps mbinputmgr,mb-applet-startup-monitor,mb-applet-clock,mb-applet-battery &
exec matchbox-window-manager $@
diff --git a/openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb b/openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb
index 0d4edc340..cacd39428 100644
--- a/openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb
+++ b/openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb
@@ -1,7 +1,8 @@
DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
-PR = "r0"
+DEPENDS = "matchbox matchbox-applet-inputmanager matchbox-applet-startup-monitor"
+PR = "r1"
SRC_URI = "file://etc"
S = ${WORKDIR}
@@ -9,4 +10,4 @@ S = ${WORKDIR}
do_install() {
cp -R ${S}/etc ${D}/etc
chmod -R 755 ${D}/etc
-} \ No newline at end of file
+}