summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch10
-rw-r--r--meta/packages/mutter/mutter.inc47
-rw-r--r--meta/packages/mutter/mutter_2.28.1.bb9
-rw-r--r--meta/packages/mutter/mutter_git.bb50
4 files changed, 59 insertions, 57 deletions
diff --git a/meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch b/meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch
deleted file mode 100644
index 3714383bc..000000000
--- a/meta/packages/mutter/fix_pkgconfig-7adb574bb3fa3880eb85dbc86e580cf3452d57c4.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: git/src/metacity-plugins.pc.in
-===================================================================
---- git.orig/src/metacity-plugins.pc.in 2008-12-17 22:42:19.000000000 +0000
-+++ git/src/metacity-plugins.pc.in 2008-12-17 22:42:25.000000000 +0000
-@@ -14,4 +14,4 @@
- Requires: @CLUTTER_PACKAGE@
- Version: @VERSION@
- Libs: @CLUTTER_LIBS@
--Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
-+Cflags: -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
diff --git a/meta/packages/mutter/mutter.inc b/meta/packages/mutter/mutter.inc
new file mode 100644
index 000000000..860d9906d
--- /dev/null
+++ b/meta/packages/mutter/mutter.inc
@@ -0,0 +1,47 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutter is metacity + clutter."
+LICENSE = "GPLv2"
+DEPENDS = "startup-notification gtk+ gconf clutter-1.0 gdk-pixbuf-csource-native intltool glib-2.0-native"
+# gobject-introspection
+inherit gnome update-alternatives
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/mutter"
+ALTERNATIVE_PRIORITY = "11"
+
+EXTRA_OECONF += "--disable-verbose \
+ --disable-xinerama \
+ --without-introspection \
+ --with-clutter"
+
+#RDEPENDS_${PN} = "zenity"
+
+FILES_${PN} += "${datadir}/themes ${libdir}/mutter/plugins/*.so ${datadir}/gnome/wm-properties/"
+FILES_${PN}-dbg += "${libdir}/mutter/plugins/.debug/*"
+
+export CC_FOR_BUILD = "${BUILD_CC}"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include"
+export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0"
+
+do_configure_prepend () {
+ echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+pkg_postinst_${PN} () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+. ${sysconfdir}/init.d/functions
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/mutter/general/clutter_plugins '[default]'
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/mutter/general/compositing_manager true
+}
+
diff --git a/meta/packages/mutter/mutter_2.28.1.bb b/meta/packages/mutter/mutter_2.28.1.bb
new file mode 100644
index 000000000..c4b810789
--- /dev/null
+++ b/meta/packages/mutter/mutter_2.28.1.bb
@@ -0,0 +1,9 @@
+require mutter.inc
+
+SRC_URI = "http://download.moblin.org/sources/mutter/2.28/mutter-2.28.1_0.0.tar.bz2 \
+ file://nodocs.patch;patch=1 \
+ file://nozenity.patch;patch=1 \
+ file://fix_pkgconfig.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/mutter-2.28.1_0.0" \ No newline at end of file
diff --git a/meta/packages/mutter/mutter_git.bb b/meta/packages/mutter/mutter_git.bb
index 7352cf8a9..b41bf1e50 100644
--- a/meta/packages/mutter/mutter_git.bb
+++ b/meta/packages/mutter/mutter_git.bb
@@ -1,11 +1,7 @@
-SECTION = "x11/wm"
-DESCRIPTION = "Metacity is the boring window manager for the adult in you. Mutter is metacity + clutter."
-LICENSE = "GPLv2"
-DEPENDS = "startup-notification gtk+ gconf clutter-1.0 gdk-pixbuf-csource-native intltool glib-2.0-native"
-# gobject-introspection
-PR = "r18"
+require mutter.inc
+
PV = "2.28.1+git${SRCPV}"
-inherit gnome update-alternatives
+PR = "r18"
# Gnome is the upstream but moblin is under more active development atm
# git://git.gnome.org/mutter.git;protocol=git;branch=master
@@ -19,43 +15,3 @@ SRC_URI = "git://git.moblin.org/mutter.git;protocol=git;branch=master \
"
S = "${WORKDIR}/git"
-ALTERNATIVE_NAME = "x-window-manager"
-ALTERNATIVE_LINK = "${bindir}/x-window-manager"
-ALTERNATIVE_PATH = "${bindir}/mutter"
-ALTERNATIVE_PRIORITY = "11"
-
-EXTRA_OECONF += "--disable-verbose \
- --disable-xinerama \
- --without-introspection \
- --with-clutter"
-
-#RDEPENDS_${PN} = "zenity"
-
-FILES_${PN} += "${datadir}/themes ${libdir}/mutter/plugins/*.so ${datadir}/gnome/wm-properties/"
-FILES_${PN}-dbg += "${libdir}/mutter/plugins/.debug/*"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include"
-export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0"
-
-do_configure_prepend () {
- echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make
-}
-
-do_stage () {
- autotools_stage_all
-}
-
-pkg_postinst_${PN} () {
-#!/bin/sh -e
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-. ${sysconfdir}/init.d/functions
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/mutter/general/clutter_plugins '[default]'
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/mutter/general/compositing_manager true
-}
-