summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--bitbake/lib/bb/fetch/git.py1
-rw-r--r--openembedded/packages/meta/task-oh.bb8
2 files changed, 5 insertions, 4 deletions
diff --git a/bitbake/lib/bb/fetch/git.py b/bitbake/lib/bb/fetch/git.py
index 439d52218..f30ae2360 100644
--- a/bitbake/lib/bb/fetch/git.py
+++ b/bitbake/lib/bb/fetch/git.py
@@ -134,6 +134,7 @@ class Git(Fetch):
os.chdir(repodir)
rungitcmd("git pull %s://%s%s" % (proto, host, path),d)
rungitcmd("git pull --tags %s://%s%s" % (proto, host, path),d)
+ rungitcmd("git prune-packed", d)
# old method of downloading tags
#rungitcmd("rsync -a --verbose --stats --progress rsync://%s%s/ %s" % (host, path, os.path.join(repodir, ".git", "")),d)
diff --git a/openembedded/packages/meta/task-oh.bb b/openembedded/packages/meta/task-oh.bb
index 7d3dd4248..c374a2eea 100644
--- a/openembedded/packages/meta/task-oh.bb
+++ b/openembedded/packages/meta/task-oh.bb
@@ -1,7 +1,7 @@
PACKAGES = "task-oh-base task-oh-devel task-oh-boot task-oh-standard task-oh-boot-extras task-oh-boot-min-extras"
DESCRIPTION = "Tasks for OpenedHand Poky"
MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r27"
+PR = "r28"
ALLOW_EMPTY = "1"
@@ -35,6 +35,9 @@ RDEPENDS_task-oh-base := "\
matchbox \
xserver-kdrive-common \
xserver-nodm-init \
+ ttf-bitstream-vera \
+ xauth \
+ xhost \
udev \
sysfsutils \
leafpad \
@@ -66,9 +69,6 @@ RDEPENDS_task-oh-standard := "\
puzzles \
kf \
rxvt-unicode \
- xhost \
- ttf-bitstream-vera \
- xauth \
avahi-daemon \
gdk-pixbuf-loader-png \
gdk-pixbuf-loader-gif \