summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta-moblin/packages/aspell/aspell_0.60.6.bb15
-rw-r--r--meta-moblin/packages/enchant/enchant_1.3.0.bb20
-rw-r--r--meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch15
-rw-r--r--meta-moblin/packages/libsexy/libsexy.inc13
-rw-r--r--meta-moblin/packages/libsexy/libsexy_0.1.11.bb2
5 files changed, 65 insertions, 0 deletions
diff --git a/meta-moblin/packages/aspell/aspell_0.60.6.bb b/meta-moblin/packages/aspell/aspell_0.60.6.bb
new file mode 100644
index 000000000..de0cfa6aa
--- /dev/null
+++ b/meta-moblin/packages/aspell/aspell_0.60.6.bb
@@ -0,0 +1,15 @@
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz"
+DESCRIPTION = "GNU Aspell spell-checker"
+SECTION = "console/utils"
+LICENSE="LGPL"
+
+PACKAGES += "libaspell libpspell libpspell-dev aspell-utils"
+
+FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*"
+FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
+FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
+FILES_${PN} = "${bindir}/aspell"
+FILES_libpspell = "${libdir}/libpspell.so.*"
+FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
+
+inherit autotools_stage
diff --git a/meta-moblin/packages/enchant/enchant_1.3.0.bb b/meta-moblin/packages/enchant/enchant_1.3.0.bb
new file mode 100644
index 000000000..e9e8a898c
--- /dev/null
+++ b/meta-moblin/packages/enchant/enchant_1.3.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Enchant Spell checker API Library"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "aspell"
+RDEPENDS = "aspell"
+
+inherit autotools_stage pkgconfig
+
+PR = "r1"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz"
+
+EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-aspell --disable-binreloc"
+
+FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}/*.so"
+FILES_${PN}-dev += "${libdir}/${PN}/*{SOLIBSDEV} ${libdir}/${PN}/*.la ${libdir}/${PN}/*.a"
+
+export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
diff --git a/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch b/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch
new file mode 100644
index 000000000..61da9474d
--- /dev/null
+++ b/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch
@@ -0,0 +1,15 @@
+Index: libsexy-0.1.11/libsexy.pc.in
+===================================================================
+--- libsexy-0.1.11.orig/libsexy.pc.in 2005-11-10 10:21:18.000000000 +0000
++++ libsexy-0.1.11/libsexy.pc.in 2008-03-05 14:36:39.000000000 +0000
+@@ -6,7 +6,8 @@
+ Name: libsexy
+ Description: Doing naughty things to good widgets
+ Version: @VERSION@
+-Libs: -L${libdir} -lsexy @PACKAGE_LIBS@
+-Cflags: -I${includedir} @PACKAGE_CFLAGS@
+
++Requires: pango glib-2.0 gtk+-2.0 libxml-2.0
++Libs: -L${libdir} -lsexy
++Cflags: -I${includedir}
+
diff --git a/meta-moblin/packages/libsexy/libsexy.inc b/meta-moblin/packages/libsexy/libsexy.inc
new file mode 100644
index 000000000..473faf5e6
--- /dev/null
+++ b/meta-moblin/packages/libsexy/libsexy.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Libsexy is a collection of GTK+ widgets that extend the functionality of such standard widgets as GtkEntry and GtkLabel"
+HOMEPAGE = "http://wiki.chipx86.com/wiki/Libsexy"
+AUTHOR = "Christian Hammond <chipx86@chipx86.com>"
+SECTION = "x11/libs"
+
+DEPENDS = "gtk+ enchant libxml2"
+
+SRC_URI = "http://releases.chipx86.com/libsexy/${PN}/${PN}-${PV}.tar.gz \
+ file://libsexy-pkgconfig-fixes.patch;patch=1"
+
+inherit autotools_stage pkgconfig
+
+
diff --git a/meta-moblin/packages/libsexy/libsexy_0.1.11.bb b/meta-moblin/packages/libsexy/libsexy_0.1.11.bb
new file mode 100644
index 000000000..91784ffb4
--- /dev/null
+++ b/meta-moblin/packages/libsexy/libsexy_0.1.11.bb
@@ -0,0 +1,2 @@
+require libsexy.inc
+PR = "r1"