summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/linux/linux-rp-2.6.23/w100fb-unused-var.patch17
-rw-r--r--meta/packages/linux/linux-rp_2.6.23.bb1
2 files changed, 18 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-rp-2.6.23/w100fb-unused-var.patch b/meta/packages/linux/linux-rp-2.6.23/w100fb-unused-var.patch
new file mode 100644
index 000000000..8cbbb6bd0
--- /dev/null
+++ b/meta/packages/linux/linux-rp-2.6.23/w100fb-unused-var.patch
@@ -0,0 +1,17 @@
+From: Marcin Juszkiewicz <openembedded@haerwu.biz>
+
+drivers/video/w100fb.c: In function ‘w100fb_imageblit’:
+drivers/video/w100fb.c:507: warning: unused variable ‘par’
+
+Signed-off-by: Marcin Juszkiewicz <openembedded@haerwu.biz>
+
+--- linux-2.6.23/drivers/video/w100fb.c 2007-10-11 16:52:30.000000000 +0200
++++ linux-2.6.23/drivers/video/w100fb.c 2007-10-15 12:56:01.000000000 +0200
+@@ -504,7 +504,6 @@ static void w100_hostdata(u32 width, u32
+ static void w100fb_imageblit(struct fb_info *info,
+ const struct fb_image *image)
+ {
+- struct w100fb_par *par = info->par;
+ union dp_gui_master_cntl_u gmc;
+ u32 fgcolor, bgcolor;
+
diff --git a/meta/packages/linux/linux-rp_2.6.23.bb b/meta/packages/linux/linux-rp_2.6.23.bb
index 6e9b30423..16858800b 100644
--- a/meta/packages/linux/linux-rp_2.6.23.bb
+++ b/meta/packages/linux/linux-rp_2.6.23.bb
@@ -39,6 +39,7 @@ SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2 \
${RPSRC}/pxa27x_overlay-r6.patch;patch=1 \
${RPSRC}/w100_extaccel-r1.patch;patch=1 \
${RPSRC}/w100_extmem-r1.patch;patch=1 \
+ file://w100fb-unused-var.patch;patch=1 \
file://hostap-monitor-mode.patch;patch=1 \
file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1 \
${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \