summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/cairo/cairo-fpu.inc6
-rw-r--r--meta/packages/cairo/cairo_1.3.6.bb20
2 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/cairo/cairo-fpu.inc b/meta/packages/cairo/cairo-fpu.inc
new file mode 100644
index 000000000..bdaf78979
--- /dev/null
+++ b/meta/packages/cairo/cairo-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_cairo_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--disable-some-floating-point"
+ return ""
+
diff --git a/meta/packages/cairo/cairo_1.3.6.bb b/meta/packages/cairo/cairo_1.3.6.bb
new file mode 100644
index 000000000..d9454fadc
--- /dev/null
+++ b/meta/packages/cairo/cairo_1.3.6.bb
@@ -0,0 +1,20 @@
+#This is a development snapshot, so lets hint OE to use the releases
+DEFAULT_PREFERENCE = "-1"
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 libsm libpng fontconfig libxrender"
+DESCRIPTION = "Cairo graphics library"
+LICENSE = "MPL LGPL"
+
+SRC_URI = "http://cairographics.org/snapshots/cairo-${PV}.tar.gz"
+
+#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require cairo-fpu.inc
+EXTRA_OECONF += "${@get_cairo_fpu_setting(bb, d)}"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}