summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--bitbake-dev/lib/bb/fetch/wget.py25
-rw-r--r--bitbake/lib/bb/fetch/wget.py25
-rw-r--r--meta-moblin/packages/sreadahead/sreadahead_0.02.bb6
-rw-r--r--meta/classes/autotools.bbclass38
-rw-r--r--meta/classes/base.bbclass7
-rw-r--r--meta/classes/packaged-staging.bbclass3
-rw-r--r--meta/packages/drm/libdrm_2.4.0.bb1
-rw-r--r--meta/packages/drm/libdrm_git.bb2
-rw-r--r--meta/packages/e2fsprogs/e2fsprogs_1.41.2.bb2
-rw-r--r--meta/packages/packkagekit/files/no_validate.patch21
-rw-r--r--meta/packages/packkagekit/packagekit_0.3.8.bb9
-rw-r--r--meta/packages/pam/files/disable_crossbinary.patch34
-rw-r--r--meta/packages/pam/pam_1.0.2.bb5
-rw-r--r--meta/packages/policykit/policykit_0.9.bb2
-rw-r--r--meta/packages/syslinux/syslinux-installer-native_3.36.bb1
-rw-r--r--meta/packages/uuid/files/fixes.patch42
-rw-r--r--meta/packages/uuid/uuid_1.6.2.bb15
-rwxr-xr-xscripts/poky-autobuild-moblin8
19 files changed, 153 insertions, 94 deletions
diff --git a/.gitignore b/.gitignore
index b19697147..0b13ee1f5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.pyc
+build/conf/local.conf
build/tmp/
sources/
meta-moblin-internal
diff --git a/bitbake-dev/lib/bb/fetch/wget.py b/bitbake-dev/lib/bb/fetch/wget.py
index 88193755d..0008a2870 100644
--- a/bitbake-dev/lib/bb/fetch/wget.py
+++ b/bitbake-dev/lib/bb/fetch/wget.py
@@ -60,11 +60,30 @@ class Wget(Fetch):
else:
fetchcmd = data.getVar("FETCHCOMMAND", d, 1)
+ uri = uri.split(";")[0]
+ uri_decoded = list(bb.decodeurl(uri))
+ uri_type = uri_decoded[0]
+ uri_host = uri_decoded[1]
+
bb.msg.note(1, bb.msg.domain.Fetcher, "fetch " + uri)
- fetchcmd = fetchcmd.replace("${URI}", uri.split(";")[0])
+ fetchcmd = fetchcmd.replace("${URI}", uri)
fetchcmd = fetchcmd.replace("${FILE}", ud.basename)
- httpproxy = data.getVar("http_proxy", d, True)
- ftpproxy = data.getVar("ftp_proxy", d, True)
+ httpproxy = None
+ ftpproxy = None
+ if uri_type == 'http':
+ httpproxy = data.getVar("HTTP_PROXY", d, True)
+ httpproxy_ignore = (data.getVar("HTTP_PROXY_IGNORE", d, True) or "").split()
+ for p in httpproxy_ignore:
+ if uri_host.endswith(p):
+ httpproxy = None
+ break
+ if uri_type == 'ftp':
+ ftpproxy = data.getVar("FTP_PROXY", d, True)
+ ftpproxy_ignore = (data.getVar("HTTP_PROXY_IGNORE", d, True) or "").split()
+ for p in ftpproxy_ignore:
+ if uri_host.endswith(p):
+ ftpproxy = None
+ break
if httpproxy:
fetchcmd = "http_proxy=" + httpproxy + " " + fetchcmd
if ftpproxy:
diff --git a/bitbake/lib/bb/fetch/wget.py b/bitbake/lib/bb/fetch/wget.py
index 88193755d..0008a2870 100644
--- a/bitbake/lib/bb/fetch/wget.py
+++ b/bitbake/lib/bb/fetch/wget.py
@@ -60,11 +60,30 @@ class Wget(Fetch):
else:
fetchcmd = data.getVar("FETCHCOMMAND", d, 1)
+ uri = uri.split(";")[0]
+ uri_decoded = list(bb.decodeurl(uri))
+ uri_type = uri_decoded[0]
+ uri_host = uri_decoded[1]
+
bb.msg.note(1, bb.msg.domain.Fetcher, "fetch " + uri)
- fetchcmd = fetchcmd.replace("${URI}", uri.split(";")[0])
+ fetchcmd = fetchcmd.replace("${URI}", uri)
fetchcmd = fetchcmd.replace("${FILE}", ud.basename)
- httpproxy = data.getVar("http_proxy", d, True)
- ftpproxy = data.getVar("ftp_proxy", d, True)
+ httpproxy = None
+ ftpproxy = None
+ if uri_type == 'http':
+ httpproxy = data.getVar("HTTP_PROXY", d, True)
+ httpproxy_ignore = (data.getVar("HTTP_PROXY_IGNORE", d, True) or "").split()
+ for p in httpproxy_ignore:
+ if uri_host.endswith(p):
+ httpproxy = None
+ break
+ if uri_type == 'ftp':
+ ftpproxy = data.getVar("FTP_PROXY", d, True)
+ ftpproxy_ignore = (data.getVar("HTTP_PROXY_IGNORE", d, True) or "").split()
+ for p in ftpproxy_ignore:
+ if uri_host.endswith(p):
+ ftpproxy = None
+ break
if httpproxy:
fetchcmd = "http_proxy=" + httpproxy + " " + fetchcmd
if ftpproxy:
diff --git a/meta-moblin/packages/sreadahead/sreadahead_0.02.bb b/meta-moblin/packages/sreadahead/sreadahead_0.02.bb
index ca8963577..1ca5f1655 100644
--- a/meta-moblin/packages/sreadahead/sreadahead_0.02.bb
+++ b/meta-moblin/packages/sreadahead/sreadahead_0.02.bb
@@ -14,6 +14,12 @@ SRC_URI = "http://www.moblin.org/sites/all/files/sreadahead-${PV}.tar.gz \
CFLAGS_prepend = "-I ${S}/include "
+#
+# Not compatible on arm due to the use of __sync_fetch_and_add
+# Would need to use a pthread mutex on arm
+#
+COMPATIBLE_HOST = "(i.86).*-linux"
+
PACKAGES += "${PN}-generate"
FILES_${PN} = "${base_sbindir}/sreadahead ${sysconfdir}/init.d/sreadahead.sh"
FILES_${PN}-generate = "${base_sbindir}/generate_filelist ${sysconfdir}/init.d/sreadahead-generate.sh"
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 83ab06337..365258f65 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -175,6 +175,26 @@ autotools_stage_dir() {
fi
}
+autotools_stage_libdir() {
+ from="$1"
+ to="$2"
+
+ olddir=`pwd`
+ cd $from
+ las=$(find . -name \*.la -type f)
+ cd $olddir
+ echo "Found la files: $las"
+ for i in $las
+ do
+ sed -e 's/^installed=yes$/installed=no/' \
+ -e '/^dependency_libs=/s,${WORKDIR}[[:alnum:]/\._+-]*/\([[:alnum:]\._+-]*\),${STAGING_LIBDIR}/\1,g' \
+ -e "/^dependency_libs=/s,\([[:space:]']\)${libdir},\1${STAGING_LIBDIR},g" \
+ -i $from/$i
+ done
+ autotools_stage_dir $from $to
+}
+
+
autotools_stage_all() {
if [ "${INHIBIT_AUTO_STAGE}" = "1" ]
then
@@ -193,19 +213,11 @@ autotools_stage_all() {
fi
if [ -d ${STAGE_TEMP}/${libdir} ]
then
- olddir=`pwd`
- cd ${STAGE_TEMP}/${libdir}
- las=$(find . -name \*.la -type f)
- cd $olddir
- echo "Found la files: $las"
- for i in $las
- do
- sed -e 's/^installed=yes$/installed=no/' \
- -e '/^dependency_libs=/s,${WORKDIR}[[:alnum:]/\._+-]*/\([[:alnum:]\._+-]*\),${STAGING_LIBDIR}/\1,g' \
- -e "/^dependency_libs=/s,\([[:space:]']\)${libdir},\1${STAGING_LIBDIR},g" \
- -i ${STAGE_TEMP}/${libdir}/$i
- done
- autotools_stage_dir ${STAGE_TEMP}/${libdir} ${STAGING_LIBDIR}
+ autotools_stage_libdir ${STAGE_TEMP}/${libdir} ${STAGING_LIBDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${base_libdir} ]
+ then
+ autotools_stage_libdir ${STAGE_TEMP}/${base_libdir} ${STAGING_DIR_HOST}${layout_base_libdir}
fi
rm -rf ${STAGE_TEMP}/${mandir} || true
rm -rf ${STAGE_TEMP}/${infodir} || true
diff --git a/meta/classes/base.bbclass b/meta/classes/base.bbclass
index 1b70bfdd5..76b21382f 100644
--- a/meta/classes/base.bbclass
+++ b/meta/classes/base.bbclass
@@ -742,12 +742,9 @@ def generate_git_config(e):
f = open(gitconfig_path, 'w')
f.write("[core]\n")
- ignore_count = 1
- ignore_host = data.getVar('GIT_PROXY_IGNORE_1', e.data, True)
- while (ignore_host):
+ ignore_hosts = data.getVar('GIT_PROXY_IGNORE', e.data, True).split()
+ for ignore_host in ignore_hosts:
f.write(" gitproxy = none for %s\n" % ignore_host)
- ignore_count += 1
- ignore_host = data.getVar('GIT_PROXY_IGNORE_%s' % ignore_count, e.data, True)
f.write(proxy_command)
f.close
diff --git a/meta/classes/packaged-staging.bbclass b/meta/classes/packaged-staging.bbclass
index 2497ac4d1..144087fed 100644
--- a/meta/classes/packaged-staging.bbclass
+++ b/meta/classes/packaged-staging.bbclass
@@ -159,9 +159,8 @@ staging_helper () {
mkdir -p ${TMPDIR}${layout_libdir}/opkg/info/
fi
if [ ! -e ${TMPDIR}${layout_libdir}/ipkg/ ]; then
- mkdir -p ${TMPDIR}${layout_libdir}/opkg
cd ${TMPDIR}${layout_libdir}/
- ln -sf opkg/ ipkg
+ ln -sf opkg/ ipkg || true
fi
}
diff --git a/meta/packages/drm/libdrm_2.4.0.bb b/meta/packages/drm/libdrm_2.4.0.bb
index 9caf9b4be..d5e716014 100644
--- a/meta/packages/drm/libdrm_2.4.0.bb
+++ b/meta/packages/drm/libdrm_2.4.0.bb
@@ -2,6 +2,7 @@ SECTION = "x11/base"
LICENSE = "MIT"
SRC_URI = "http://dri.freedesktop.org/libdrm/libdrm-${PV}.tar.bz2"
PROVIDES = "drm"
+DEPENDS = "libpthread-stubs"
inherit autotools pkgconfig
diff --git a/meta/packages/drm/libdrm_git.bb b/meta/packages/drm/libdrm_git.bb
index e05e16bb0..27d913c8d 100644
--- a/meta/packages/drm/libdrm_git.bb
+++ b/meta/packages/drm/libdrm_git.bb
@@ -5,6 +5,8 @@ PROVIDES = "drm"
S = ${WORKDIR}/git
+DEPENDS = "libpthread-stubs"
+
PR = "r0"
PV = "2.4.0+git${SRCREV}"
diff --git a/meta/packages/e2fsprogs/e2fsprogs_1.41.2.bb b/meta/packages/e2fsprogs/e2fsprogs_1.41.2.bb
index 4e4d37260..42644b59d 100644
--- a/meta/packages/e2fsprogs/e2fsprogs_1.41.2.bb
+++ b/meta/packages/e2fsprogs/e2fsprogs_1.41.2.bb
@@ -1,6 +1,6 @@
require e2fsprogs.inc
-PR = "r10"
+PR = "r11"
S = "${WORKDIR}/e2fsprogs-${PV}"
diff --git a/meta/packages/packkagekit/files/no_validate.patch b/meta/packages/packkagekit/files/no_validate.patch
new file mode 100644
index 000000000..f987b567d
--- /dev/null
+++ b/meta/packages/packkagekit/files/no_validate.patch
@@ -0,0 +1,21 @@
+Index: PackageKit-0.3.8/configure.ac
+===================================================================
+--- PackageKit-0.3.8.orig/configure.ac 2008-11-04 21:37:17.000000000 +0000
++++ PackageKit-0.3.8/configure.ac 2008-11-04 21:37:57.000000000 +0000
+@@ -451,11 +451,11 @@
+ polkit-grant >= $POLKIT_GRANT_REQUIRED)
+ AC_SUBST(POLKIT_CFLAGS)
+ AC_SUBST(POLKIT_LIBS)
+- AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
+- [polkit-policy-file-validate], [polkit-policy-file-validate])
+- if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
+- AC_MSG_ERROR([polkit-policy-file-validate not found])
+- fi
++ #AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
++ # [polkit-policy-file-validate], [polkit-policy-file-validate])
++ #if test -z "$POLKIT_POLICY_FILE_VALIDATE"; then
++ # AC_MSG_ERROR([polkit-policy-file-validate not found])
++ #fi
+ AC_DEFINE(USE_SECURITY_POLKIT, 1, [if we should use PolicyKit])
+ elif test x$with_security_framework = xdummy; then
+ AC_DEFINE(USE_SECURITY_DUMMY, 1, [if we should use a dummy security framework])
diff --git a/meta/packages/packkagekit/packagekit_0.3.8.bb b/meta/packages/packkagekit/packagekit_0.3.8.bb
index ccac51c01..6b44aeac7 100644
--- a/meta/packages/packkagekit/packagekit_0.3.8.bb
+++ b/meta/packages/packkagekit/packagekit_0.3.8.bb
@@ -1,10 +1,11 @@
HOMEPAGE = "http://www.packagekit.org/"
-PR = "r4"
+PR = "r6"
-SRC_URI = "http://www.packagekit.org/releases/PackageKit-0.3.8.tar.gz"
+SRC_URI = "http://www.packagekit.org/releases/PackageKit-0.3.8.tar.gz \
+ file://no_validate.patch;patch=1 "
-DEPENDS = "python polkit pam opkg-sdk"
-EXTRA_OECONF = "--disable-qt --disable-tests --enable-yum --with-default-backend=yum --disable-local"
+DEPENDS = "python polkit pam"
+EXTRA_OECONF = "--disable-qt --disable-tests --enable-yum --with-default-backend=yum --disable-local --with-security-framework=polkit --disable-gstreamer-plugin"
S = "${WORKDIR}/PackageKit-${PV}"
diff --git a/meta/packages/pam/files/disable_crossbinary.patch b/meta/packages/pam/files/disable_crossbinary.patch
new file mode 100644
index 000000000..43359b08f
--- /dev/null
+++ b/meta/packages/pam/files/disable_crossbinary.patch
@@ -0,0 +1,34 @@
+padout should be compiled using the native compiler but isn't.
+Disable this piece of documentation for now.
+
+RP
+
+Index: Linux-PAM-1.0.2/doc/specs/Makefile.am
+===================================================================
+--- Linux-PAM-1.0.2.orig/doc/specs/Makefile.am 2008-11-04 21:06:23.000000000 +0000
++++ Linux-PAM-1.0.2/doc/specs/Makefile.am 2008-11-04 21:07:06.000000000 +0000
+@@ -2,21 +2,8 @@
+ # Copyright (c) 2005, 2006 Thorsten Kukuk <kukuk@suse.de>
+ #
+
+-CLEANFILES = draft-morgan-pam-current.txt *~
++CLEANFILES = *~
+
+-EXTRA_DIST = draft-morgan-pam.raw std-agent-id.raw rfc86.0.txt
++EXTRA_DIST = std-agent-id.raw rfc86.0.txt
+
+-draft-morgan-pam-current.txt: padout draft-morgan-pam.raw
+- ./padout < $(srcdir)/draft-morgan-pam.raw > draft-morgan-pam-current.txt
+-
+-AM_YFLAGS = -d
+-
+-BUILT_SOURCES = parse_y.h
+-
+-noinst_PROGRAMS = padout
+-
+-padout_SOURCES = parse_l.l parse_y.y
+-
+-padout_LDADD = @LEXLIB@
+-
+-doc_DATA = draft-morgan-pam-current.txt rfc86.0.txt
++doc_DATA = rfc86.0.txt
diff --git a/meta/packages/pam/pam_1.0.2.bb b/meta/packages/pam/pam_1.0.2.bb
index d894824d4..2a91414d7 100644
--- a/meta/packages/pam/pam_1.0.2.bb
+++ b/meta/packages/pam/pam_1.0.2.bb
@@ -1,7 +1,8 @@
HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam/"
-PR = "r5"
+PR = "r7"
-SRC_URI = "http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-1.0.2.tar.bz2"
+SRC_URI = "http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-1.0.2.tar.bz2 \
+ file://disable_crossbinary.patch;patch=1 "
EXTRA_OECONF = "--with-db-uniquename=_pam \
--includedir=${includedir}/security \
diff --git a/meta/packages/policykit/policykit_0.9.bb b/meta/packages/policykit/policykit_0.9.bb
index 26b9351c0..b2efd5832 100644
--- a/meta/packages/policykit/policykit_0.9.bb
+++ b/meta/packages/policykit/policykit_0.9.bb
@@ -4,7 +4,7 @@ PR = "r4"
SRC_URI = "http://hal.freedesktop.org/releases/PolicyKit-0.9.tar.gz"
-DEPENDS = "pam"
+DEPENDS = "pam expat dbus-glib"
RDEPENDS = "pam"
EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc"
diff --git a/meta/packages/syslinux/syslinux-installer-native_3.36.bb b/meta/packages/syslinux/syslinux-installer-native_3.36.bb
index 88bc37a1d..cc61693be 100644
--- a/meta/packages/syslinux/syslinux-installer-native_3.36.bb
+++ b/meta/packages/syslinux/syslinux-installer-native_3.36.bb
@@ -5,6 +5,7 @@ DESCRIPTION = "A multi-purpose linux bootloader"
HOMEPAGE = "http://syslinux.zytor.com/"
LICENSE = "GPL"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
+DEPENDS = "nasm-native"
S = "${WORKDIR}/syslinux-${PV}"
STAGE_TEMP = "${WORKDIR}/stage_temp"
diff --git a/meta/packages/uuid/files/fixes.patch b/meta/packages/uuid/files/fixes.patch
deleted file mode 100644
index 8a792c723..000000000
--- a/meta/packages/uuid/files/fixes.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Index: uuid-1.6.2/Makefile.in
-===================================================================
---- uuid-1.6.2.orig/Makefile.in 2008-10-29 04:37:32.000000000 +0000
-+++ uuid-1.6.2/Makefile.in 2008-10-29 04:40:18.000000000 +0000
-@@ -55,7 +55,6 @@
- CP = cp
- RMDIR = rmdir
- SHTOOL = $(S)/shtool
--LIBTOOL = $(C)/libtool
- TRUE = true
- POD2MAN = pod2man
- PERL = @PERL@
-Index: uuid-1.6.2/configure.ac
-===================================================================
---- uuid-1.6.2.orig/configure.ac 2008-10-29 04:31:31.000000000 +0000
-+++ uuid-1.6.2/configure.ac 2008-10-29 04:33:07.000000000 +0000
-@@ -40,11 +40,8 @@
-
- AC_PROG_MAKE_SET
- AC_PROG_CC
--AC_CHECK_DEBUGGING
--AC_CHECK_DMALLOC
-
- with_tags=""
--sinclude(libtool.m4)
- AC_PROG_LIBTOOL
-
- sinclude(uuid.ac)
-Index: uuid-1.6.2/uuid.ac
-===================================================================
---- uuid-1.6.2.orig/uuid.ac 2008-10-29 04:31:39.000000000 +0000
-+++ uuid-1.6.2/uuid.ac 2008-10-29 04:31:53.000000000 +0000
-@@ -39,9 +39,6 @@
- fi
- AC_CHECK_LIB(socket, accept)
-
-- dnl # check for portable va_copy()
-- AC_CHECK_VA_COPY()
--
- dnl # check for system headers
- AC_CHECK_HEADERS(sys/types.h sys/param.h sys/time.h sys/socket.h sys/sockio.h sys/ioctl.h sys/select.h)
- AC_CHECK_HEADERS(netdb.h ifaddrs.h net/if.h net/if_dl.h net/if_arp.h netinet/in.h arpa/inet.h,,,
diff --git a/meta/packages/uuid/uuid_1.6.2.bb b/meta/packages/uuid/uuid_1.6.2.bb
deleted file mode 100644
index eb76349d8..000000000
--- a/meta/packages/uuid/uuid_1.6.2.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SRC_URI = "ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz \
- file://fixes.patch;patch=1"
-PR = "r0"
-
-inherit autotools
-
-do_configure_prepend () {
- rm libtool.m4
-}
-
-export LIBTOOL = "${S}/${TARGET_PREFIX}libtool"
-
-do_stage () {
- autotools_stage_all
-} \ No newline at end of file
diff --git a/scripts/poky-autobuild-moblin b/scripts/poky-autobuild-moblin
index 0fa2ba0f0..afd85964b 100755
--- a/scripts/poky-autobuild-moblin
+++ b/scripts/poky-autobuild-moblin
@@ -49,7 +49,7 @@ fi
BDIR="build"
. ./scripts/poky-env-internal
-BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE GIT_CORE_CONFIG GIT_PROXY_IGNORE_1 GIT_PROXY_HOST GIT_PROXY_PORT"
+BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE"
POSTPROCESS=`which poky-autobuild-postprocess-moblin`
if [ "xcomplete" = "x$1" ]; then
@@ -68,12 +68,12 @@ if [ ! -e "$CONFFILE" ]; then
if [ ! -d "./conf" ]; then
mkdir -p "./conf"
fi
- echo 'PACKAGE_CLASSES = "package_ipk package_deb"' > "$CONFFILE"
+ echo 'PACKAGE_CLASSES = "package_ipk package_deb package_rpm"' > "$CONFFILE"
echo 'BB_NUMBER_THREADS = "6"' >> "$CONFFILE"
echo 'PARALLEL_MAKE = "-j 6"' >> "$CONFFILE"
echo "DL_DIR = \"$SRVWORKDIR/sources\"" >> "$CONFFILE"
echo 'INHERIT += "poky-autobuild-notifier"' >> "$CONFFILE"
- echo 'GIT_PROXY_COMMAND=poky-git-proxy-socks-command' >> "$CONFFILE"
+ echo 'INHERIT += "poky-moblin-autobuilder-proxy-config"' >> "$CONFFILE"
if [ "$ABTARGET" = "darwin" ]; then
echo 'PACKAGE_CLASSES += "package_tar"' >> "$CONFFILE"
echo "BBFILES += \"$CURRDIR/meta-darwin/packages/*/*.bb\"" >> "./conf/local.conf"
@@ -84,6 +84,8 @@ if [ ! -e "$CONFFILE" ]; then
fi
fi
+BBPATH=$SRVWORKDIR/localmeta:$BBPATH
+
if [ "$ABTARGET" = "darwin" ]; then
BBPATH=$CURRDIR/meta-darwin:$BBPATH
fi