summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--meta/packages/flex/flex-2.5.31/include.patch27
-rw-r--r--meta/packages/flex/flex.inc4
-rw-r--r--meta/packages/flex/flex/fix-gen.patch17
-rw-r--r--meta/packages/flex/flex/flex-lvalue.diff36
-rw-r--r--meta/packages/flex/flex_2.5.31.bb6
-rw-r--r--meta/packages/flex/flex_2.5.35.bb4
6 files changed, 5 insertions, 89 deletions
diff --git a/meta/packages/flex/flex-2.5.31/include.patch b/meta/packages/flex/flex-2.5.31/include.patch
deleted file mode 100644
index b60dcb29d..000000000
--- a/meta/packages/flex/flex-2.5.31/include.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- flex-2.5.31/Makefile.am~include
-+++ flex-2.5.31/Makefile.am
-@@ -141,7 +141,7 @@
- tests
-
- localedir = $(datadir)/locale
--AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
-+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
- LIBS = @LIBINTL@ @LIBS@
-
- skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
---- flex-2.5.31/Makefile.in~include
-+++ flex-2.5.31/Makefile.in
-@@ -292,7 +292,7 @@
-
-
- localedir = $(datadir)/locale
--AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
-+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
-
- # Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
- #
diff --git a/meta/packages/flex/flex.inc b/meta/packages/flex/flex.inc
index d348d78cb..da95a5e25 100644
--- a/meta/packages/flex/flex.inc
+++ b/meta/packages/flex/flex.inc
@@ -5,9 +5,7 @@ SECTION = "devel"
LICENSE = "BSD"
DEPENDS = "gettext"
-SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-2.5.31.tar.bz2 \
- file://flex-lvalue.diff;patch=1 \
- file://fix-gen.patch;patch=1"
+SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 "
inherit autotools
diff --git a/meta/packages/flex/flex/fix-gen.patch b/meta/packages/flex/flex/fix-gen.patch
deleted file mode 100644
index 55f4f6fdf..000000000
--- a/meta/packages/flex/flex/fix-gen.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- flex-2.5.31/gen.c~fix-gen
-+++ flex-2.5.31/gen.c
-@@ -1812,8 +1812,7 @@
- if (yytext_is_array) {
- if (!reentrant){
- indent_puts ("static int yy_more_offset = 0;");
-- }else{
-- indent_puts ("static int yy_prev_more_offset = 0;");
-+ indent_puts ("static int yy_prev_more_offset = 0;");
- }
- }
- else if (!reentrant) {
diff --git a/meta/packages/flex/flex/flex-lvalue.diff b/meta/packages/flex/flex/flex-lvalue.diff
deleted file mode 100644
index 56ae539a6..000000000
--- a/meta/packages/flex/flex/flex-lvalue.diff
+++ /dev/null
@@ -1,36 +0,0 @@
-Patch from http://bugs.debian.org/cgi-bin/bugreport.cgi/flex-lvalue.diff?bug=194844;msg=10;att=1
-
-according to posix 0,1,2 are already setup and this avoids
-the issues with
-| filter.c: In function 'filter_apply_chain':
-| filter.c:161: error: invalid lvalue in assignment
-| filter.c:163: error: invalid lvalue in assignment
-| filter.c:184: error: invalid lvalue in assignment
-
-
-diff -ur flex-2.5.31.ORIG/filter.c flex-2.5.31/filter.c
---- flex-2.5.31.ORIG/filter.c 2003-03-25 16:39:08.000000000 +0000
-+++ flex-2.5.31/filter.c 2003-05-27 17:00:26.000000000 +0000
-@@ -157,11 +157,8 @@
- if (chain->filter_func) {
- int r;
-
-- /* setup streams again */
-- if ((stdin = fdopen (0, "r")) == NULL)
-- flexfatal (_("fdopen(0) failed"));
-- if ((stdout = fdopen (1, "w")) == NULL)
-- flexfatal (_("fdopen(1) failed"));
-+ /* POSIX says we inherit fd[0-2], so we don't need
-+ to do anything to them here */
-
- if ((r = chain->filter_func (chain)) == -1)
- flexfatal (_("filter_func failed"));
-@@ -181,8 +178,6 @@
- if (dup2 (pipes[1], 1) == -1)
- flexfatal (_("dup2(pipes[1],1)"));
- close (pipes[1]);
-- if ((stdout = fdopen (1, "w")) == NULL)
-- flexfatal (_("fdopen(1) failed"));
-
- return true;
- }
diff --git a/meta/packages/flex/flex_2.5.31.bb b/meta/packages/flex/flex_2.5.31.bb
deleted file mode 100644
index 7ca7c7ee3..000000000
--- a/meta/packages/flex/flex_2.5.31.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require flex.inc
-PR = "r5"
-
-SRC_URI += "file://include.patch;patch=1"
-
-BBCLASSEXTEND = "native"
diff --git a/meta/packages/flex/flex_2.5.35.bb b/meta/packages/flex/flex_2.5.35.bb
new file mode 100644
index 000000000..f5f20f47e
--- /dev/null
+++ b/meta/packages/flex/flex_2.5.35.bb
@@ -0,0 +1,4 @@
+require flex.inc
+PR = "r0"
+
+BBCLASSEXTEND = "native"