summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xopenembedded/packages/chkhinge26/chkhinge26_svn.bb2
-rwxr-xr-xopenembedded/packages/chkhinge26/files/hinge-handler19
2 files changed, 15 insertions, 6 deletions
diff --git a/openembedded/packages/chkhinge26/chkhinge26_svn.bb b/openembedded/packages/chkhinge26/chkhinge26_svn.bb
index b265fe6c8..5313401b5 100755
--- a/openembedded/packages/chkhinge26/chkhinge26_svn.bb
+++ b/openembedded/packages/chkhinge26/chkhinge26_svn.bb
@@ -2,7 +2,7 @@ LICENSE = "LGPL"
SECTION = "x11"
MAINTAINER = "Matthew Allum <mallum@openedhand.com>"
DESCRIPTION = "Chkhinge26 fires off cmds on cXXXX Zs."
-PR = "r1"
+PR = "r2"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=chkhinge26;proto=http \
file://hinge-handler"
diff --git a/openembedded/packages/chkhinge26/files/hinge-handler b/openembedded/packages/chkhinge26/files/hinge-handler
index d8100e9b2..5d5f62e30 100755
--- a/openembedded/packages/chkhinge26/files/hinge-handler
+++ b/openembedded/packages/chkhinge26/files/hinge-handler
@@ -3,6 +3,14 @@
# Quick handler for chkhinge26 and X.
#
+killproc() { # kill the named process(es)
+ pid=`/bin/ps -e x |
+ /bin/grep $1 |
+ /bin/grep -v grep |
+ /bin/sed -e 's/^ *//' -e 's/ .*//'`
+ [ "$pid" != "" ] && kill $pid
+}
+
export DISPLAY=:0
if [ -z "$1" ]; then
@@ -20,10 +28,10 @@ fi
if [ $STATE = "0" ]; then
echo "lanscape"
- killall mbinputmgr
+ killproc /usr/bin/mbinputmgr
# urg mbinputmgr should kill below
- killall matchbox-keyboard
- killall matchbox-stroke
+ killproc /usr/bin/matchbox-keyboard
+ killproc /usr/bin/matchbox-stroke
xrandr -o normal
exit 0
fi
@@ -33,6 +41,7 @@ if [ $STATE = "2" ]; then
xrandr -o left
# just to be extra safe
sleep 1
- mbinputmgr &
+ /usr/bin/mbinputmgr &
exit 0
-fi \ No newline at end of file
+fi
+