summaryrefslogtreecommitdiff
path: root/bitbake-dev/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake-dev/bin')
-rwxr-xr-xbitbake-dev/bin/bitbake14
1 files changed, 9 insertions, 5 deletions
diff --git a/bitbake-dev/bin/bitbake b/bitbake-dev/bin/bitbake
index 34c49b8c5..cabdf2b45 100755
--- a/bitbake-dev/bin/bitbake
+++ b/bitbake-dev/bin/bitbake
@@ -144,7 +144,11 @@ Default BBFILES are the .bb files in the current directory.""" )
configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
- cooker = bb.cooker.BBCooker(configuration)
+ # Save a logfile for cooker into the current working directory. When the
+ # server is daemonized this logfile will be truncated.
+ cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
+
+ cooker = bb.cooker.BBCooker(configuration, bb.server.xmlrpc)
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
@@ -152,13 +156,13 @@ Default BBFILES are the .bb files in the current directory.""" )
bb.utils.clean_environment()
cooker.parseCommandLine()
+
+
+
+
host = cooker.server.host
port = cooker.server.port
- # Save a logfile for cooker into the current working directory. When the
- # server is daemonized this logfile will be truncated.
- cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
-
daemonize.createDaemon(cooker.serve, cooker_logfile)
del cooker