summaryrefslogtreecommitdiff
path: root/bitbake/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bitbake/bin')
-rwxr-xr-xbitbake/bin/bitbake4
1 files changed, 2 insertions, 2 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index b046156b4..797b5a8d6 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -180,7 +180,7 @@ Default BBFILES are the .bb files in the current directory.""")
serverinfo = server.BitbakeServerInfo(cooker.server)
- server.BitBakeServerFork(serverinfo, cooker.serve, cooker_logfile)
+ server.BitBakeServerFork(cooker, cooker.server, serverinfo, cooker_logfile)
del cooker
# Setup a connection to the server (cooker)
@@ -203,7 +203,7 @@ Default BBFILES are the .bb files in the current directory.""")
print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
else:
try:
- return_value = ui_init(serverConnection.connection, serverConnection.events)
+ return_value = server.BitbakeUILauch().launch(serverinfo, ui_init, serverConnection.connection, serverConnection.events)
except Exception as e:
print("FATAL: Unable to start to '%s' UI: %s" % (ui, e))
raise