summaryrefslogtreecommitdiff
path: root/meta-emenlow/recipes/libdrm-poulsbo
diff options
context:
space:
mode:
Diffstat (limited to 'meta-emenlow/recipes/libdrm-poulsbo')
-rw-r--r--meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch61
-rw-r--r--meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb16
2 files changed, 77 insertions, 0 deletions
diff --git a/meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch b/meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
new file mode 100644
index 000000000..14bde6887
--- /dev/null
+++ b/meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
@@ -0,0 +1,61 @@
+# Make this package produce libdrm-poulsbo instead of libdrm so that the
+# emenlow libdrm can coexist with the normal libdrm.
+# jdike@linux.intel.com
+
+Index: libdrm-poulsbo-2.3.0/configure.ac
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/configure.ac
++++ libdrm-poulsbo-2.3.0/configure.ac
+@@ -19,7 +19,7 @@
+ # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+ AC_PREREQ(2.57)
+-AC_INIT([libdrm], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm)
++AC_INIT([libdrm_poulsbo], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm_poulsbo)
+ AC_CONFIG_SRCDIR([Makefile.am])
+ AM_INIT_AUTOMAKE([dist-bzip2])
+
+@@ -35,4 +35,4 @@ AC_SYS_LARGEFILE
+ pkgconfigdir=${libdir}/pkgconfig
+ AC_SUBST(pkgconfigdir)
+
+-AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm.pc])
++AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm_poulsbo.pc])
+Index: libdrm-poulsbo-2.3.0/Makefile.am
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/Makefile.am
++++ libdrm-poulsbo-2.3.0/Makefile.am
+@@ -25,6 +25,6 @@ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = libdrm shared-core
+
+ pkgconfigdir = @pkgconfigdir@
+-pkgconfig_DATA = libdrm.pc
++pkgconfig_DATA = libdrm_poulsbo.pc
+
+-EXTRA_DIST = libdrm.pc.in
++EXTRA_DIST = libdrm_poulsbo.pc.in
+Index: libdrm-poulsbo-2.3.0/libdrm/Makefile.am
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/libdrm/Makefile.am
++++ libdrm-poulsbo-2.3.0/libdrm/Makefile.am
+@@ -18,14 +18,14 @@
+ # IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+ # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-libdrm_la_LTLIBRARIES = libdrm.la
+-libdrm_ladir = $(libdir)
+-libdrm_la_LDFLAGS = -version-number 2:3:0 -no-undefined
++libdrm_poulsbo_la_LTLIBRARIES = libdrm_poulsbo.la
++libdrm_poulsbo_ladir = $(libdir)
++libdrm_poulsbo_la_LDFLAGS = -version-number 2:3:0 -no-undefined
+
+ AM_CFLAGS = -I$(top_srcdir)/shared-core
+-libdrm_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c xf86drmMode.c
++libdrm_poulsbo_la_SOURCES = xf86drm.c xf86drmHash.c xf86drmRandom.c xf86drmSL.c xf86drmMode.c
+
+-libdrmincludedir = ${includedir}/psb
+-libdrminclude_HEADERS = xf86drm.h xf86mm.h xf86drmMode.h
++libdrm_poulsboincludedir = ${includedir}/psb
++libdrm_poulsboinclude_HEADERS = xf86drm.h xf86mm.h xf86drmMode.h
+
+ EXTRA_DIST = ChangeLog TODO
diff --git a/meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb b/meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
new file mode 100644
index 000000000..066fe3f3b
--- /dev/null
+++ b/meta-emenlow/recipes/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Userspace interface to kernel DRM services"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7"
+PR = "r4"
+
+PROVIDES = "libdrm-poulsbo"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libdrm-poulsbo_2.3.0-1ubuntu0sarvatt4~1004um1ubuntu1.tar.gz \
+ file://libdrm-poulsbo.patch"
+
+do_configure_prepend() {
+ sed -e 's/-ldrm/-ldrm_poulsbo/' -e 's/libdrm/libdrm_poulsbo/' \
+ < ${S}/libdrm.pc.in > ${S}/libdrm_poulsbo.pc.in
+}