summaryrefslogtreecommitdiff
path: root/meta-extras/packages/python/python-2.5.1
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/python/python-2.5.1')
-rw-r--r--meta-extras/packages/python/python-2.5.1/autohell.patch49
-rw-r--r--meta-extras/packages/python/python-2.5.1/bindir-libdir.patch20
-rw-r--r--meta-extras/packages/python/python-2.5.1/crosscompile.patch110
-rw-r--r--meta-extras/packages/python/python-2.5.1/default-is-optimized.patch13
-rw-r--r--meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch41
-rw-r--r--meta-extras/packages/python/python-2.5.1/sitebranding.patch21
6 files changed, 254 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-2.5.1/autohell.patch b/meta-extras/packages/python/python-2.5.1/autohell.patch
new file mode 100644
index 000000000..e2d63145b
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/autohell.patch
@@ -0,0 +1,49 @@
+#
+# FIXME: Don't simply rip this test out... add getting it from cache
+#
+Index: Python-2.5.1/configure.in
+===================================================================
+--- Python-2.5.1.orig/configure.in
++++ Python-2.5.1/configure.in
+@@ -3367,41 +3367,6 @@ else
+ AC_MSG_RESULT(no)
+ fi
+
+-AC_MSG_CHECKING(for %zd printf() format support)
+-AC_TRY_RUN([#include <stdio.h>
+-#include <stddef.h>
+-#include <string.h>
+-
+-int main()
+-{
+- char buffer[256];
+-
+-#ifdef HAVE_SSIZE_T
+-typedef ssize_t Py_ssize_t;
+-#elif SIZEOF_VOID_P == SIZEOF_LONG
+-typedef long Py_ssize_t;
+-#else
+-typedef int Py_ssize_t;
+-#endif
+-
+- if(sprintf(buffer, "%zd", (size_t)123) < 0)
+- return 1;
+-
+- if (strcmp(buffer, "123"))
+- return 1;
+-
+- if (sprintf(buffer, "%zd", (Py_ssize_t)-123) < 0)
+- return 1;
+-
+- if (strcmp(buffer, "-123"))
+- return 1;
+-
+- return 0;
+-}],
+-[AC_MSG_RESULT(yes)
+- AC_DEFINE(PY_FORMAT_SIZE_T, "z", [Define to printf format modifier for Py_ssize_t])],
+- AC_MSG_RESULT(no))
+-
+ AC_CHECK_TYPE(socklen_t,,
+ AC_DEFINE(socklen_t,int,
+ Define to `int' if <sys/socket.h> does not define.),[
diff --git a/meta-extras/packages/python/python-2.5.1/bindir-libdir.patch b/meta-extras/packages/python/python-2.5.1/bindir-libdir.patch
new file mode 100644
index 000000000..047c358a5
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/bindir-libdir.patch
@@ -0,0 +1,20 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: Python-2.5.1/Makefile.pre.in
+===================================================================
+--- Python-2.5.1.orig/Makefile.pre.in
++++ Python-2.5.1/Makefile.pre.in
+@@ -83,8 +83,8 @@ prefix= @prefix@
+ exec_prefix= @exec_prefix@
+
+ # Expanded directories
+-BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++BINDIR= @bindir@
++LIBDIR= @libdir@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include
diff --git a/meta-extras/packages/python/python-2.5.1/crosscompile.patch b/meta-extras/packages/python/python-2.5.1/crosscompile.patch
new file mode 100644
index 000000000..f456048ef
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/crosscompile.patch
@@ -0,0 +1,110 @@
+#
+# Patch (C) by Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+Index: Python-2.5.1/Makefile.pre.in
+===================================================================
+--- Python-2.5.1.orig/Makefile.pre.in
++++ Python-2.5.1/Makefile.pre.in
+@@ -170,6 +170,7 @@ UNICODE_OBJS= @UNICODE_OBJS@
+
+ PYTHON= python$(EXE)
+ BUILDPYTHON= python$(BUILDEXE)
++HOSTPYTHON= $(BUILDPYTHON)
+
+ # === Definitions added by makesetup ===
+
+@@ -196,7 +197,7 @@ GRAMMAR_INPUT= $(srcdir)/Grammar/Grammar
+ ##########################################################################
+ # Parser
+ PGEN= Parser/pgen$(EXE)
+-
++HOSTPGEN= $(PGEN)$(EXE)
+ POBJS= \
+ Parser/acceler.o \
+ Parser/grammar1.o \
+@@ -345,8 +346,8 @@ platform: $(BUILDPYTHON)
+ # Build the shared modules
+ sharedmods: $(BUILDPYTHON)
+ case $$MAKEFLAGS in \
+- *-s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
+- *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
++ *-s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
++ *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
+ esac
+
+ # Build static library
+@@ -470,7 +471,7 @@ Modules/python.o: $(srcdir)/Modules/pyth
+
+
+ $(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
+- -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
++ -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
+
+ $(PGEN): $(PGENOBJS)
+ $(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
+@@ -773,19 +774,19 @@ libinstall: $(BUILDPYTHON) $(srcdir)/Lib
+ done
+ $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
+ PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+- ./$(BUILDPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
++ $(HOSTPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
+ PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+- ./$(BUILDPYTHON) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
++ $(HOSTPYTHON) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
+ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+- ./$(BUILDPYTHON) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
++ $(HOSTPYTHON) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST)/site-packages -f \
+ -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
+ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+- ./$(BUILDPYTHON) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
++ $(HOSTPYTHON) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST)/site-packages -f \
+ -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
+
+@@ -885,7 +886,7 @@ libainstall: all
+ # Install the dynamically loadable modules
+ # This goes into $(exec_prefix)
+ sharedinstall:
+- $(RUNSHARED) ./$(BUILDPYTHON) -E $(srcdir)/setup.py install \
++ $(RUNSHARED) $(HOSTPYTHON) -E $(srcdir)/setup.py install \
+ --prefix=$(prefix) \
+ --install-scripts=$(BINDIR) \
+ --install-platlib=$(DESTSHARED) \
+Index: Python-2.5.1/setup.py
+===================================================================
+--- Python-2.5.1.orig/setup.py
++++ Python-2.5.1/setup.py
+@@ -211,6 +211,7 @@ class PyBuildExt(build_ext):
+ except ImportError, why:
+ self.announce('*** WARNING: renaming "%s" since importing it'
+ ' failed: %s' % (ext.name, why), level=3)
++ return
+ assert not self.inplace
+ basename, tail = os.path.splitext(ext_filename)
+ newname = basename + "_failed" + tail
+@@ -244,8 +245,8 @@ class PyBuildExt(build_ext):
+
+ def detect_modules(self):
+ # Ensure that /usr/local is always used
+- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
+- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
++ # add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
++ # add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+
+ # Add paths specified in the environment variables LDFLAGS and
+ # CPPFLAGS for header and library files.
+@@ -341,6 +342,9 @@ class PyBuildExt(build_ext):
+
+ # XXX Omitted modules: gl, pure, dl, SGI-specific modules
+
++ lib_dirs = [ os.getenv( "STAGING_LIBDIR" ) ]
++ inc_dirs = [ os.getenv( "STAGING_INCDIR" ) ]
++
+ #
+ # The following modules are all pretty straightforward, and compile
+ # on pretty much any POSIXish platform.
diff --git a/meta-extras/packages/python/python-2.5.1/default-is-optimized.patch b/meta-extras/packages/python/python-2.5.1/default-is-optimized.patch
new file mode 100644
index 000000000..6beeb6e02
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/default-is-optimized.patch
@@ -0,0 +1,13 @@
+Index: Python-2.5.1/Python/compile.c
+===================================================================
+--- Python-2.5.1.orig/Python/compile.c
++++ Python-2.5.1/Python/compile.c
+@@ -30,7 +30,7 @@
+ #include "symtable.h"
+ #include "opcode.h"
+
+-int Py_OptimizeFlag = 0;
++int Py_OptimizeFlag = 1;
+
+ /*
+ ISSUES:
diff --git a/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch b/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
new file mode 100644
index 000000000..93bd34338
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
@@ -0,0 +1,41 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: Python-2.5.1/setup.py
+===================================================================
+--- Python-2.5.1.orig/setup.py
++++ Python-2.5.1/setup.py
+@@ -1227,7 +1227,7 @@ class PyBuildExt(build_ext):
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1246,22 +1246,6 @@ class PyBuildExt(build_ext):
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)
diff --git a/meta-extras/packages/python/python-2.5.1/sitebranding.patch b/meta-extras/packages/python/python-2.5.1/sitebranding.patch
new file mode 100644
index 000000000..c6e486ae9
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/sitebranding.patch
@@ -0,0 +1,21 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: Python-2.5.1/Lib/site.py
+===================================================================
+--- Python-2.5.1.orig/Lib/site.py
++++ Python-2.5.1/Lib/site.py
+@@ -323,8 +323,9 @@ def setcopyright():
+ "Jython is maintained by the Jython developers (www.jython.org).")
+ else:
+ __builtin__.credits = _Printer("credits", """\
+- Thanks to CWI, CNRI, BeOpen.com, Zope Corporation and a cast of thousands
+- for supporting Python development. See www.python.org for more information.""")
++ This version of Python has been built by the OpenEmbedded buildsystem (http://openembedded.org).
++ It is a part of the Python-For-Embedded-Systems initiative which is maintained by
++ Michael 'Mickey' Lauer (http://www.Vanille.de/projects/python.spy).""")
+ here = os.path.dirname(os.__file__)
+ __builtin__.license = _Printer(
+ "license", "See http://www.python.org/%.3s/license.html" % sys.version,