summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb')
-rw-r--r--meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb57
1 files changed, 51 insertions, 6 deletions
diff --git a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb
index 518e2d790..a35dd8f87 100644
--- a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb
+++ b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS = "formfactor gtk-engines initscripts matchbox-session"
-PR = "r16"
+PR = "r17"
# This package is architecture specific because the session script is modified
# based on the machine architecture.
@@ -25,6 +25,7 @@ fi
. ${sysconfdir}/init.d/functions
+
# Theme
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
@@ -62,6 +63,25 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/desktop/gnome/sound/theme_name moblin
+# Screen shot
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/global_keybindings/run_command_screenshot \
+ "Print"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/keybinding_commands/command_screenshot \
+ "gnome-screenshot"
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/global_keybindings/run_command_window_screenshot \
+ "<Alt>Print"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type string -s \
+ /apps/metacity/keybinding_commands/command_window_screenshot \
+ "gnome-screenshot --window"
+
# Window Actions
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
@@ -73,14 +93,15 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/apps/metacity/general/action_right_click_titlebar "none"
+
# UX Shell
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type bool -s \
- /apps/metacity/general/clutter_disabled false
+ /apps/mutter/general/clutter_disabled false
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type list --list-type string -s \
- /apps/metacity/general/clutter_plugins '[moblin-netbook]'
+ /apps/mutter/general/clutter_plugins '[moblin-netbook]'
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
@@ -93,7 +114,7 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/desktop/gnome/background/picture_filename \
- '/usr/share/mutter-moblin/theme/myzone/toys.jpg'
+ '/usr/share/mutter-moblin/theme/moblin-panel-myzone/toys.jpg'
# Fonts
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
@@ -118,16 +139,40 @@ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type bool -s \
- /apps/nautilus/icon_view/labels_beside_icons true
+ /apps/nautilus/preferences/exit_with_last_window false
+
+# Do not automount, this is done by g-s-d plugin
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type bool -s \
+ /apps/nautilus/preferences/media_automount false
+
+# And should not open new window whenever media mounted
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type bool -s \
+ /apps/nautilus/preferences/media_automount_open false
+
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type bool -s \
+ /apps/nautilus/icon_view/labels_beside_icons false
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
- /apps/nautilus/icon_view/default_zoom_level large
+ /apps/nautilus/icon_view/default_zoom_level standard
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
--direct --type string -s \
/apps/gnome_settings_daemon/keybindings/power ""
+# General
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type float -s \
+ /desktop/gnome/peripherals/mouse/mouse_acceleration 0.8
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \
+ --direct --type int -s \
+ /desktop/gnome/peripherals/mouse/mouse_threshold 2
+
#
# The interesting bit - we convert to run the system as the user "pokyuser"
# and setup this user account as needed