summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/moblin-web-browser
diff options
context:
space:
mode:
Diffstat (limited to 'meta-moblin/packages/moblin-web-browser')
-rw-r--r--meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch35
-rw-r--r--meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb18
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
new file mode 100644
index 000000000..a8675868a
--- /dev/null
+++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
@@ -0,0 +1,35 @@
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2009-06-10 15:01:55.000000000 +0100
++++ git/configure.ac 2009-06-10 15:19:36.000000000 +0100
+@@ -36,6 +36,13 @@
+ MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul-unstable`"/unstable"
+ AC_SUBST([MOZIDLDIR])
+
++IDLPREFIX=
++AC_ARG_WITH(idl-prefix, AC_HELP_STRING([--with-idl-prefix=DIR],[prefix to add to access to the idl files]), with_idl_prefix=${withval})
++if test x"${with_idl_prefix}" != x ; then
++ IDLPREFIX=${with_idl_prefix}
++fi
++AC_SUBST([IDLPREFIX])
++
+ AC_PATH_PROG(DBUSBINDINGTOOL, dbus-binding-tool)
+
+ AC_OUTPUT([
+Index: git/libmwbpages/Makefile.am
+===================================================================
+--- git.orig/libmwbpages/Makefile.am 2009-06-10 15:01:55.000000000 +0100
++++ git/libmwbpages/Makefile.am 2009-06-10 15:20:12.000000000 +0100
+@@ -23,10 +23,10 @@
+ mwb-start-page.lo : MwbIStartPage.h
+
+ MwbIStartPage.h : MwbIStartPage.idl
+- $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m header $<
++ xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m header $<
+
+ MwbIStartPage.xpt : MwbIStartPage.idl
+- $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $<
++ xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $<
+
+ xpt_DATA = MwbIStartPage.xpt
+ xptdir = $(MOZHOME)/components
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
new file mode 100644
index 000000000..bb7e2ff0d
--- /dev/null
+++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Moblin web browser (based on clutter + mozilla-headless/mozilla-offscreen)"
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
+ file://xpidl.patch;patch=1"
+LICENSE = "LGPLv2.1"
+PV = "0.0+git${SRCPV}"
+PR = "r2"
+
+DEPENDS = "clutter clutter-mozembed clutter-gtk libunique mozilla-headless-services libccss nbtk mozilla-headless"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = "--with-idl-prefix=${STAGING_DIR_TARGET}/"
+
+FILES_${PN} += "${libdir}/xulrunner-*/chrome/*"
+FILES_${PN} += "${libdir}/xulrunner-*/components/*"
+FILES_${PN}-dbg += "${libdir}/xulrunner-*/components/.debug/*"
+
+inherit autotools_stage