summaryrefslogtreecommitdiff
path: root/meta/packages/autoconf/autoconf-2.63/path_prog_fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/autoconf/autoconf-2.63/path_prog_fixes.patch')
-rw-r--r--meta/packages/autoconf/autoconf-2.63/path_prog_fixes.patch126
1 files changed, 126 insertions, 0 deletions
diff --git a/meta/packages/autoconf/autoconf-2.63/path_prog_fixes.patch b/meta/packages/autoconf/autoconf-2.63/path_prog_fixes.patch
new file mode 100644
index 000000000..f47b973ab
--- /dev/null
+++ b/meta/packages/autoconf/autoconf-2.63/path_prog_fixes.patch
@@ -0,0 +1,126 @@
+Index: autoconf-2.63/bin/autoheader.in
+===================================================================
+--- autoconf-2.63.orig/bin/autoheader.in 2008-12-31 17:48:33.000000000 +0000
++++ autoconf-2.63/bin/autoheader.in 2008-12-31 17:48:33.000000000 +0000
+@@ -1,8 +1,8 @@
+-#! @PERL@
++#! @bindir@/env perl
+ # -*- Perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
+ if 0;
+
+ # autoheader -- create `config.h.in' from `configure.ac'
+Index: autoconf-2.63/bin/autom4te.in
+===================================================================
+--- autoconf-2.63.orig/bin/autom4te.in 2008-08-28 03:08:41.000000000 +0100
++++ autoconf-2.63/bin/autom4te.in 2008-12-31 17:48:33.000000000 +0000
+@@ -1,8 +1,10 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ # autom4te - Wrapper around M4 libraries.
+@@ -88,7 +90,7 @@
+ my $freeze = 0;
+
+ # $M4.
+-my $m4 = $ENV{"M4"} || '@M4@';
++my $m4 = $ENV{"M4"} || '@bindir@/env m4';
+ # Some non-GNU m4's don't reject the --help option, so give them /dev/null.
+ fatal "need GNU m4 1.4 or later: $m4"
+ if system "$m4 --help </dev/null 2>&1 | grep reload-state >/dev/null";
+Index: autoconf-2.63/bin/autoreconf.in
+===================================================================
+--- autoconf-2.63.orig/bin/autoreconf.in 2008-12-31 17:48:33.000000000 +0000
++++ autoconf-2.63/bin/autoreconf.in 2008-12-31 17:48:33.000000000 +0000
+@@ -1,8 +1,10 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ # autoreconf - install the GNU Build System in a directory tree
+Index: autoconf-2.63/bin/autoscan.in
+===================================================================
+--- autoconf-2.63.orig/bin/autoscan.in 2008-08-28 03:08:10.000000000 +0100
++++ autoconf-2.63/bin/autoscan.in 2008-12-31 17:48:33.000000000 +0000
+@@ -1,4 +1,4 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+@@ -23,7 +23,9 @@
+
+ # Written by David MacKenzie <djm@gnu.ai.mit.edu>.
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ BEGIN
+Index: autoconf-2.63/bin/autoupdate.in
+===================================================================
+--- autoconf-2.63.orig/bin/autoupdate.in 2008-08-28 03:08:10.000000000 +0100
++++ autoconf-2.63/bin/autoupdate.in 2008-12-31 17:48:33.000000000 +0000
+@@ -1,4 +1,4 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+@@ -24,7 +24,9 @@
+ # Originally written by David MacKenzie <djm@gnu.ai.mit.edu>.
+ # Rewritten by Akim Demaille <akim@freefriends.org>.
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ BEGIN
+@@ -56,7 +58,7 @@
+ my @include = ('@datadir@');
+ my $force = 0;
+ # m4.
+-my $m4 = $ENV{"M4"} || '@M4@';
++my $m4 = $ENV{"M4"} || '@bindir@/env m4';
+
+
+ # $HELP
+Index: autoconf-2.63/bin/ifnames.in
+===================================================================
+--- autoconf-2.63.orig/bin/ifnames.in 2008-08-28 03:08:10.000000000 +0100
++++ autoconf-2.63/bin/ifnames.in 2008-12-31 17:48:33.000000000 +0000
+@@ -1,8 +1,10 @@
+-#! @PERL@ -w
++#! @bindir@/env perl
+ # -*- perl -*-
+ # @configure_input@
+
+-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
++use warnings;
++
++eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+ if 0;
+
+ # ifnames - print the identifiers used in C preprocessor conditionals