summaryrefslogtreecommitdiff
path: root/meta/packages/busybox/busybox_1.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/busybox/busybox_1.9.1.bb')
-rw-r--r--meta/packages/busybox/busybox_1.9.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/packages/busybox/busybox_1.9.1.bb b/meta/packages/busybox/busybox_1.9.1.bb
new file mode 100644
index 000000000..cec4af8d5
--- /dev/null
+++ b/meta/packages/busybox/busybox_1.9.1.bb
@@ -0,0 +1,25 @@
+require busybox.inc
+PR = "r4"
+
+SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
+ http://busybox.net/downloads/fixes-1.9.1/busybox-1.9.1-lineedit.patch;patch=1 \
+ file://udhcpscript.patch;patch=1 \
+ file://adduser-longops.patch;patch=1 \
+ file://sort-z-nul.patch;patch=1;status=upstream \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ cml1_do_configure
+}