summaryrefslogtreecommitdiff
path: root/meta/packages/busybox/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/busybox/files')
-rw-r--r--meta/packages/busybox/files/busybox-appletlib-dependency.patch15
-rw-r--r--meta/packages/busybox/files/find-touchscreen.sh9
-rwxr-xr-xmeta/packages/busybox/files/mdev11
-rw-r--r--meta/packages/busybox/files/mdev.conf33
-rw-r--r--meta/packages/busybox/files/mountall1
-rw-r--r--meta/packages/busybox/files/simple.script72
6 files changed, 141 insertions, 0 deletions
diff --git a/meta/packages/busybox/files/busybox-appletlib-dependency.patch b/meta/packages/busybox/files/busybox-appletlib-dependency.patch
new file mode 100644
index 000000000..3efd4c088
--- /dev/null
+++ b/meta/packages/busybox/files/busybox-appletlib-dependency.patch
@@ -0,0 +1,15 @@
+Index: busybox-1.13.2/Makefile
+===================================================================
+--- busybox-1.13.2.orig/Makefile 2009-03-19 15:44:37.419270265 +0300
++++ busybox-1.13.2/Makefile 2009-03-19 15:45:57.737521296 +0300
+@@ -471,6 +471,10 @@
+ util-linux/ \
+ util-linux/volume_id/ \
+
++# Lib interdeps
++# libbb uses headers generated in applets
++libbb: applets
++
+ endif # KBUILD_EXTMOD
+
+ ifeq ($(dot-config),1)
diff --git a/meta/packages/busybox/files/find-touchscreen.sh b/meta/packages/busybox/files/find-touchscreen.sh
new file mode 100644
index 000000000..1582ea891
--- /dev/null
+++ b/meta/packages/busybox/files/find-touchscreen.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ `egrep "input:.*-e0.*,3,.*a0,1,.*18,.*" /sys/class/input/$MDEV/device/modalias|wc -l` -gt 0 ]; then
+ ln -sf /dev/input/$MDEV /dev/input/touchscreen0
+fi
+
+if [ `egrep "ads7846" /sys/class/input/$MDEV/device/modalias|wc -l` -gt 0 ]; then
+ ln -sf /dev/input/$MDEV /dev/input/touchscreen0
+fi
diff --git a/meta/packages/busybox/files/mdev b/meta/packages/busybox/files/mdev
new file mode 100755
index 000000000..4eed51e94
--- /dev/null
+++ b/meta/packages/busybox/files/mdev
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+mount -t tmpfs tmpfs /dev -o size=64k,mode=0755
+
+mkdir /dev/pts /dev/shm
+
+mount -t devpts devpts /dev/pts
+
+echo "/sbin/mdev" >/proc/sys/kernel/hotplug
+
+mdev -s
diff --git a/meta/packages/busybox/files/mdev.conf b/meta/packages/busybox/files/mdev.conf
new file mode 100644
index 000000000..163ebfe45
--- /dev/null
+++ b/meta/packages/busybox/files/mdev.conf
@@ -0,0 +1,33 @@
+console 0:0 0600
+cpu_dma_latency 0:0 0660
+fb0:0 44 0660
+full 0:0 0666
+initctl 0:0 0600
+ircomm[0-9].* 0:20 0660
+kmem 0:15 0640
+kmsg 0:0 0660
+log 0:0 0666
+loop[0-9].* 0:6 0640
+mem 0:15 0640
+network_latency 0:0 0660
+network_throughput 0:0 0660
+null 0:0 0666
+port 0:15 0640
+ptmx 0:5 0666
+ram[0-9].* 0:6 0640
+random 0:0 0666
+sda 0:6 0640
+tty 0:5 0666
+tty.* 0:0 0620
+urandom 0:0 0666
+usbdev.* 0:0 0660
+vcs.* 0:5 0660
+zero 0:0 0666
+
+pcm.* 0:0 0660 =snd/
+control.* 0:0 0660 =snd/
+timer 0:0 0660 =snd/
+
+event.* 0:0 0660 =input/ @/etc/mdev/find-touchscreen.sh
+mice 0:0 0660 =input/
+mouse.* 0:0 0660 =input/
diff --git a/meta/packages/busybox/files/mountall b/meta/packages/busybox/files/mountall
new file mode 100644
index 000000000..d5408b8f8
--- /dev/null
+++ b/meta/packages/busybox/files/mountall
@@ -0,0 +1 @@
+MOUNTALL="-t nonfs,nosmbfs,noncpfs"
diff --git a/meta/packages/busybox/files/simple.script b/meta/packages/busybox/files/simple.script
new file mode 100644
index 000000000..5cc21b9de
--- /dev/null
+++ b/meta/packages/busybox/files/simple.script
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# udhcpc script edited by Tim Riker <Tim@Rikers.org>
+
+[ -z "$1" ] && echo "Error: should be called from udhcpc" && exit 1
+
+RESOLV_CONF="/etc/resolv.conf"
+[ -n "$broadcast" ] && BROADCAST="broadcast $broadcast"
+[ -n "$subnet" ] && NETMASK="netmask $subnet"
+
+# return 0 if root is mounted on a network filesystem
+root_is_nfs() {
+ grep -qe '^/dev/root.*\(nfs\|smbfs\|ncp\|coda\) .*' /proc/mounts
+}
+
+have_bin_ip=0
+if [ -x /bin/ip ]; then
+ have_bin_ip=1
+fi
+
+case "$1" in
+ deconfig)
+ if ! root_is_nfs ; then
+ if [ $have_bin_ip -eq 1 ]; then
+ ip addr flush dev $interface
+ ip link set dev $interface up
+ else
+ /sbin/ifconfig $interface 0.0.0.0
+ fi
+ fi
+ ;;
+
+ renew|bound)
+ if [ $have_bin_ip -eq 1 ]; then
+ ip addr add dev $interface local $ip/$mask $BROADCAST
+ else
+ /sbin/ifconfig $interface $ip $BROADCAST $NETMASK
+ fi
+
+ if [ -n "$router" ] ; then
+ if ! root_is_nfs ; then
+ if [ $have_bin_ip -eq 1 ]; then
+ while ip route del default 2>/dev/null ; do
+ :
+ done
+ else
+ while route del default gw 0.0.0.0 dev $interface 2>/dev/null ; do
+ :
+ done
+ fi
+ fi
+
+ metric=0
+ for i in $router ; do
+ if [ $have_bin_ip -eq 1 ]; then
+ ip route add default via $i metric $((metric++))
+ else
+ route add default gw $i dev $interface metric $((metric++)) 2>/dev/null
+ fi
+ done
+ fi
+
+ echo -n > $RESOLV_CONF
+ [ -n "$domain" ] && echo search $domain >> $RESOLV_CONF
+ for i in $dns ; do
+ echo adding dns $i
+ echo nameserver $i >> $RESOLV_CONF
+ done
+ ;;
+esac
+
+exit 0