summaryrefslogtreecommitdiff
path: root/meta/packages/cx3110x/cx3110x_2.0.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/cx3110x/cx3110x_2.0.15.bb')
-rw-r--r--meta/packages/cx3110x/cx3110x_2.0.15.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/cx3110x/cx3110x_2.0.15.bb b/meta/packages/cx3110x/cx3110x_2.0.15.bb
new file mode 100644
index 000000000..b4a184e21
--- /dev/null
+++ b/meta/packages/cx3110x/cx3110x_2.0.15.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "cx3110x wifi support as found in the Nokia 770/N800/N810"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PACKAGES = "${PN}"
+
+COMPATIBLE_MACHINE = "(nokia800)"
+
+export KERNEL_SRC_DIR = ${STAGING_KERNEL_DIR}
+export LDFLAGS = ""
+
+SRC_URI = "http://repository.maemo.org/pool/os2008/free/source/c/cx3110x-module-src/cx3110x-module-src_2.0.15-1.tar.gz"
+
+S = "${WORKDIR}/cx3110x-module-src-${PV}"
+
+inherit module
+
+do_compile() {
+ oe_runmake modules
+}
+
+BROKEN = "1"
+# require more headers or whole kernel source