summaryrefslogtreecommitdiff
path: root/meta/packages/dbus/dbus-glib-0.78
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/dbus/dbus-glib-0.78')
-rw-r--r--meta/packages/dbus/dbus-glib-0.78/fix_asneeded.patch13
-rw-r--r--meta/packages/dbus/dbus-glib-0.78/native-binding-tool.patch19
-rw-r--r--meta/packages/dbus/dbus-glib-0.78/no-examples.patch8
-rw-r--r--meta/packages/dbus/dbus-glib-0.78/run-with-tmp-session-bus.patch24
4 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus-glib-0.78/fix_asneeded.patch b/meta/packages/dbus/dbus-glib-0.78/fix_asneeded.patch
new file mode 100644
index 000000000..a0aaec372
--- /dev/null
+++ b/meta/packages/dbus/dbus-glib-0.78/fix_asneeded.patch
@@ -0,0 +1,13 @@
+Index: dbus-glib-0.78/dbus/Makefile.am
+===================================================================
+--- dbus-glib-0.78.orig/dbus/Makefile.am 2009-01-15 15:14:29.000000000 +0000
++++ dbus-glib-0.78/dbus/Makefile.am 2009-01-15 15:14:46.000000000 +0000
+@@ -104,7 +104,7 @@
+
+ dbus_bash_completion_helper_SOURCES = \
+ dbus-bash-completion-helper.c
+-dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) -lexpat libdbus-gtool.la libdbus-glib-1.la
++dbus_bash_completion_helper_LDADD=$(DBUS_LIBS) $(DBUS_GLIB_LIBS) libdbus-gtool.la libdbus-glib-1.la -lexpat
+
+
+ EXTRA_DIST=dbus-gmarshal.list make-dbus-glib-error-switch.sh make-dbus-glib-error-enum.sh dbus-bash-completion.sh.in
diff --git a/meta/packages/dbus/dbus-glib-0.78/native-binding-tool.patch b/meta/packages/dbus/dbus-glib-0.78/native-binding-tool.patch
new file mode 100644
index 000000000..1bdac5a39
--- /dev/null
+++ b/meta/packages/dbus/dbus-glib-0.78/native-binding-tool.patch
@@ -0,0 +1,19 @@
+Use the dbus-binding-tool from PATH, not the generated one.
+
+RP - 12/1/09
+
+Index: dbus-glib-0.76/tools/Makefile.am
+===================================================================
+--- dbus-glib-0.76.orig/tools/Makefile.am 2009-01-12 10:11:02.000000000 +0000
++++ dbus-glib-0.76/tools/Makefile.am 2009-01-12 10:12:01.000000000 +0000
+@@ -3,8 +3,8 @@
+ nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+-dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT)
+- $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --prefix=dbus_bus --output=dbus-glib-bindings.h dbus-bus-introspect.xml
++dbus-glib-bindings.h: dbus-bus-introspect.xml
++ dbus-binding-tool --mode=glib-client --prefix=dbus_bus --output=dbus-glib-bindings.h dbus-bus-introspect.xml
+
+ BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+
diff --git a/meta/packages/dbus/dbus-glib-0.78/no-examples.patch b/meta/packages/dbus/dbus-glib-0.78/no-examples.patch
new file mode 100644
index 000000000..483153db7
--- /dev/null
+++ b/meta/packages/dbus/dbus-glib-0.78/no-examples.patch
@@ -0,0 +1,8 @@
+--- dbus-glib-0.70/dbus/Makefile.am.orig 2006-07-23 16:04:43.000000000 +0200
++++ dbus-glib-0.70/dbus/Makefile.am 2006-07-23 16:04:52.000000000 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++SUBDIRS = .
+
+ INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
+
diff --git a/meta/packages/dbus/dbus-glib-0.78/run-with-tmp-session-bus.patch b/meta/packages/dbus/dbus-glib-0.78/run-with-tmp-session-bus.patch
new file mode 100644
index 000000000..a04f404f7
--- /dev/null
+++ b/meta/packages/dbus/dbus-glib-0.78/run-with-tmp-session-bus.patch
@@ -0,0 +1,24 @@
+Index: dbus-glib-0.76/tools/run-with-tmp-session-bus.sh
+===================================================================
+--- dbus-glib-0.76.orig/tools/run-with-tmp-session-bus.sh 2008-06-13 16:31:54.000000000 +0100
++++ dbus-glib-0.76/tools/run-with-tmp-session-bus.sh 2008-06-13 16:32:54.000000000 +0100
+@@ -30,17 +30,15 @@
+ echo "escaped service dir is: $ESCAPED_SERVICE_DIR" >&2
+
+ ## create a configuration file based on the standard session.conf
+-cat $DBUS_TOP_SRCDIR/tools/session.conf | \
++cat $datadir/tools/session.conf | \
+ sed -e 's/<servicedir>.*$/<servicedir>'$ESCAPED_SERVICE_DIR'<\/servicedir>/g' | \
+ sed -e 's/<include.*$//g' \
+ > $CONFIG_FILE
+
+ echo "Created configuration file $CONFIG_FILE" >&2
+
+-PATH=$DBUS_TOP_BUILDDIR/bus:$PATH
+-export PATH
+ ## the libtool script found by the path search should already do this, but
+-LD_LIBRARY_PATH=$DBUS_TOP_BUILDDIR/dbus/.libs:$LD_LIBRARY_PATH
++LD_LIBRARY_PATH=$libdir:$LD_LIBRARY_PATH
+ export PATH
+ unset DBUS_SESSION_BUS_ADDRESS
+ unset DBUS_SESSION_BUS_PID