summaryrefslogtreecommitdiff
path: root/meta/packages/elfutils/elfutils-0.131
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/elfutils/elfutils-0.131')
-rw-r--r--meta/packages/elfutils/elfutils-0.131/gcc-4.3_support.diff100
-rw-r--r--meta/packages/elfutils/elfutils-0.131/gnu_inline.diff105
-rw-r--r--meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch70
-rw-r--r--meta/packages/elfutils/elfutils-0.131/warnings.patch154
4 files changed, 0 insertions, 429 deletions
diff --git a/meta/packages/elfutils/elfutils-0.131/gcc-4.3_support.diff b/meta/packages/elfutils/elfutils-0.131/gcc-4.3_support.diff
deleted file mode 100644
index b337da9b6..000000000
--- a/meta/packages/elfutils/elfutils-0.131/gcc-4.3_support.diff
+++ /dev/null
@@ -1,100 +0,0 @@
-Index: elfutils-0.131/libelf/common.h
-===================================================================
---- elfutils-0.131.orig/libelf/common.h 2008-04-02 13:32:19.000000000 -0300
-+++ elfutils-0.131/libelf/common.h 2008-04-02 13:35:53.000000000 -0300
-@@ -110,45 +110,6 @@
- }
-
-
--/* Acquire lock for the descriptor and all children. */
--static void
--libelf_acquire_all (Elf *elf)
--{
-- rwlock_wrlock (elf->lock);
--
-- if (elf->kind == ELF_K_AR)
-- {
-- Elf *child = elf->state.ar.children;
--
-- while (child != NULL)
-- {
-- if (child->ref_count != 0)
-- libelf_acquire_all (child);
-- child = child->next;
-- }
-- }
--}
--
--/* Release own lock and those of the children. */
--static void
--libelf_release_all (Elf *elf)
--{
-- if (elf->kind == ELF_K_AR)
-- {
-- Elf *child = elf->state.ar.children;
--
-- while (child != NULL)
-- {
-- if (child->ref_count != 0)
-- libelf_release_all (child);
-- child = child->next;
-- }
-- }
--
-- rwlock_unlock (elf->lock);
--}
--
--
- /* Macro to convert endianess in place. It determines the function it
- has to use itself. */
- #define CONVERT(Var) \
-Index: elfutils-0.131/libelf/elf_readall.c
-===================================================================
---- elfutils-0.131.orig/libelf/elf_readall.c 2008-04-02 13:36:06.000000000 -0300
-+++ elfutils-0.131/libelf/elf_readall.c 2008-04-02 13:38:25.000000000 -0300
-@@ -60,6 +60,45 @@
- #include "common.h"
-
-
-+/* Acquire lock for the descriptor and all children. */
-+static void
-+libelf_acquire_all (Elf *elf)
-+{
-+ rwlock_wrlock (elf->lock);
-+
-+ if (elf->kind == ELF_K_AR)
-+ {
-+ Elf *child = elf->state.ar.children;
-+
-+ while (child != NULL)
-+ {
-+ if (child->ref_count != 0)
-+ libelf_acquire_all (child);
-+ child = child->next;
-+ }
-+ }
-+}
-+
-+/* Release own lock and those of the children. */
-+static void
-+libelf_release_all (Elf *elf)
-+{
-+ if (elf->kind == ELF_K_AR)
-+ {
-+ Elf *child = elf->state.ar.children;
-+
-+ while (child != NULL)
-+ {
-+ if (child->ref_count != 0)
-+ libelf_release_all (child);
-+ child = child->next;
-+ }
-+ }
-+
-+ rwlock_unlock (elf->lock);
-+}
-+
-+
- static void
- set_address (Elf *elf, size_t offset)
- {
diff --git a/meta/packages/elfutils/elfutils-0.131/gnu_inline.diff b/meta/packages/elfutils/elfutils-0.131/gnu_inline.diff
deleted file mode 100644
index 8652d0e1c..000000000
--- a/meta/packages/elfutils/elfutils-0.131/gnu_inline.diff
+++ /dev/null
@@ -1,105 +0,0 @@
----
- backends/ia64_retval.c | 3 +++
- libdw/libdw.h | 2 +-
- libdw/libdwP.h | 3 +++
- src/ld.h | 3 +++
- src/strip.c | 3 +++
- src/unstrip.c | 4 ++++
- 6 files changed, 17 insertions(+), 1 deletion(-)
-
---- elfutils-0.131.orig/backends/ia64_retval.c
-+++ elfutils-0.131/backends/ia64_retval.c
-@@ -31,10 +31,13 @@
- #include <dwarf.h>
-
- #define BACKEND ia64_
- #include "libebl_CPU.h"
-
-+#if defined(__GNUC_GNU_INLINE__) || defined(__GNUC_STDC_INLINE__)
-+#define inline inline __attribute__ ((gnu_inline))
-+#endif
-
- /* r8, or pair r8, r9, or aggregate up to r8-r11. */
- static const Dwarf_Op loc_intreg[] =
- {
- { .atom = DW_OP_reg8 }, { .atom = DW_OP_piece, .number = 8 },
---- elfutils-0.131.orig/libdw/libdw.h
-+++ elfutils-0.131/libdw/libdw.h
-@@ -62,11 +62,11 @@
- # define __nonnull_attribute__(args...)
- # define __deprecated_attribute__
- #endif
-
-
--#ifdef __GNUC_STDC_INLINE__
-+#if defined(__GNUC_GNU_INLINE__) || defined(__GNUC_STDC_INLINE__)
- # define __libdw_extern_inline extern __inline __attribute__ ((__gnu_inline__))
- #else
- # define __libdw_extern_inline extern __inline
- #endif
-
---- elfutils-0.131.orig/libdw/libdwP.h
-+++ elfutils-0.131/libdw/libdwP.h
-@@ -54,10 +54,13 @@
- #include <libintl.h>
- #include <stdbool.h>
-
- #include <libdw.h>
-
-+#if defined(__GNUC_GNU_INLINE__) || defined(__GNUC_STDC_INLINE__)
-+#define inline inline __attribute__ ((gnu_inline))
-+#endif
-
- /* gettext helper macros. */
- #define _(Str) dgettext ("elfutils", Str)
-
-
---- elfutils-0.131.orig/src/ld.h
-+++ elfutils-0.131/src/ld.h
-@@ -30,10 +30,13 @@
- #include <obstack.h>
- #include <stdbool.h>
- #include <stdio.h>
- #include "xelf.h"
-
-+#if defined(__GNUC_GNU_INLINE__) || defined(__GNUC_STDC_INLINE__)
-+#define inline inline __attribute__ ((gnu_inline))
-+#endif
-
- /* Recommended size of the buffer passed to ld_strerror. */
- #define ERRBUFSIZE (512)
-
- /* Character used to introduce version name after symbol. */
---- elfutils-0.131.orig/src/strip.c
-+++ elfutils-0.131/src/strip.c
-@@ -50,10 +50,13 @@
-
- #include <elf-knowledge.h>
- #include <libebl.h>
- #include <system.h>
-
-+#if defined(__GNUC_GNU_INLINE__) || defined(__GNUC_STDC_INLINE__)
-+#define inline inline __attribute__ ((gnu_inline))
-+#endif
-
- /* Name and version of program. */
- static void print_version (FILE *stream, struct argp_state *state);
- void (*argp_program_version_hook) (FILE *, struct argp_state *) = print_version;
-
---- elfutils-0.131.orig/src/unstrip.c
-+++ elfutils-0.131/src/unstrip.c
-@@ -60,10 +60,14 @@
-
- #ifndef _
- # define _(str) gettext (str)
- #endif
-
-+#if defined(__GNUC_GNU_INLINE__) || defined(__GNUC_STDC_INLINE__)
-+#define inline inline __attribute__ ((gnu_inline))
-+#endif
-+
- /* Name and version of program. */
- static void print_version (FILE *stream, struct argp_state *state);
- void (*argp_program_version_hook) (FILE *, struct argp_state *)
- = print_version;
-
diff --git a/meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch b/meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch
deleted file mode 100644
index 3c3cf79d9..000000000
--- a/meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-newer prelink building (configure) fails like this
- checking libelf.h usability... no
- checking libelf.h presence... yes
- configure: WARNING: libelf.h: present but cannot be compiled
-
-Found a bug report suggesting fix for the issue here:
- http://bugs.gentoo.org/204502
-The bug report says:
-------- Comment #7 From SpanKY 2008-01-06 04:53:16 0000 [reply] -------
-do `sed -i 's:off64_t:__off64_t:'` on libelf.h ... that lets me build prelink
-
-2010/06/24
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-
-Index: elfutils-0.131/libelf/libelf.h
-===================================================================
---- elfutils-0.131.orig/libelf/libelf.h
-+++ elfutils-0.131/libelf/libelf.h
-@@ -95,7 +95,7 @@ typedef struct
- Elf_Type d_type; /* Type of this piece of data. */
- unsigned int d_version; /* ELF version. */
- size_t d_size; /* Size in bytes. */
-- off64_t d_off; /* Offset into section. */
-+ __off64_t d_off; /* Offset into section. */
- size_t d_align; /* Alignment in section. */
- } Elf_Data;
-
-@@ -157,7 +157,7 @@ typedef struct
- uid_t ar_uid; /* User ID. */
- gid_t ar_gid; /* Group ID. */
- mode_t ar_mode; /* File mode. */
-- off64_t ar_size; /* File size. */
-+ __off64_t ar_size; /* File size. */
- char *ar_rawname; /* Original name of archive member. */
- } Elf_Arhdr;
-
-@@ -198,13 +198,13 @@ extern Elf_Cmd elf_next (Elf *__elf);
- extern int elf_end (Elf *__elf);
-
- /* Update ELF descriptor and write file to disk. */
--extern off64_t elf_update (Elf *__elf, Elf_Cmd __cmd);
-+extern __off64_t elf_update (Elf *__elf, Elf_Cmd __cmd);
-
- /* Determine what kind of file is associated with ELF. */
- extern Elf_Kind elf_kind (Elf *__elf) __attribute__ ((__pure__));
-
- /* Get the base offset for an object file. */
--extern off64_t elf_getbase (Elf *__elf);
-+extern __off64_t elf_getbase (Elf *__elf);
-
-
- /* Retrieve file identification data. */
-@@ -302,7 +302,7 @@ extern Elf_Data *elf_newdata (Elf_Scn *_
- would be for TYPE. The resulting Elf_Data pointer is valid until
- elf_end (ELF) is called. */
- extern Elf_Data *elf_getdata_rawchunk (Elf *__elf,
-- off64_t __offset, size_t __size,
-+ __off64_t __offset, size_t __size,
- Elf_Type __type);
-
-
-@@ -314,7 +314,7 @@ extern char *elf_strptr (Elf *__elf, siz
- extern Elf_Arhdr *elf_getarhdr (Elf *__elf);
-
- /* Return offset in archive for current file ELF. */
--extern off64_t elf_getaroff (Elf *__elf);
-+extern __off64_t elf_getaroff (Elf *__elf);
-
- /* Select archive element at OFFSET. */
- extern size_t elf_rand (Elf *__elf, size_t __offset);
diff --git a/meta/packages/elfutils/elfutils-0.131/warnings.patch b/meta/packages/elfutils/elfutils-0.131/warnings.patch
deleted file mode 100644
index 132e3cf63..000000000
--- a/meta/packages/elfutils/elfutils-0.131/warnings.patch
+++ /dev/null
@@ -1,154 +0,0 @@
----
- configure.ac | 4 ++++
- lib/Makefile.am | 2 +-
- libasm/Makefile.am | 2 +-
- libcpu/Makefile.am | 2 +-
- libdw/Makefile.am | 2 +-
- libebl/Makefile.am | 2 +-
- libelf/Makefile.am | 2 +-
- src/Makefile.am | 2 +-
- tests/Makefile.am | 4 ++--
- 9 files changed, 13 insertions(+), 9 deletions(-)
-
---- elfutils-0.131.orig/configure.ac
-+++ elfutils-0.131/configure.ac
-@@ -54,10 +54,14 @@ AC_DEFINE(USE_TLS))
- AH_TEMPLATE([USE_TLS], [Defined if thread local storage should be used.])
-
- dnl Add all the languages for which translations are available.
- ALL_LINGUAS=
-
-+if test X"$CFLAGS" = X; then
-+ CFLAGS="-Wall -g -O2"
-+fi
-+
- AC_PROG_CC
- AC_PROG_RANLIB
- AC_PROG_YACC
- AM_PROG_LEX
-
---- elfutils-0.131.orig/lib/Makefile.am
-+++ elfutils-0.131/lib/Makefile.am
-@@ -28,11 +28,11 @@ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
- if MUDFLAP
- AM_CFLAGS = -fmudflap
- else
- AM_CFLAGS =
- endif
--AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra $($(*F)_CFLAGS)
-+AM_CFLAGS += -fpic -Wshadow -Wunused $($(*F)_CFLAGS)
- INCLUDES = -I$(srcdir)/../libelf -I..
-
- noinst_LIBRARIES = libeu.a
-
- libeu_a_SOURCES = xstrndup.c xmalloc.c next_prime.c \
---- elfutils-0.131.orig/libasm/Makefile.am
-+++ elfutils-0.131/libasm/Makefile.am
-@@ -28,11 +28,11 @@ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
- if MUDFLAP
- AM_CFLAGS = -fmudflap
- else
- AM_CFLAGS =
- endif
--AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
-+AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Wunused -Wextra -Wformat=2
- INCLUDES = -I. -I$(srcdir) -I.. \
- -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw\
- -I$(top_srcdir)/lib
- GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
- VERSION = 1
---- elfutils-0.131.orig/libcpu/Makefile.am
-+++ elfutils-0.131/libcpu/Makefile.am
-@@ -23,11 +23,11 @@
- ## included package. Should you wish to participate in the Open Invention
- ## Network licensing program, please visit www.openinventionnetwork.com
- ## <http://www.openinventionnetwork.com>.
- ##
- DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
--AM_CFLAGS = -Wall -Wshadow -Werror -Wextra -Wformat=2 -Wunused
-+AM_CFLAGS = -Wshadow -Wformat=2 -Wunused
- INCLUDES = -I$(srcdir)
-
- noinst_LIBRARIES = libcpu_i386.a
-
- libcpu_i386_a_SOURCES = i386_dis.c
---- elfutils-0.131.orig/libdw/Makefile.am
-+++ elfutils-0.131/libdw/Makefile.am
-@@ -31,11 +31,11 @@ else
- AM_CFLAGS =
- endif
- if BUILD_STATIC
- AM_CFLAGS += -fpic
- endif
--AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
-+AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99
- INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
- VERSION = 1
-
- COMPILE.os = $(filter-out -fprofile-arcs, $(filter-out -ftest-coverage, \
- $(COMPILE)))
---- elfutils-0.131.orig/libebl/Makefile.am
-+++ elfutils-0.131/libebl/Makefile.am
-@@ -28,11 +28,11 @@ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H -DO
- if MUDFLAP
- AM_CFLAGS = -fmudflap
- else
- AM_CFLAGS =
- endif
--AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
-+AM_CFLAGS += -fpic -Wshadow -Wunused -Wformat=2 \
- -std=gnu99
-
- INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
- -I$(top_srcdir)/lib -I..
- VERSION = 1
---- elfutils-0.131.orig/libelf/Makefile.am
-+++ elfutils-0.131/libelf/Makefile.am
-@@ -31,11 +31,11 @@ else
- AM_CFLAGS =
- endif
- if BUILD_STATIC
- AM_CFLAGS += -fpic
- endif
--AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
-+AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99 \
- $($(*F)_CFLAGS)
- INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
- GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
- VERSION = 1
- PACKAGE_VERSION = @PACKAGE_VERSION@
---- elfutils-0.131.orig/src/Makefile.am
-+++ elfutils-0.131/src/Makefile.am
-@@ -30,11 +30,11 @@ if MUDFLAP
- AM_CFLAGS = -fmudflap
- else
- AM_CFLAGS =
- endif
- AM_CFLAGS += -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
-- $(if $($(*F)_no_Werror),,-Werror) \
-+ $(if $($(*F)_no_Werror),,) \
- $(if $($(*F)_no_Wunused),,-Wunused -Wextra) \
- $(if $($(*F)_no_Wformat),,-Wformat=2) $(CFLAGS_$(*F))
-
- INCLUDES = -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
- -I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
---- elfutils-0.131.orig/tests/Makefile.am
-+++ elfutils-0.131/tests/Makefile.am
-@@ -24,15 +24,15 @@
- ## Network licensing program, please visit www.openinventionnetwork.com
- ## <http://www.openinventionnetwork.com>.
- ##
- DEFS = -DHAVE_CONFIG_H -D_GNU_SOURCE
- if MUDFLAP
--AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
-+AM_CFLAGS = -Wall -Wextra -std=gnu99 -fmudflap\
- $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
- BUILD_RPATH = \$$ORIGIN/../backends
- else
--AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
-+AM_CFLAGS = -Wall -Wextra -std=gnu99 \
- $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
- BUILT_RPATH = \$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../backends:\$$ORIGIN/../libelf
- endif
-
- AM_LDFLAGS =