summaryrefslogtreecommitdiff
path: root/meta/packages/gcc/gcc-cross_4.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gcc/gcc-cross_4.2.2.bb')
-rw-r--r--meta/packages/gcc/gcc-cross_4.2.2.bb19
1 files changed, 6 insertions, 13 deletions
diff --git a/meta/packages/gcc/gcc-cross_4.2.2.bb b/meta/packages/gcc/gcc-cross_4.2.2.bb
index def16597e..8a7a21f18 100644
--- a/meta/packages/gcc/gcc-cross_4.2.2.bb
+++ b/meta/packages/gcc/gcc-cross_4.2.2.bb
@@ -1,22 +1,15 @@
-require gcc_${PV}.bb
-# path mangling, needed by the cross packaging
-require gcc-paths-cross.inc
-inherit cross
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
-# NOTE: split PR. If the main .oe changes something that affects its *build*
-# remember to increment this one too.
PR = "r6"
-DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
-PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
-
-# cross build
-require gcc3-build-cross.inc
-# cross packaging
+require gcc-${PV}.inc
+require gcc-cross4.inc
+require gcc-configure-cross.inc
require gcc-package-cross.inc
+
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
# Do not build libssp libmudflap and libgomp
# We might need them for some beefy targets
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
--with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"