summaryrefslogtreecommitdiff
path: root/meta/packages/gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gnome')
-rw-r--r--meta/packages/gnome/metacity-clutter/crosscompile.patch55
-rw-r--r--meta/packages/gnome/metacity-clutter/fix_pkgconfig.patch10
-rw-r--r--meta/packages/gnome/metacity-clutter/nodocs.patch29
-rw-r--r--meta/packages/gnome/metacity-clutter_git.bb51
4 files changed, 0 insertions, 145 deletions
diff --git a/meta/packages/gnome/metacity-clutter/crosscompile.patch b/meta/packages/gnome/metacity-clutter/crosscompile.patch
deleted file mode 100644
index b27383b09..000000000
--- a/meta/packages/gnome/metacity-clutter/crosscompile.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-Index: git/configure.in
-===================================================================
---- git.orig/configure.in 2009-01-27 14:49:10.000000000 +0000
-+++ git/configure.in 2009-01-27 15:29:41.000000000 +0000
-@@ -46,6 +46,32 @@
- AC_LIBTOOL_WIN32_DLL
- AM_PROG_LIBTOOL
-
-+if test x"$CC_FOR_BUILD" = x; then
-+ if test x"$cross_compiling" = xyes; then
-+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
-+ else
-+ CC_FOR_BUILD="$CC"
-+ fi
-+fi
-+AC_SUBST([CC_FOR_BUILD])
-+if test x"$CFLAGS_FOR_BUILD" = x; then
-+ if test x"$cross_compiling" = xyes; then
-+ AC_CHECK_PROGS(CFLAGS_FOR_BUILD, gcc cc)
-+ else
-+ CFLAGS_FOR_BUILD="$CFLAGS"
-+ fi
-+fi
-+AC_SUBST([CFLAGS_FOR_BUILD])
-+if test x"$LDFLAGS_FOR_BUILD" = x; then
-+ if test x"$cross_compiling" = xyes; then
-+ AC_CHECK_PROGS(LDFLAGS_FOR_BUILD, gcc cc)
-+ else
-+ LDFLAGS_FOR_BUILD="$LDFLAGS"
-+ fi
-+fi
-+AC_SUBST([LDFLAGS_FOR_BUILD])
-+
-+
- #### Integer sizes
-
- AC_CHECK_SIZEOF(char)
-Index: git/src/Makefile.am
-===================================================================
---- git.orig/src/Makefile.am 2009-01-27 15:25:31.000000000 +0000
-+++ git/src/Makefile.am 2009-01-27 15:39:54.000000000 +0000
-@@ -168,11 +168,9 @@
- metacity_dialog_SOURCES= \
- ui/metacity-dialog.c
-
--schema_bindings_SOURCES = \
-- core/schema-bindings.c \
-- metacity.schemas.in.in
-+schema_bindings:
-+ @CC_FOR_BUILD@ core/schema-bindings.c -I./include -I ../ @CFLAGS_FOR_BUILD@ @LDFLAGS_FOR_BUILD@ -o schema_bindings
-
--schema_bindings_LDADD = @METACITY_LIBS@
- metacity.schemas.in: schema_bindings ${srcdir}/metacity.schemas.in.in
- @echo Generating keybinding schemas... ${srcdir}/metacity.schemas.in.in
- ${builddir}/schema_bindings ${srcdir}/metacity.schemas.in.in ${builddir}/metacity.schemas.in
diff --git a/meta/packages/gnome/metacity-clutter/fix_pkgconfig.patch b/meta/packages/gnome/metacity-clutter/fix_pkgconfig.patch
deleted file mode 100644
index 3714383bc..000000000
--- a/meta/packages/gnome/metacity-clutter/fix_pkgconfig.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: git/src/metacity-plugins.pc.in
-===================================================================
---- git.orig/src/metacity-plugins.pc.in 2008-12-17 22:42:19.000000000 +0000
-+++ git/src/metacity-plugins.pc.in 2008-12-17 22:42:25.000000000 +0000
-@@ -14,4 +14,4 @@
- Requires: @CLUTTER_PACKAGE@
- Version: @VERSION@
- Libs: @CLUTTER_LIBS@
--Cflags: @CLUTTER_CFLAGS@ -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
-+Cflags: -DWITH_CLUTTER -I${includedir}/metacity-1/metacity-private -DMETACITY_MAJOR_VERSION=${metacity_major_version} -DMETACITY_MINOR_VERSION=${metacity_minor_version} -DMETACITY_MICRO_VERSION=${metacity_micro_version} -DMETACITY_CLUTTER_PLUGIN_API_VERSION=${metacity_clutter_plugin_api_version} -DMUTTER_PLUGIN_DIR=\"${mutterplugindir}\"
diff --git a/meta/packages/gnome/metacity-clutter/nodocs.patch b/meta/packages/gnome/metacity-clutter/nodocs.patch
deleted file mode 100644
index 98f43be5e..000000000
--- a/meta/packages/gnome/metacity-clutter/nodocs.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: git/Makefile.am
-===================================================================
---- git.orig/Makefile.am 2009-01-27 13:26:12.000000000 +0000
-+++ git/Makefile.am 2009-01-27 14:07:13.000000000 +0000
-@@ -1,5 +1,5 @@
-
--SUBDIRS=src po doc
-+SUBDIRS=src po
-
- EXTRA_DIST = HACKING MAINTAINERS rationales.txt \
- intltool-extract.in intltool-merge.in intltool-update.in
-Index: git/configure.in
-===================================================================
---- git.orig/configure.in 2009-01-27 13:26:12.000000000 +0000
-+++ git/configure.in 2009-01-27 14:11:16.000000000 +0000
-@@ -538,12 +538,9 @@
-
- # Warnings are there for a reason
- if test "x$GCC" = "xyes"; then
-- CFLAGS="$CFLAGS -Wall -Werror -ansi"
-+ CFLAGS="$CFLAGS -Wall -ansi"
- fi
-
--# Use gnome-doc-utils:
--GNOME_DOC_INIT([0.8.0])
--
- AC_CONFIG_FILES([
- Makefile
- doc/Makefile
diff --git a/meta/packages/gnome/metacity-clutter_git.bb b/meta/packages/gnome/metacity-clutter_git.bb
deleted file mode 100644
index 00d9a9427..000000000
--- a/meta/packages/gnome/metacity-clutter_git.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-SECTION = "x11/wm"
-DESCRIPTION = "Metacity is the boring window manager for the adult in you."
-LICENSE = "GPL"
-DEPENDS = "startup-notification gtk+ gconf clutter-0.8 gdk-pixbuf-csource-native intltool glib-2.0-native"
-PR = "r8"
-PV = "2.25.1+git${SRCREV}"
-inherit gnome update-alternatives
-
-SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter \
- file://nodocs.patch;patch=1 \
- file://crosscompile.patch;patch=1 \
- file://fix_pkgconfig.patch;patch=1"
-S = "${WORKDIR}/git"
-
-ALTERNATIVE_NAME = "x-window-manager"
-ALTERNATIVE_LINK = "${bindir}/x-window-manager"
-ALTERNATIVE_PATH = "${bindir}/metacity"
-ALTERNATIVE_PRIORITY = "11"
-
-EXTRA_OECONF += "--disable-verbose \
- --disable-xinerama \
- --with-clutter"
-
-FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so"
-FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include"
-export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0"
-
-do_configure_prepend () {
- echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make
-}
-
-do_stage () {
- autotools_stage_all
-}
-
-pkg_postinst_${PN} () {
-#!/bin/sh -e
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-. ${sysconfdir}/init.d/functions
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[default]'
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /apps/metacity/general/compositing_manager true
-}
-