summaryrefslogtreecommitdiff
path: root/meta/packages/gtk+/gtk+-2.18.5/configurefix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/gtk+/gtk+-2.18.5/configurefix.patch')
-rw-r--r--meta/packages/gtk+/gtk+-2.18.5/configurefix.patch98
1 files changed, 98 insertions, 0 deletions
diff --git a/meta/packages/gtk+/gtk+-2.18.5/configurefix.patch b/meta/packages/gtk+/gtk+-2.18.5/configurefix.patch
new file mode 100644
index 000000000..ba85f17c0
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.18.5/configurefix.patch
@@ -0,0 +1,98 @@
+Index: gtk+-2.18.5/docs/faq/Makefile.am
+===================================================================
+--- gtk+-2.18.5.orig/docs/faq/Makefile.am 2009-12-10 17:38:18.000000000 +0000
++++ gtk+-2.18.5/docs/faq/Makefile.am 2009-12-10 17:39:27.000000000 +0000
+@@ -3,34 +3,36 @@
+ EXTRA_DIST += \
+ gtk-faq.sgml
+
+-if HAVE_DOCBOOK
++
+ html:
++if HAVE_DOCBOOK
+ if test -w $(srcdir); then \
+ (cd $(srcdir); \
+ db2html gtk-faq.sgml; \
+ test -d html && rm -r html; \
+ mv gtk-faq html); \
+ fi
+-
+-pdf:
+- if test -w $(srcdir); then \
+- (cd $(srcdir); db2pdf gtk-faq.sgml); \
+- fi
+-
+-dist-hook: html
+- cp -Rp $(srcdir)/html $(distdir)
+ else
+-html:
+ echo "***"
+ echo "*** Warning: FAQ not built"
+ echo "***"
++endif
+
+ pdf:
++if HAVE_DOCBOOK
++ if test -w $(srcdir); then \
++ (cd $(srcdir); db2pdf gtk-faq.sgml); \
++ fi
++else
+ echo "***"
+ echo "*** Warning: FAQ not built"
+ echo "***"
++endif
+
+-dist-hook:
++dist-hook: html
++if HAVE_DOCBOOK
++ cp -Rp $(srcdir)/html $(distdir)
++else
+ echo "***"
+ echo "*** Warning: FAQ not built"
+ echo "*** DISTRIBUTION IS INCOMPLETE"
+Index: gtk+-2.18.5/gtk-doc.make
+===================================================================
+--- gtk+-2.18.5.orig/gtk-doc.make 2009-12-10 17:47:54.000000000 +0000
++++ gtk+-2.18.5/gtk-doc.make 2009-12-10 17:48:01.000000000 +0000
+@@ -23,7 +23,7 @@
+
+ TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+-EXTRA_DIST = \
++EXTRA_DIST += \
+ $(content_files) \
+ $(HTML_IMAGES) \
+ $(DOC_MAIN_SGML_FILE) \
+Index: gtk+-2.18.5/gtk/tests/Makefile.am
+===================================================================
+--- gtk+-2.18.5.orig/gtk/tests/Makefile.am 2009-12-10 17:43:16.000000000 +0000
++++ gtk+-2.18.5/gtk/tests/Makefile.am 2009-12-10 18:11:40.000000000 +0000
+@@ -57,13 +57,13 @@
+ # this doesn't work in make distcheck, since running
+ # on a naked X server creates slightly different event
+ # sequences than running on a normal desktop
+-# TEST_PROGS += crossingevents
++#TEST_PROGS += crossingevents
+ crossingevents_SOURCES = crossingevents.c
+ crossingevents_LDADD = $(progs_ldadd)
+
+ # this doesn't work in make distcheck, since it doesn't
+ # find file-chooser-test-dir
+-# TEST_PROGS += filechooser
++#TEST_PROGS += filechooser
+ filechooser_SOURCES = filechooser.c pixbuf-init.c
+ filechooser_LDADD = $(progs_ldadd)
+
+Index: gtk+-2.18.5/tests/Makefile.am
+===================================================================
+--- gtk+-2.18.5.orig/tests/Makefile.am 2009-12-10 17:41:49.000000000 +0000
++++ gtk+-2.18.5/tests/Makefile.am 2009-12-10 17:45:33.000000000 +0000
+@@ -339,7 +339,7 @@
+ gtkoffscreenbox.h \
+ testoffscreen.c
+
+-testwindow_SOURCES = \
++testwindows_SOURCES = \
+ testwindows.c
+
+ EXTRA_DIST += \