summaryrefslogtreecommitdiff
path: root/meta/packages/linux-libc-headers
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/linux-libc-headers')
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb9
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb11
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb12
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb22
-rw-r--r--meta/packages/linux-libc-headers/linux-libc-headers_2.6.20.bb2
5 files changed, 39 insertions, 17 deletions
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
index 30f57000b..3f5cc3a0b 100644
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
@@ -1,12 +1,11 @@
-SECTION = "devel"
-DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+require linux-libc-headers.inc
+
HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
-# license note from the package:
+# license note from the package:
# Linux-libc-headers are derived from linux kernel headers. For license of a
# particular header, check it's content, and if copyright notice isn't present,
-# standard linux kernel license applies.
+# standard linux kernel license applies.
# since we assume GPL for linux i think we can also assume it here
-LICENSE = "GPL"
INHIBIT_DEFAULT_DEPS = "1"
PR = "r2"
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
index 8d82f7b66..0dba90dc9 100644
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
@@ -1,17 +1,16 @@
-SECTION = "devel"
-DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+require linux-libc-headers.inc
+
# This package is derived from the original linux-libc-headers at
# http://ep09.pld-linux.org/~mmazur/linux-libc-headers/
-# More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with
+# More specifically, llh-2.6.12.0 was patched up to 2.6.16-rc6 with
# the official linux patches (where applicable) and then fixed up just
# enough to build glibc-2.4. BEWARE!
#
-# license note from the linux-libc-headers package:
+# license note from the linux-libc-headers package:
# Linux-libc-headers are derived from linux kernel headers. For license of a
# particular header, check it's content, and if copyright notice isn't present,
-# standard linux kernel license applies.
+# standard linux kernel license applies.
# since we assume GPL for linux i think we can also assume it here
-LICENSE = "GPL"
DEFAULT_PREFERENCE = "-1"
INHIBIT_DEFAULT_DEPS = "1"
PR = "r4"
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb
index 8c6222560..7cb5c4aa2 100644
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18+2.6.19-rc1.bb
@@ -36,7 +36,7 @@ do_install() {
set_arch
install -d ${D}${includedir}
cp -pfLR ${S}${includedir}/linux ${D}${includedir}/
- cp -pfLR ${S}${includedir}/asm-$ARCH ${D}${includedir}/asm
+ cp -pfLR ${S}${includedir}/asm-${ARCH} ${D}${includedir}/asm
cp -pfLR ${S}${includedir}/asm-generic ${D}${includedir}/
}
@@ -45,6 +45,14 @@ do_stage () {
install -d ${STAGING_INCDIR}
rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
cp -pfLR ${S}${includedir}/linux ${STAGING_INCDIR}/
- cp -pfLR ${S}${includedir}/asm-$ARCH ${STAGING_INCDIR}/asm
+ cp -pfLR ${S}${includedir}/asm-${ARCH} ${STAGING_INCDIR}/asm
cp -pfLR ${S}${includedir}/asm-generic ${STAGING_INCDIR}/
}
+
+do_stage_append_nylon () {
+ cp -pPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
+ cp -pPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
+ cp -pPR include/linux/* ${STAGING_INCDIR}/linux/
+ cp -pPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
+}
+
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
index 33cbb4ad2..3abf26f4f 100644
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
@@ -30,7 +30,7 @@ set_arch() {
do_configure() {
set_arch
- oe_runmake allnoconfig ARCH=$ARCH
+ oe_runmake allnoconfig ARCH=${ARCH}
}
do_compile () {
@@ -38,7 +38,7 @@ do_compile () {
do_install() {
set_arch
- oe_runmake headers_install INSTALL_HDR_PATH=${D}/usr ARCH=$ARCH
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}/usr ARCH=${ARCH}
}
do_install_append_arm() {
@@ -51,8 +51,8 @@ do_stage () {
set_arch
rm -rf ${STAGE_TEMP}
mkdir -p ${STAGE_TEMP}
- oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}/usr ARCH=$ARCH
- if [ "$ARCH" = "arm" ]; then
+ oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}/usr ARCH=${ARCH}
+ if [ "${ARCH}" == "arm" ]; then
cp include/asm-arm/procinfo.h ${STAGE_TEMP}${includedir}/asm
fi
install -d ${STAGING_INCDIR}
@@ -60,4 +60,18 @@ do_stage () {
cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
+ # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
+ # utsrelease.h in order to avoid recompiling a kernel every time a localversion
+ # changed. Since the our headers are static and we're not compiling an
+ # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
+ # compile with kernel headers that work with EABI on ARM
+ echo '#define UTS_RELEASE "2.6.18"' >> ${STAGING_INCDIR}/linux/version.h
}
+
+do_stage_append_nylon () {
+ cp -pPR include/asm-${ARCH}/* ${STAGING_INCDIR}/asm/
+ cp -pPR include/asm-${ARCH}/* ${CROSS_DIR}/${TARGET_SYS}/include/asm/
+ cp -pPR include/linux/* ${STAGING_INCDIR}/linux/
+ cp -pPR include/linux/* ${CROSS_DIR}/${TARGET_SYS}/include/linux/
+}
+
diff --git a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.20.bb b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.20.bb
index 3f5607684..0b6112884 100644
--- a/meta/packages/linux-libc-headers/linux-libc-headers_2.6.20.bb
+++ b/meta/packages/linux-libc-headers/linux-libc-headers_2.6.20.bb
@@ -25,6 +25,8 @@ set_arch() {
sparc64*) ARCH=sparc64 ;;
sparc*) ARCH=sparc ;;
x86_64*) ARCH=x86_64 ;;
+ avr32*) ARCH=avr32 ;;
+ bfin*) ARCH=blackfin ;;
esac
}