summaryrefslogtreecommitdiff
path: root/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb')
-rw-r--r--meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
new file mode 100644
index 000000000..e1180ad30
--- /dev/null
+++ b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Custom MB session files for poky"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session"
+PR = "r22"
+
+SRC_URI = "file://session"
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/matchbox
+ install -m 0755 ${S}/session ${D}/${sysconfdir}/matchbox/
+}
+
+pkg_postinst_matchbox-sato () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+. ${sysconfdir}/init.d/functions
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/touchscreen true
+
+if [ "`cpuinfo_id`" = "GTA01" ]
+then
+ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 6"
+else
+ gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
+fi
+}