summaryrefslogtreecommitdiff
path: root/meta/packages/matchbox-sato
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/matchbox-sato')
-rw-r--r--meta/packages/matchbox-sato/matchbox-session-sato/session22
-rw-r--r--meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb53
2 files changed, 0 insertions, 75 deletions
diff --git a/meta/packages/matchbox-sato/matchbox-session-sato/session b/meta/packages/matchbox-sato/matchbox-session-sato/session
deleted file mode 100644
index 1a7e99c0a..000000000
--- a/meta/packages/matchbox-sato/matchbox-session-sato/session
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh
-
-. /etc/formfactor/config
-
-if [ "$HAVE_TOUCHSCREEN" = "1" ]; then
- SHOWCURSOR="no"
-else
- SHOWCURSOR="yes"
-fi
-
-matchbox-desktop &
-
-# Lines containing feature-[foo] are removed at build time if the machine
-# doesn't have the feature "foo".
-
-START_APPLETS=showdesktop,windowselector
-END_APPLETS=clock,battery,systray,startup-notify,notify
-END_APPLETS=openmoko-panel-gsm,$END_APPLETS # feature-phone
-
-matchbox-panel --titlebar --start-applets $START_APPLETS --end-applets $END_APPLETS &
-
-exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
deleted file mode 100644
index 5c01a1328..000000000
--- a/meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
+++ /dev/null
@@ -1,53 +0,0 @@
-DESCRIPTION = "Custom MB session files for poky"
-HOMEPAGE = "http://www.matchbox-project.org/"
-BUGTRACKER = "http://bugzilla.openedhand.com/"
-
-LICENSE = "GPL"
-
-SECTION = "x11"
-RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session"
-PR = "r27"
-
-# This package is architecture specific because the session script is modified
-# based on the machine architecture.
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-SRC_URI = "file://session"
-S = "${WORKDIR}"
-
-do_install() {
- # This is the set of machine features that the script has markers for
- FEATURES="phone"
- SCRIPT="${S}/sedder"
- rm -f $SCRIPT
- touch $SCRIPT
- for FEAT in $FEATURES; do
- if echo ${MACHINE_FEATURES} | awk "/$FEAT/ {exit 1}"; then
- echo "/feature-$FEAT/d" >> $SCRIPT
- fi
- done
-
- install -d ${D}/${sysconfdir}/matchbox
- sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
- chmod +x ${D}/${sysconfdir}/matchbox/session
-}
-
-pkg_postinst_${PN} () {
-#!/bin/sh -e
-if [ "x$D" != "x" ]; then
- exit 1
-fi
-
-. ${sysconfdir}/init.d/functions
-
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
-gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/touchscreen true
-
-if [ "`machine_id`" = "gta01" ]
-then
- gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 6"
-else
- gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
-fi
-}