summaryrefslogtreecommitdiff
path: root/meta/packages/pointercal/pointercal_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/pointercal/pointercal_0.0.bb')
-rw-r--r--meta/packages/pointercal/pointercal_0.0.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta/packages/pointercal/pointercal_0.0.bb b/meta/packages/pointercal/pointercal_0.0.bb
index 36bcca85b..6cf50241a 100644
--- a/meta/packages/pointercal/pointercal_0.0.bb
+++ b/meta/packages/pointercal/pointercal_0.0.bb
@@ -1,14 +1,17 @@
DESCRIPTION = "Touchscreen calibration data"
SECTION = "base"
-
-COMPATIBLE_MACHINE = "(spitz|c7x0|nokia800|akita)"
+PR = "r1"
SRC_URI = "file://pointercal"
S = "${WORKDIR}"
+ALLOW_EMPTY_${PN} = "1"
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_install() {
- install -d ${D}${sysconfdir}/
- install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+ # Only install file if it has a contents
+ if [ -s ${S}/pointercal ]; then
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${S}/pointercal ${D}${sysconfdir}/
+ fi
}