summaryrefslogtreecommitdiff
path: root/meta/packages/psplash/psplash_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/psplash/psplash_0.0.bb')
-rw-r--r--meta/packages/psplash/psplash_0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/psplash/psplash_0.0.bb b/meta/packages/psplash/psplash_0.0.bb
new file mode 100644
index 000000000..a64b4c2b7
--- /dev/null
+++ b/meta/packages/psplash/psplash_0.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
+SECTION = "base"
+MAINTAINER = "Matthew Allum <mallum@openedhand.com>"
+LICENSE = "GPL"
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
+ file://psplash-init"
+
+S = "${WORKDIR}/psplash"
+
+inherit autotools pkgconfig update-rc.d
+
+FILES_${PN} += "/mnt/.psplash"
+
+do_install_prepend() {
+ install -d ${D}/mnt/.psplash/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+}
+
+INITSCRIPT_NAME = "psplash"
+INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."