summaryrefslogtreecommitdiff
path: root/meta/packages/psplash
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/psplash')
-rwxr-xr-xmeta/packages/psplash/files/psplash-init29
-rw-r--r--meta/packages/psplash/psplash_svn.bb26
2 files changed, 0 insertions, 55 deletions
diff --git a/meta/packages/psplash/files/psplash-init b/meta/packages/psplash/files/psplash-init
deleted file mode 100755
index 66c85e933..000000000
--- a/meta/packages/psplash/files/psplash-init
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-### BEGIN INIT INFO
-# Provides: psplash
-# Required-Start:
-# Required-Stop:
-# Default-Start: S
-# Default-Stop:
-### END INIT INFO
-
-read CMDLINE < /proc/cmdline
-for x in $CMDLINE; do
- case $x in
- psplash=false)
- echo "Boot splashscreen disabled"
- exit 0;
- ;;
- esac
-done
-
-export TMPDIR=/mnt/.psplash
-mount tmpfs -t tmpfs $TMPDIR -o,size=40k
-
-rotation=0
-if [ -e /etc/rotation ]; then
- read rotation < /etc/rotation
-fi
-
-/usr/bin/psplash --angle $rotation &
-
diff --git a/meta/packages/psplash/psplash_svn.bb b/meta/packages/psplash/psplash_svn.bb
deleted file mode 100644
index 1e53ef1f1..000000000
--- a/meta/packages/psplash/psplash_svn.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
-HOMEPAGE = "http://svn.o-hand.com/view/misc/trunk/psplash/"
-SECTION = "base"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://psplash.h;md5=a87c39812c1e37f3451567cc29a29c8f"
-
-PV = "0.0+svnr${SRCREV}"
-PR = "r5"
-
-SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
- file://psplash-init"
-
-S = "${WORKDIR}/psplash"
-
-inherit autotools pkgconfig update-rc.d
-
-FILES_${PN} += "/mnt/.psplash"
-
-do_install_prepend() {
- install -d ${D}/mnt/.psplash/
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
-}
-
-INITSCRIPT_NAME = "psplash.sh"
-INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."